]> git.pld-linux.org Git - packages/scapy.git/blob - scapy.spec
- missing Source0-md5
[packages/scapy.git] / scapy.spec
1 # TODO:
2 # - package and add Suggests:
3 # * Vpython (http://www.vpython.org/)
4
5 %define _hg_rev 834b9f8a3c23
6 Summary:        Interactive packet manipulation program.
7 Summary(pl.UTF-8):      Interaktywny program do manipulacji pakietami.
8 Name:           scapy
9 Version:        2.0.1
10 Release:        2
11 License:        GPL
12 Group:          Applications/Networking
13 Source0:        http://hg.secdev.org/scapy/archive/%{_hg_rev}.tar.bz2
14 # Source0-md5:  7356de9660216844ad6ae60ef8febf23
15 URL:            http://www.secdev.org/projects/scapy/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  sphinx-pdg
18 Requires:       python-libdnet
19 Requires:       python-pylibpcap
20 Suggests:       python-pyx
21 Suggests:       texlive
22 Suggests:       texlive-fonts-type1-bluesky
23 Suggests:       graphviz-python
24 Suggests:       python-crypto
25 Suggests:       sox
26 Suggests:       python-gnuplot
27
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Scapy is a powerful interactive packet manipulation program. It is
32 able to forge or decode packets of a wide number of protocols, send
33 them on the wire, capture them, match requests and replies, and much
34 more. It can easily handle most classical tasks like scanning,
35 tracerouting, probing, unit tests, attacks or network discovery (it
36 can replace hping, 85% of nmap, arpspoof, arp-sk, arping, tcpdump,
37 tethereal, p0f, etc.). It also performs very well at a lot of other
38 specific tasks that most other tools can't handle, like sending
39 invalid frames, injecting your own 802.11 frames, combining technics
40 (VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted
41 channel, ...), etc.
42
43 %description -l pl.UTF-8
44 Scapy jest interaktywnym programem służacym do manipulacji pakietami
45 o olbrzymich możliwościach. Potrafi tworzyć i dekodować pakiety
46 sporej ilości protokołów, przesyłać je, przechwytywac je,
47 dopasowywać żądania i odpowiedzi i wiele więcej. Z łatwością
48 obsługuje typowe zadania takie jak skanowanie, śledzenie trasy,
49 sondowanie, testy jednostkowe, ataki czy też wykrywanie (usług w)
50 sieci (może zastapić hping, 85% nmapa, arpspoof, arp-sk, arping,
51 tcpdump, tethereal, p0f itp.). Radzi sobie rownież z innymi
52 specyficznymi zadaniami, którym inne narzedzia nie są w stanie
53 podołać - wysyłanie nieprawidlowych ramek, wstrzykiwanie własnych
54 ramek 802.11, łączenie technik (przeskakiwanie VLANów+zatruwanie
55 ARP cache, dekodowanie VIOP na kanale zabezpieczonym WEP, ...) itp.
56
57 %prep
58 %setup -q -n %{name}-%{_hg_rev}
59
60 %build
61 %{__python} setup.py build
62 cd doc/scapy
63 make html
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__python} setup.py install \
69         --root=$RPM_BUILD_ROOT \
70         --optimize=2
71
72 rm -Rf $RPM_BUILD_ROOT/%{py_sitescriptdir}/%{name}/*.py
73 rm -Rf $RPM_BUILD_ROOT/%{py_sitescriptdir}/%{name}/arch/*.py
74 rm -Rf $RPM_BUILD_ROOT/%{py_sitescriptdir}/%{name}/asn1/*.py
75 rm -Rf $RPM_BUILD_ROOT/%{py_sitescriptdir}/%{name}/layers/*.py
76 rm -Rf $RPM_BUILD_ROOT/%{py_sitescriptdir}/%{name}/modules/*.py
77 rm -Rf $RPM_BUILD_ROOT/%{py_sitescriptdir}/%{name}/tools/*.py
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc doc/scapy/_build/html/*
85 #%doc doc/scapy/_build/html/_static/*
86 #%doc doc/scapy/_build/html/_images/*
87 #%doc doc/scapy/_build/html/_sources/*.txt
88 %attr(755,root,root) %{_bindir}/*
89 %{py_sitescriptdir}/*.egg-info
90 %dir %{py_sitescriptdir}/%{name}
91 %dir %{py_sitescriptdir}/%{name}/arch
92 %dir %{py_sitescriptdir}/%{name}/asn1
93 %dir %{py_sitescriptdir}/%{name}/layers
94 %dir %{py_sitescriptdir}/%{name}/modules
95 %dir %{py_sitescriptdir}/%{name}/tools
96 %{py_sitescriptdir}/%{name}/*.py[co]
97 %{py_sitescriptdir}/%{name}/arch/*.py[co]
98 %{py_sitescriptdir}/%{name}/asn1/*.py[co]
99 %{py_sitescriptdir}/%{name}/layers/*.py[co]
100 %{py_sitescriptdir}/%{name}/modules/*.py[co]
101 %{py_sitescriptdir}/%{name}/tools/*.py[co]
102 %{_mandir}/man1/%{name}.1.gz
This page took 0.058834 seconds and 4 git commands to generate.