]> git.pld-linux.org Git - packages/rust.git/commitdiff
up to 1.47.0
authorJan Palus <atler@pld-linux.org>
Tue, 13 Oct 2020 12:11:57 +0000 (14:11 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 13 Oct 2020 12:11:57 +0000 (14:11 +0200)
- miri built despite stable channel

rust-no-miri.patch [deleted file]
rust.spec

diff --git a/rust-no-miri.patch b/rust-no-miri.patch
deleted file mode 100644 (file)
index ad90523..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-(rebased to 1.44.1)
-From 416b010f4087d055febe2d55919f74e261ca8cd6 Mon Sep 17 00:00:00 2001
-From: Ralf Jung <post@ralfj.de>
-Date: Thu, 11 Jun 2020 09:25:06 +0200
-Subject: [PATCH] x.py: do not build Miri by default
-
----
- src/bootstrap/builder.rs |  2 ++
- src/bootstrap/tool.rs    | 30 ++++++++++++++++++------------
- 2 files changed, 20 insertions(+), 12 deletions(-)
-
-diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index ffdd8485181f4..c4f29927cf4a8 100644
---- a/src/bootstrap/builder.rs
-+++ b/src/bootstrap/builder.rs
-@@ -52,6 +52,8 @@ pub trait Step: 'static + Clone + Debug + PartialEq + Eq + Hash {
-     /// it's been assembled.
-     type Output: Clone;
-+    /// Whether this step is run by default as part of its respective phase.
-+    /// `true` here can still be overwritten by `should_run` calling `default_condition`.
-     const DEFAULT: bool = false;
-     /// If true, then this rule should be skipped if --target was specified, but --host was not
-diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
-index 6cd9f9029c948..9c95de0a81eae 100644
---- a/src/bootstrap/tool.rs
-+++ b/src/bootstrap/tool.rs
-@@ -591,6 +591,7 @@ macro_rules! tool_extended {
-        $toolstate:ident,
-        $path:expr,
-        $tool_name:expr,
-+       stable = $stable:expr,
-        $extra_deps:block;)+) => {
-         $(
-             #[derive(Debug, Clone, Hash, PartialEq, Eq)]
-@@ -602,17 +603,22 @@ macro_rules! tool_extended {
-         impl Step for $name {
-             type Output = Option<PathBuf>;
--            const DEFAULT: bool = true;
-+            const DEFAULT: bool = true; // Overwritten below
-             const ONLY_HOSTS: bool = true;
-             fn should_run(run: ShouldRun<'_>) -> ShouldRun<'_> {
-                 let builder = run.builder;
-                 run.path($path).default_condition(
-                     builder.config.extended
--                        && builder.config.tools.as_ref().map_or(true, |tools| {
--                            tools.iter().any(|tool| match tool.as_ref() {
--                                "clippy" => $tool_name == "clippy-driver",
--                                x => $tool_name == x,
-+                        && builder.config.tools.as_ref().map_or(
-+                            // By default, on nightly/dev enable all tools, else only
-+                            // build stable tools.
-+                            $stable || builder.build.unstable_features(),
-+                            // If `tools` is set, search list for this tool.
-+                            |tools| {
-+                                tools.iter().any(|tool| match tool.as_ref() {
-+                                    "clippy" => $tool_name == "clippy-driver",
-+                                    x => $tool_name == x,
-                             })
-                         }),
-                 )
-@@ -646,12 +652,12 @@ macro_rules! tool_extended {
- }
- tool_extended!((self, builder),
--    Cargofmt, rustfmt, "src/tools/rustfmt", "cargo-fmt", {};
--    CargoClippy, clippy, "src/tools/clippy", "cargo-clippy", {};
--    Clippy, clippy, "src/tools/clippy", "clippy-driver", {};
--    Miri, miri, "src/tools/miri", "miri", {};
--    CargoMiri, miri, "src/tools/miri", "cargo-miri", {};
--    Rls, rls, "src/tools/rls", "rls", {
-+    Cargofmt, rustfmt, "src/tools/rustfmt", "cargo-fmt", stable=true, {};
-+    CargoClippy, clippy, "src/tools/clippy", "cargo-clippy", stable=true, {};
-+    Clippy, clippy, "src/tools/clippy", "clippy-driver", stable=true, {};
-+    Miri, miri, "src/tools/miri", "miri", stable=false, {};
-+    CargoMiri, miri, "src/tools/miri", "cargo-miri", stable=false, {};
-+    Rls, rls, "src/tools/rls", "rls", stable=true, {
-         let clippy = builder.ensure(Clippy {
-             compiler: self.compiler,
-             target: self.target,
-@@ -661,7 +667,7 @@ tool_extended!((self, builder),
-             self.extra_features.push("clippy".to_owned());
-         }
-     };
--    Rustfmt, rustfmt, "src/tools/rustfmt", "rustfmt", {};
-+    Rustfmt, rustfmt, "src/tools/rustfmt", "rustfmt", stable=true, {};
- );
- impl<'a> Builder<'a> {
index 760bfcd44aed0710370f1ece6353b77db3e73392..ce7f94baf9f5a14869d770acbe3371665f2d6c69 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -21,9 +21,9 @@
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.43.1
-%define                bootstrap_cargo 1.43.1
-%define                bootstrap_date  2020-05-07
+%define                bootstrap_rust  1.46.0
+%define                bootstrap_cargo 1.46.0
+%define                bootstrap_date  2020-08-27
 
 %ifarch x32
 %define                with_cross      1
 
 %ifarch x32
 %define                with_cross      1
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.44.1
-Release:       2
+Version:       1.47.0
+Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: 0cc3b079ddb1eb9a17f9e7e52efcebc5
+# Source0-md5: 6283a61cac54bb0a7d32bc447d07fadc
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 62b0974a4bad5aeabd50c7a7fa74518c
+# Source1-md5: 45eaf35327db0bac923c65048637a2f5
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: 758d55172c8dddb1ec71913b5f532bb2
+# Source2-md5: 6a2422d81e98df5b71a959c70aa4c81b
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source3-md5: 3a9d54ab96f96664b2f6077cccb4e70b
-Patch0:                %{name}-no-miri.patch
-Patch1:                %{name}-x32.patch
+# Source3-md5: 144376df8b0ddfef57900b867746a9ab
+Patch0:                %{name}-x32.patch
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -58,7 +57,7 @@ BuildRequires:        rpmbuild(macros) >= 1.752
 BuildRequires: curl-devel
 BuildRequires: libgit2-devel
 BuildRequires: libstdc++-devel
 BuildRequires: curl-devel
 BuildRequires: libgit2-devel
 BuildRequires: libstdc++-devel
-%{?with_system_llvm:BuildRequires:     llvm-devel >= 7.0}
+%{?with_system_llvm:BuildRequires:     llvm-devel >= 8.0}
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: zlib-devel
 %endif
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: zlib-devel
 %endif
@@ -76,7 +75,7 @@ BuildRequires:        curl-devel
 BuildRequires: gcc-multilib-x32
 BuildRequires: libgit2-devel
 BuildRequires: libstdc++-devel
 BuildRequires: gcc-multilib-x32
 BuildRequires: libgit2-devel
 BuildRequires: libstdc++-devel
-%{?with_system_llvm:BuildRequires:     llvm-devel >= 7.0}
+%{?with_system_llvm:BuildRequires:     llvm-devel >= 8.0}
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: zlib-devel
 %else
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: zlib-devel
 %else
@@ -253,9 +252,8 @@ Dopełnianie parametrów polecenia cargo w powłoce Zsh.
 
 %prep
 %setup -q -n %{rustc_package}
 
 %prep
 %setup -q -n %{rustc_package}
-%patch0 -p1
 # irrelevant when not building rustc for x32
 # irrelevant when not building rustc for x32
-#patch1 -p1
+#patch0 -p1
 
 %if %{with bootstrap}
 %ifarch %{x8664} x32
 
 %if %{with bootstrap}
 %ifarch %{x8664} x32
@@ -282,8 +280,8 @@ test -f %{local_rust_root}/bin/rustc
 %{?with_system_llvm:%{__rm} -r src/llvm-project}
 
 # extract bundled licenses for packaging
 %{?with_system_llvm:%{__rm} -r src/llvm-project}
 
 # extract bundled licenses for packaging
-sed -e '/*\//q' vendor/backtrace-sys/src/libbacktrace/backtrace.h \
-       >vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
+sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
+       >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
 
 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
 
 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
@@ -383,14 +381,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
+%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
 %attr(755,root,root) %{_bindir}/rls
 %attr(755,root,root) %{_bindir}/rls
+%attr(755,root,root) %{_bindir}/rust-analyzer
 %attr(755,root,root) %{_bindir}/rustc
 %attr(755,root,root) %{_bindir}/rustdoc
 %attr(755,root,root) %{_bindir}/rustfmt
 %attr(755,root,root) %{_bindir}/rustc
 %attr(755,root,root) %{_bindir}/rustdoc
 %attr(755,root,root) %{_bindir}/rustfmt
+%attr(755,root,root) %{_libdir}/libchalk_derive-*.so
 %attr(755,root,root) %{_libdir}/librustc*-*.so
 %attr(755,root,root) %{_libdir}/libstd-*.so
 %attr(755,root,root) %{_libdir}/libtest-*.so
 %attr(755,root,root) %{_libdir}/librustc*-*.so
 %attr(755,root,root) %{_libdir}/libstd-*.so
 %attr(755,root,root) %{_libdir}/libtest-*.so
+%attr(755,root,root) %{_libdir}/libtracing_attributes-*.so
 %{_mandir}/man1/rustc.1*
 %{_mandir}/man1/rustdoc.1*
 %dir %{rustlibdir}
 %{_mandir}/man1/rustc.1*
 %{_mandir}/man1/rustdoc.1*
 %dir %{rustlibdir}
@@ -413,7 +414,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/etc
 %defattr(644,root,root,755)
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/etc
-%{_datadir}/%{name}/etc/debugger_*.py*
+%{_datadir}/%{name}/etc/lldb_commands
+%{_datadir}/%{name}/etc/rust_types.py
 
 %files lldb
 %defattr(644,root,root,755)
 
 %files lldb
 %defattr(644,root,root,755)
This page took 0.222707 seconds and 4 git commands to generate.