- updated to 4.8.2
authorBartek Szady <bszx@bszx.eu>
Sat, 30 Mar 2019 19:53:48 +0000 (20:53 +0100)
committerBartek Szady <bszx@bszx.eu>
Sat, 30 Mar 2019 19:53:48 +0000 (20:53 +0100)
qt-creator.spec

index 6a94c16303cbf16cef1659d3dbfc3dfc29850c66..e8900cc5514998426e7f7c430e498551631f744c 100644 (file)
@@ -1,33 +1,33 @@
 Summary:       An IDE tailored to the needs of Qt developers
 Summary(pl.UTF-8):     IDE dostosowane do potrzeb developerow Qt
 Name:          qt-creator
-Version:       4.6.0
-Release:       5
+Version:       4.8.2
+Release:       1
 Epoch:         1
 License:       LGPL v2.1
 Group:         X11/Development/Tools
-Source0:       http://download.qt.io/official_releases/qtcreator/4.6/%{version}/%{name}-opensource-src-%{version}.tar.xz
-# Source0-md5: 8aae7bc90f1973b86f6dd75d63dbaded
+Source0:       http://download.qt.io/official_releases/qtcreator/4.8/%{version}/%{name}-opensource-src-%{version}.tar.xz
+# Source0-md5: bf5b9953cfec44aa2504e30cb81768e6
 URL:           http://doc.qt.io/qt-5/topics-app-development.html
-BuildRequires: Qt5Concurrent-devel >= 5.6.0
-BuildRequires: Qt5Designer-devel >= 5.6.0
-BuildRequires: Qt5Gui-devel >= 5.6.0
-BuildRequires: Qt5Help-devel >= 5.6.0
-BuildRequires: Qt5Network-devel >= 5.6.0
-BuildRequires: Qt5Quick-controls >= 5.6.0
-BuildRequires: Qt5Quick-devel >= 5.6.0
-BuildRequires: Qt5Script-devel >= 5.6.0
-BuildRequires: Qt5Svg-devel >= 5.6.0
-BuildRequires: Qt5UiTools-devel >= 5.6.0
-BuildRequires: Qt5WebKit-devel >= 5.6.0
-BuildRequires: Qt5Xml-devel >= 5.6.0
-BuildRequires: clang-devel >= 3.9.0
+BuildRequires: Qt5Concurrent-devel >= 5.9.0
+BuildRequires: Qt5Designer-devel >= 5.9.0
+BuildRequires: Qt5Gui-devel >= 5.9.0
+BuildRequires: Qt5Help-devel >= 5.9.0
+BuildRequires: Qt5Network-devel >= 5.9.0
+BuildRequires: Qt5Quick-controls >= 5.9.0
+BuildRequires: Qt5Quick-devel >= 5.9.0
+BuildRequires: Qt5Script-devel >= 5.9.0
+BuildRequires: Qt5Svg-devel >= 5.9.0
+BuildRequires: Qt5UiTools-devel >= 5.9.0
+BuildRequires: Qt5WebKit-devel >= 5.9.0
+BuildRequires: Qt5Xml-devel >= 5.9.0
+BuildRequires: clang-devel >= 6.0.0
 BuildRequires: gdb
 BuildRequires: libstdc++-devel
-BuildRequires: llvm-devel >= 3.9.0
-BuildRequires: qt5-build >= 5.6.0
+BuildRequires: llvm-devel >= 6.0.0
+BuildRequires: qt5-build >= 5.9.0
 BuildRequires: qt5-linguist
-BuildRequires: qt5-qmake >= 5.6.0
+BuildRequires: qt5-qmake >= 5.9.0
 BuildRequires: rpmbuild(macros) >= 1.602
 Requires(post,postun): desktop-file-utils
 %requires_eq   Qt5Core
@@ -130,6 +130,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/qtcreator/plugins/qbs
 %dir %{_libdir}/qtcreator/plugins/qbs/plugins
 %attr(755,root,root) %{_libdir}/qtcreator/plugins/qbs/plugins/libclangcompilationdbgenerator.so
+%attr(755,root,root) %{_libdir}/qtcreator/plugins/qbs/plugins/libmakefilegenerator.so
 %attr(755,root,root) %{_libdir}/qtcreator/plugins/qbs/plugins/libqbs_cpp_scanner.so
 %attr(755,root,root) %{_libdir}/qtcreator/plugins/qbs/plugins/libqbs_qt_scanner.so
 %attr(755,root,root) %{_libdir}/qtcreator/plugins/qbs/plugins/libvisualstudiogenerator.so
This page took 0.62197 seconds and 4 git commands to generate.