]> git.pld-linux.org Git - packages/qt-creator.git/blame - qt-creator.spec
- up to 2.7.2
[packages/qt-creator.git] / qt-creator.spec
CommitLineData
2aefa737 1Summary: An IDE tailored to the needs of Qt developers
2Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
3Name: qt-creator
eedfdc85 4Version: 2.7.2
f0253cbd 5Release: 1
2aefa737 6Epoch: 1
7License: LGPL v2.1
0bdd3f4c 8Group: X11/Development/Tools
eedfdc85
JR
9Source0: http://download.qt-project.org/official_releases/qtcreator/2.7/%{version}/%{name}-%{version}-src.tar.gz
10# Source0-md5: 7f1c10740784d3edf2347c27be21fd1a
0bdd3f4c 11Source1: %{name}.desktop
2b26ffea 12Patch0: %{name}-pluginpath64.patch
e3112323 13URL: http://qt.digia.com/Product/Developer-Tools
a2bb26e4 14BuildRequires: QtDBus-devel
913e68eb 15BuildRequires: QtDeclarative-devel
99bec638 16BuildRequires: QtDesigner-devel
2aefa737 17BuildRequires: QtGui-devel
a2bb26e4
KK
18BuildRequires: QtHelp-devel
19BuildRequires: QtNetwork-devel
20BuildRequires: QtScript-devel
5eafeef8 21BuildRequires: QtSql-sqlite3
a2bb26e4
KK
22BuildRequires: QtSvg-devel
23BuildRequires: QtWebKit-devel
24BuildRequires: QtXml-devel
e3112323 25BuildRequires: qt4-build >= 4.8.0
4208b10d 26BuildRequires: qt4-linguist
e3112323 27BuildRequires: qt4-qmake >= 4.8.0
333344fa 28BuildRequires: rpmbuild(macros) >= 1.602
0bdd3f4c 29Requires(post,postun): desktop-file-utils
4208b10d 30%requires_eq QtCore
1f8887fa 31Requires: QtSql-sqlite3
333344fa 32Requires: hicolor-icon-theme
0bdd3f4c
MB
33# for xdg-open
34Suggests: xdg-utils
2aefa737 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
913e68eb 38Qt Creator is a cross-platform integrated development environment (IDE)
2aefa737 39tailored to the needs of Qt developers.
40
41%description -l pl.UTF-8
42Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
43
44%prep
8fd6a200 45%setup -q -n %{name}-%{version}-src
2aefa737 46
2b26ffea 47%if "%{_lib}" == "lib64"
48%patch0 -p1
49%endif
50
e3112323
KK
51# fix unresolved symbols in libQtcSsh
52echo "LIBS += -ldl" > src/libs/ssh/ssh_dependencies.pri
53
2aefa737 54%build
55export QTDIR=%{_libdir}/qt4
56# the qmakespec in qt4 is somewhat broken, need to look at this
57#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
58
59qmake-qt4 qtcreator.pro \
60 QMAKE_CXX="%{__cxx}" \
61 QMAKE_LINK="%{__cxx}" \
62 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
913e68eb 63 QMAKE_RPATH=
2aefa737 64
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
0bdd3f4c 69install -d $RPM_BUILD_ROOT%{_desktopdir}
2aefa737 70
71export QTDIR=%{_libdir}/qt4
2aefa737 72%{__make} install \
08788771 73 INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
2aefa737 74
5eafeef8 75%if "%{_lib}" == "lib64"
08788771 76mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
5eafeef8 77%endif
2aefa737 78
08788771
KK
79install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
80echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2b26ffea 81
0bdd3f4c
MB
82install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
83
5549a3e0
MB
84# not supported by hicolor-icon-theme
85rm -rf $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512
86
2aefa737 87%clean
88rm -rf $RPM_BUILD_ROOT
89
0bdd3f4c
MB
90%post
91/sbin/ldconfig
92%update_desktop_database
333344fa 93%update_icon_cache hicolor
0bdd3f4c
MB
94
95%postun
96/sbin/ldconfig
97%update_desktop_database_postun
333344fa 98%update_icon_cache hicolor
0bdd3f4c 99
2aefa737 100%files
101%defattr(644,root,root,755)
4208b10d
KK
102%attr(755,root,root) %{_bindir}/qtcreator
103%attr(755,root,root) %{_bindir}/qtcreator_process_stub
d715c69d 104%attr(755,root,root) %{_bindir}/qtpromaker
e3112323 105%attr(755,root,root) %{_bindir}/sdktool
2b26ffea 106%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2aefa737 107%dir %{_libdir}/qtcreator
2b26ffea 108%attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
109%attr(755,root,root) %{_libdir}/qtcreator/lib*.so
5eafeef8 110%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
2aefa737 111%dir %{_libdir}/qtcreator/plugins
36cf551a 112%dir %{_libdir}/qtcreator/plugins/BlackBerry
e3112323 113%dir %{_libdir}/qtcreator/plugins/QtProject
36cf551a 114%{_libdir}/qtcreator/plugins/BlackBerry/*.pluginspec
e3112323 115%{_libdir}/qtcreator/plugins/QtProject/*.pluginspec
36cf551a 116%attr(755,root,root) %{_libdir}/qtcreator/plugins/BlackBerry/*.so
e3112323 117%attr(755,root,root) %{_libdir}/qtcreator/plugins/QtProject/*.so
e2bdaf8d 118%{_libdir}/qtcreator/qtcomponents
2aefa737 119%{_datadir}/qtcreator
0bdd3f4c 120%{_desktopdir}/qt-creator.desktop
333344fa 121%{_iconsdir}/hicolor/*/*/*.png
This page took 0.064106 seconds and 4 git commands to generate.