]> git.pld-linux.org Git - packages/qt-creator.git/blame - qt-creator.spec
- up to 3.4.1
[packages/qt-creator.git] / qt-creator.spec
CommitLineData
2aefa737 1Summary: An IDE tailored to the needs of Qt developers
2Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
3Name: qt-creator
78e69ec7 4Version: 3.4.1
f0253cbd 5Release: 1
2aefa737 6Epoch: 1
7License: LGPL v2.1
0bdd3f4c 8Group: X11/Development/Tools
78e69ec7
JR
9Source0: http://download.qt-project.org/official_releases/qtcreator/3.4/%{version}/%{name}-opensource-src-%{version}.tar.gz
10# Source0-md5: bcbae4a567c93158babe3b7f42d01219
0bdd3f4c 11Source1: %{name}.desktop
2b26ffea 12Patch0: %{name}-pluginpath64.patch
e3112323 13URL: http://qt.digia.com/Product/Developer-Tools
913e68eb 14BuildRequires: QtDeclarative-devel
99bec638 15BuildRequires: QtDesigner-devel
2aefa737 16BuildRequires: QtGui-devel
a2bb26e4
KK
17BuildRequires: QtHelp-devel
18BuildRequires: QtNetwork-devel
19BuildRequires: QtScript-devel
a2bb26e4
KK
20BuildRequires: QtSvg-devel
21BuildRequires: QtWebKit-devel
22BuildRequires: QtXml-devel
ed875dd6 23BuildRequires: gdb
e3112323 24BuildRequires: qt4-build >= 4.8.0
4208b10d 25BuildRequires: qt4-linguist
e3112323 26BuildRequires: qt4-qmake >= 4.8.0
ed875dd6 27BuildRequires: rpm-pythonprov
333344fa 28BuildRequires: rpmbuild(macros) >= 1.602
0bdd3f4c 29Requires(post,postun): desktop-file-utils
4208b10d 30%requires_eq QtCore
1f8887fa 31Requires: QtSql-sqlite3
333344fa 32Requires: hicolor-icon-theme
0bdd3f4c
MB
33# for xdg-open
34Suggests: xdg-utils
2aefa737 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
ed875dd6
ER
38Qt Creator is a cross-platform integrated development environment
39(IDE) tailored to the needs of Qt developers.
2aefa737 40
41%description -l pl.UTF-8
ed875dd6
ER
42Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow
43Qt.
2aefa737 44
45%prep
78e69ec7 46%setup -q -n %{name}-opensource-src-%{version}
2aefa737 47
2b26ffea 48%if "%{_lib}" == "lib64"
49%patch0 -p1
50%endif
51
e3112323
KK
52# fix unresolved symbols in libQtcSsh
53echo "LIBS += -ldl" > src/libs/ssh/ssh_dependencies.pri
54
2aefa737 55%build
56export QTDIR=%{_libdir}/qt4
57# the qmakespec in qt4 is somewhat broken, need to look at this
58#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
59
60qmake-qt4 qtcreator.pro \
61 QMAKE_CXX="%{__cxx}" \
62 QMAKE_LINK="%{__cxx}" \
63 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
913e68eb 64 QMAKE_RPATH=
2aefa737 65
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
0bdd3f4c 70install -d $RPM_BUILD_ROOT%{_desktopdir}
2aefa737 71
72export QTDIR=%{_libdir}/qt4
2aefa737 73%{__make} install \
08788771 74 INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
2aefa737 75
5eafeef8 76%if "%{_lib}" == "lib64"
08788771 77mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
5eafeef8 78%endif
2aefa737 79
08788771
KK
80install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
81echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2b26ffea 82
0bdd3f4c
MB
83install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
84
5549a3e0
MB
85# not supported by hicolor-icon-theme
86rm -rf $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512
87
2aefa737 88%clean
89rm -rf $RPM_BUILD_ROOT
90
0bdd3f4c
MB
91%post
92/sbin/ldconfig
93%update_desktop_database
333344fa 94%update_icon_cache hicolor
0bdd3f4c
MB
95
96%postun
97/sbin/ldconfig
98%update_desktop_database_postun
333344fa 99%update_icon_cache hicolor
0bdd3f4c 100
2aefa737 101%files
102%defattr(644,root,root,755)
4208b10d
KK
103%attr(755,root,root) %{_bindir}/qtcreator
104%attr(755,root,root) %{_bindir}/qtcreator_process_stub
d715c69d 105%attr(755,root,root) %{_bindir}/qtpromaker
e3112323 106%attr(755,root,root) %{_bindir}/sdktool
2b26ffea 107%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2aefa737 108%dir %{_libdir}/qtcreator
2b26ffea 109%attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
110%attr(755,root,root) %{_libdir}/qtcreator/lib*.so
5eafeef8 111%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
2aefa737 112%dir %{_libdir}/qtcreator/plugins
36cf551a 113%dir %{_libdir}/qtcreator/plugins/BlackBerry
e3112323 114%dir %{_libdir}/qtcreator/plugins/QtProject
36cf551a 115%{_libdir}/qtcreator/plugins/BlackBerry/*.pluginspec
e3112323 116%{_libdir}/qtcreator/plugins/QtProject/*.pluginspec
36cf551a 117%attr(755,root,root) %{_libdir}/qtcreator/plugins/BlackBerry/*.so
e3112323 118%attr(755,root,root) %{_libdir}/qtcreator/plugins/QtProject/*.so
e2bdaf8d 119%{_libdir}/qtcreator/qtcomponents
2aefa737 120%{_datadir}/qtcreator
0bdd3f4c 121%{_desktopdir}/qt-creator.desktop
333344fa 122%{_iconsdir}/hicolor/*/*/*.png
This page took 0.084285 seconds and 4 git commands to generate.