]> git.pld-linux.org Git - packages/qqwing.git/blob - qqwing.spec
- release 2 (C++ rebuild)
[packages/qqwing.git] / qqwing.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Command-line Sudoku solver and generator
6 Summary(pl.UTF-8):      Uruchamiany z linii poleceń program do rozwiązywania i generowania Sudoku
7 Name:           qqwing
8 Version:        1.3.4
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/Games
12 #Source0Download: http://qqwing.com/download.html
13 Source0:        http://qqwing.com/%{name}-%{version}.tar.gz
14 # Source0-md5:  249dcfa8a1ca2d5cec5a81bcdbd017eb
15 URL:            http://qqwing.com/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:2.2
20 Requires:       %{name}-libs = %{version}-%{release}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 QQwing is a command-line Sudoku puzzles solver and generator.
25
26 %description -l pl.UTF-8
27 QQwing to uruchamiany z linii poleceń program do rozwiązywania i
28 generowania łamigłówek Sudoku.
29
30 %package libs
31 Summary:        Library for Sudoku solving and generation
32 Summary(pl.UTF-8):      Biblioteka do rozwiązywania i generowania Sudoku
33 Group:          Libraries
34
35 %description libs
36 libqqwing is a C++ library for solving and generating Sudoku puzzles.
37
38 %description libs -l pl.UTF-8
39 libqqwing to biblioteka C++ do rozwiązywania i generowania łamigłówek
40 Sudoku.
41
42 %package devel
43 Summary:        Header files for qqwing library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki qqwing
45 Group:          Development/Libraries
46 Requires:       %{name}-libs = %{version}-%{release}
47 Requires:       libstdc++-devel
48
49 %description devel
50 Header files for qqwing library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki qqwing.
54
55 %package static
56 Summary:        Static qqwing library
57 Summary(pl.UTF-8):      Statyczna biblioteka qqwing
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static qqwing library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka qqwing.
66
67 %prep
68 %setup -q
69
70 %build
71 %{__libtoolize}
72 %{__aclocal} -I m4
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 %configure \
77         %{?with_static_libs:--enable-static}
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   libs -p /sbin/ldconfig
92 %postun libs -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS README
97 %attr(755,root,root) %{_bindir}/qqwing
98 %{_mandir}/man1/qqwing.1*
99
100 %files libs
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libqqwing.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libqqwing.so.2
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libqqwing.so
108 %{_includedir}/qqwing.hpp
109 %{_pkgconfigdir}/qqwing.pc
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libqqwing.a
115 %endif
This page took 0.121892 seconds and 4 git commands to generate.