]> git.pld-linux.org Git - packages/python3.git/commitdiff
- rel 2; rediff patches auto/th/python3-3.9.2-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 25 Feb 2021 17:42:54 +0000 (18:42 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 25 Feb 2021 17:42:54 +0000 (18:42 +0100)
python3-install_prefix.patch
python3-installcompile.patch
python3-makefile-location.patch
python3-multilib.patch
python3-no_cmdline_tests.patch
python3-tests.patch
python3-tests_with_pythonpath.patch
python3.spec

index a643c0801cdaf63bca8ca5b3bc4c5e91e748712c..54cafeac21026b98ed0aef739d5d28d69732c712 100644 (file)
@@ -1,7 +1,7 @@
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/command/install.py Python-3.5.0/Lib/distutils/command/install.py
---- Python-3.5.0.orig/Lib/distutils/command/install.py 2015-11-25 17:54:32.000000000 +0100
-+++ Python-3.5.0/Lib/distutils/command/install.py      2015-11-25 18:06:33.876268151 +0100
-@@ -9,6 +9,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/command/install.py Python-3.9.2/Lib/distutils/command/install.py
+--- Python-3.9.2.org/Lib/distutils/command/install.py  2021-02-25 18:41:13.921266287 +0100
++++ Python-3.9.2/Lib/distutils/command/install.py      2021-02-25 18:41:15.634652993 +0100
+@@ -9,6 +9,7 @@ from distutils import log
  from distutils.core import Command
  from distutils.debug import DEBUG
  from distutils.sysconfig import get_config_vars
@@ -9,7 +9,7 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/command/install.py
  from distutils.errors import DistutilsPlatformError
  from distutils.file_util import write_file
  from distutils.util import convert_path, subst_vars, change_root
-@@ -418,8 +419,8 @@
+@@ -419,8 +420,8 @@ class install(Command):
                      raise DistutilsOptionError(
                            "must not supply exec-prefix without prefix")
  
@@ -20,12 +20,10 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/command/install.py
  
              else:
                  if self.exec_prefix is None:
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/sysconfig.py Python-3.5.0/Lib/distutils/sysconfig.py
---- Python-3.5.0.orig/Lib/distutils/sysconfig.py       2015-11-25 17:54:32.000000000 +0100
-+++ Python-3.5.0/Lib/distutils/sysconfig.py    2015-11-25 18:03:39.338573134 +0100
-@@ -17,8 +17,12 @@
- from .errors import DistutilsPlatformError
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/sysconfig.py Python-3.9.2/Lib/distutils/sysconfig.py
+--- Python-3.9.2.org/Lib/distutils/sysconfig.py        2021-02-25 18:41:13.927933162 +0100
++++ Python-3.9.2/Lib/distutils/sysconfig.py    2021-02-25 18:41:15.634652993 +0100
+@@ -19,6 +19,10 @@ from .errors import DistutilsPlatformErr
  # These are needed in a couple of spots, so just compute them once.
  PREFIX = os.path.normpath(sys.prefix)
  EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
@@ -36,11 +34,11 @@ diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/distutils/sysconfig.py Pytho
  BASE_PREFIX = os.path.normpath(sys.base_prefix)
  BASE_EXEC_PREFIX = os.path.normpath(sys.base_exec_prefix)
  
-diff -dur -x '*~' -x '*.orig' Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/site.py
---- Python-3.5.0.orig/Lib/site.py      2015-11-25 17:54:32.000000000 +0100
-+++ Python-3.5.0/Lib/site.py   2015-11-25 17:56:39.979513073 +0100
-@@ -74,7 +74,7 @@
- import _sitebuiltins
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/site.py Python-3.9.2/Lib/site.py
+--- Python-3.9.2.org/Lib/site.py       2021-02-25 18:41:13.924599724 +0100
++++ Python-3.9.2/Lib/site.py   2021-02-25 18:41:15.634652993 +0100
+@@ -76,7 +76,7 @@ import _sitebuiltins
+ import io
  
  # Prefixes for site-packages; add additional prefixes like /usr/local here
 -PREFIXES = [sys.prefix, sys.exec_prefix]
index dd9268e08e2e4f0034860ead2c7510705de6841b..82c914e573bb85ddcc7810cc4252c43d9e100a0d 100644 (file)
@@ -1,15 +1,16 @@
---- Python-3.5.0/Makefile.pre.in.orig  2016-02-28 20:07:09.864711963 +0100
-+++ Python-3.5.0/Makefile.pre.in       2016-02-28 20:10:18.334704006 +0100
-@@ -1029,7 +1029,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Makefile.pre.in Python-3.9.2/Makefile.pre.in
+--- Python-3.9.2.org/Makefile.pre.in   2021-02-25 18:42:02.242771533 +0100
++++ Python-3.9.2/Makefile.pre.in       2021-02-25 18:42:03.919490432 +0100
+@@ -1262,7 +1262,7 @@ altinstall: commoninstall
  
- commoninstall:  @FRAMEWORKALTINSTALLFIRST@ \
+ commoninstall:  check-clean-src @FRAMEWORKALTINSTALLFIRST@ \
                altbininstall libinstall inclinstall libainstall \
 -              sharedinstall oldsharedinstall altmaninstall \
 +              sharedinstall oldsharedinstall altmaninstall installcompile \
                @FRAMEWORKALTINSTALLLAST@
  
  # Install shared libraries enabled by Setup
-@@ -1262,6 +1262,8 @@
+@@ -1530,6 +1530,8 @@ libinstall:      build_all $(srcdir)/Modules/
                $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
                        $(DESTDIR)$(LIBDEST)/distutils/tests ; \
        fi
@@ -17,8 +18,8 @@
 +installcompile: libainstall libinstall
        -PYTHONPATH=$(DESTDIR)$(LIBDEST)  $(RUNSHARED) \
                $(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
-               -d $(LIBDEST) -f \
-@@ -1939,7 +1939,7 @@ Python/thread.o: @THREADHEADERS@ $(srcdi
+               -j0 -d $(LIBDEST) -f \
+@@ -1938,7 +1940,7 @@ Python/thread.o: @THREADHEADERS@ $(srcdi
  .PHONY: frameworkinstall frameworkinstallframework frameworkinstallstructure
  .PHONY: frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools
  .PHONY: frameworkaltinstallunixtools recheck clean clobber distclean
@@ -27,4 +28,3 @@
  .PHONY: clean-retain-profile profile-removal run_profile_task
  .PHONY: build_all_generate_profile build_all_merge_profile
  .PHONY: gdbhooks
-
index 912e4cdb0d99b2d5f9d82deecb548c933c7bc065..2dbb571ad8ff7af21b7e2ed2b0feb54fcf8c6984 100644 (file)
@@ -1,12 +1,12 @@
-diff -Nur Python-3.3.1.orig/Lib/distutils/sysconfig.py Python-3.3.1/Lib/distutils/sysconfig.py
---- Python-3.3.1.orig/Lib/distutils/sysconfig.py       2013-04-06 08:41:35.000000000 +0100
-+++ Python-3.3.1/Lib/distutils/sysconfig.py    2013-04-07 19:45:29.409178359 +0100
-@@ -256,7 +256,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/sysconfig.py Python-3.9.2/Lib/distutils/sysconfig.py
+--- Python-3.9.2.org/Lib/distutils/sysconfig.py        2021-02-25 18:40:49.900518043 +0100
++++ Python-3.9.2/Lib/distutils/sysconfig.py    2021-02-25 18:40:51.570570064 +0100
+@@ -260,7 +260,7 @@ def get_makefile_filename():
      """Return full pathname of installed Makefile from the Python build."""
      if python_build:
          return os.path.join(_sys_home or project_base, "Makefile")
 -    lib_dir = get_python_lib(plat_specific=0, standard_lib=1)
 +    lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
      config_file = 'config-{}{}'.format(get_python_version(), build_flags)
-     return os.path.join(lib_dir, config_file, 'Makefile')
+     if hasattr(sys.implementation, '_multiarch'):
+         config_file += '-%s' % sys.implementation._multiarch
index 9863ccb8c9b6ed0c89682357427e4d633e54e51c..f27da6f2677960c7b9731c767ce94455da6d8e12 100644 (file)
@@ -1,7 +1,7 @@
-diff -urNp Python-3.8.7.org/Lib/distutils/command/install.py Python-3.8.7/Lib/distutils/command/install.py
---- Python-3.8.7.org/Lib/distutils/command/install.py  2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/Lib/distutils/command/install.py      2021-02-06 00:56:02.718897271 +0100
-@@ -31,14 +31,14 @@ WINDOWS_SCHEME = {
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/command/install.py Python-3.9.2/Lib/distutils/command/install.py
+--- Python-3.9.2.org/Lib/distutils/command/install.py  2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/distutils/command/install.py      2021-02-25 18:40:00.705652346 +0100
+@@ -29,14 +29,14 @@ WINDOWS_SCHEME = {
  
  INSTALL_SCHEMES = {
      'unix_prefix': {
@@ -18,9 +18,9 @@ diff -urNp Python-3.8.7.org/Lib/distutils/command/install.py Python-3.8.7/Lib/di
          'platlib': '$base/$platlibdir/python',
          'headers': '$base/include/python/$dist_name',
          'scripts': '$base/bin',
-diff -urNp Python-3.8.7.org/Lib/distutils/sysconfig.py Python-3.8.7/Lib/distutils/sysconfig.py
---- Python-3.8.7.org/Lib/distutils/sysconfig.py        2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/Lib/distutils/sysconfig.py    2021-02-06 00:56:02.718897271 +0100
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/sysconfig.py Python-3.9.2/Lib/distutils/sysconfig.py
+--- Python-3.9.2.org/Lib/distutils/sysconfig.py        2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/distutils/sysconfig.py    2021-02-25 18:40:00.705652346 +0100
 @@ -145,13 +145,13 @@ def get_python_lib(plat_specific=0, stan
              prefix = plat_specific and EXEC_PREFIX or PREFIX
  
@@ -37,9 +37,9 @@ diff -urNp Python-3.8.7.org/Lib/distutils/sysconfig.py Python-3.8.7/Lib/distutil
          libpython = os.path.join(prefix, libdir,
                                   "python" + get_python_version())
          if standard_lib:
-diff -urNp Python-3.8.7.org/Lib/distutils/tests/test_install.py Python-3.8.7/Lib/distutils/tests/test_install.py
---- Python-3.8.7.org/Lib/distutils/tests/test_install.py       2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/Lib/distutils/tests/test_install.py   2021-02-06 00:56:02.722230710 +0100
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/distutils/tests/test_install.py Python-3.9.2/Lib/distutils/tests/test_install.py
+--- Python-3.9.2.org/Lib/distutils/tests/test_install.py       2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/distutils/tests/test_install.py   2021-02-25 18:40:00.705652346 +0100
 @@ -56,7 +56,7 @@ class InstallTestCase(support.TempdirMan
              expected = os.path.normpath(expected)
              self.assertEqual(got, expected)
@@ -47,11 +47,11 @@ diff -urNp Python-3.8.7.org/Lib/distutils/tests/test_install.py Python-3.8.7/Lib
 -        libdir = os.path.join(destination, "lib", "python")
 +        libdir = os.path.join(destination, sys.platlibdir, "python")
          check_path(cmd.install_lib, libdir)
-         check_path(cmd.install_platlib, libdir)
-         check_path(cmd.install_purelib, libdir)
-diff -urNp Python-3.8.7.org/Lib/site.py Python-3.8.7/Lib/site.py
---- Python-3.8.7.org/Lib/site.py       2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/Lib/site.py   2021-02-06 00:56:02.722230710 +0100
+         platlibdir = os.path.join(destination, sys.platlibdir, "python")
+         check_path(cmd.install_platlib, platlibdir)
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/site.py Python-3.9.2/Lib/site.py
+--- Python-3.9.2.org/Lib/site.py       2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/site.py   2021-02-25 18:40:00.705652346 +0100
 @@ -344,6 +344,8 @@ def getsitepackages(prefixes=None):
                                      "python%d.%d" % sys.version_info[:2],
                                      "site-packages")
@@ -61,10 +61,10 @@ diff -urNp Python-3.8.7.org/Lib/site.py Python-3.8.7/Lib/site.py
          else:
              sitepackages.append(prefix)
  
-diff -urNp Python-3.8.7.org/Lib/sysconfig.py Python-3.8.7/Lib/sysconfig.py
---- Python-3.8.7.org/Lib/sysconfig.py  2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/Lib/sysconfig.py      2021-02-06 00:56:02.722230710 +0100
-@@ -22,7 +22,7 @@ _INSTALL_SCHEMES = {
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/sysconfig.py Python-3.9.2/Lib/sysconfig.py
+--- Python-3.9.2.org/Lib/sysconfig.py  2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/sysconfig.py      2021-02-25 18:40:00.705652346 +0100
+@@ -27,7 +27,7 @@ _INSTALL_SCHEMES = {
      'posix_prefix': {
          'stdlib': '{installed_base}/{platlibdir}/python{py_version_short}',
          'platstdlib': '{platbase}/{platlibdir}/python{py_version_short}',
@@ -73,7 +73,7 @@ diff -urNp Python-3.8.7.org/Lib/sysconfig.py Python-3.8.7/Lib/sysconfig.py
          'platlib': '{platbase}/{platlibdir}/python{py_version_short}/site-packages',
          'include':
              '{installed_base}/include/python{py_version_short}{abiflags}',
-@@ -32,10 +32,10 @@ _INSTALL_SCHEMES = {
+@@ -37,10 +37,10 @@ _INSTALL_SCHEMES = {
          'data': '{base}',
          },
      'posix_home': {
@@ -88,7 +88,7 @@ diff -urNp Python-3.8.7.org/Lib/sysconfig.py Python-3.8.7/Lib/sysconfig.py
          'include': '{installed_base}/include/python',
          'platinclude': '{installed_base}/include/python',
          'scripts': '{base}/bin',
-@@ -64,7 +64,7 @@ _INSTALL_SCHEMES = {
+@@ -69,7 +69,7 @@ _INSTALL_SCHEMES = {
      'posix_user': {
          'stdlib': '{userbase}/{platlibdir}/python{py_version_short}',
          'platstdlib': '{userbase}/{platlibdir}/python{py_version_short}',
@@ -97,7 +97,7 @@ diff -urNp Python-3.8.7.org/Lib/sysconfig.py Python-3.8.7/Lib/sysconfig.py
          'platlib': '{userbase}/{platlibdir}/python{py_version_short}/site-packages',
          'include': '{userbase}/include/python{py_version_short}',
          'scripts': '{userbase}/bin',
-@@ -480,7 +480,11 @@ def get_config_h_filename():
+@@ -490,7 +490,11 @@ def get_config_h_filename():
          else:
              inc_dir = _sys_home or _PROJECT_BASE
      else:
@@ -110,10 +110,10 @@ diff -urNp Python-3.8.7.org/Lib/sysconfig.py Python-3.8.7/Lib/sysconfig.py
      return os.path.join(inc_dir, 'pyconfig.h')
  
  
-diff -urNp Python-3.8.7.org/Makefile.pre.in Python-3.8.7/Makefile.pre.in
---- Python-3.8.7.org/Makefile.pre.in   2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/Makefile.pre.in       2021-02-06 00:56:02.722230710 +0100
-@@ -1560,9 +1562,9 @@ libainstall:     @DEF_MAKE_RULE@ python-conf
+diff -urNp -x '*.orig' Python-3.9.2.org/Makefile.pre.in Python-3.9.2/Makefile.pre.in
+--- Python-3.9.2.org/Makefile.pre.in   2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Makefile.pre.in       2021-02-25 18:40:00.705652346 +0100
+@@ -1634,9 +1634,9 @@ libainstall:     @DEF_MAKE_RULE@ python-conf
        @if test -d $(LIBRARY); then :; else \
                if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
                        if test "$(SHLIB_SUFFIX)" = .dll; then \
@@ -125,10 +125,10 @@ diff -urNp Python-3.8.7.org/Makefile.pre.in Python-3.8.7/Makefile.pre.in
                        fi; \
                else \
                        echo Skip install of $(LIBRARY) - use make frameworkinstall; \
-diff -urNp Python-3.8.7.org/setup.py Python-3.8.7/setup.py
---- Python-3.8.7.org/setup.py  2020-12-21 17:25:24.000000000 +0100
-+++ Python-3.8.7/setup.py      2021-02-06 00:56:02.728897587 +0100
-@@ -670,7 +670,7 @@ class PyBuildExt(build_ext):
+diff -urNp -x '*.orig' Python-3.9.2.org/setup.py Python-3.9.2/setup.py
+--- Python-3.9.2.org/setup.py  2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/setup.py      2021-02-25 18:40:00.708985783 +0100
+@@ -750,7 +750,7 @@ class PyBuildExt(build_ext):
              add_dir_to_list(self.compiler.include_dirs,
                              sysconfig.get_config_var("INCLUDEDIR"))
  
@@ -137,7 +137,7 @@ diff -urNp Python-3.8.7.org/setup.py Python-3.8.7/setup.py
          system_include_dirs = ['/usr/include']
          # lib_dirs and inc_dirs are used to search for files;
          # if a file is found in one of those directories, it can
-@@ -953,11 +953,11 @@ class PyBuildExt(build_ext):
+@@ -1039,11 +1039,11 @@ class PyBuildExt(build_ext):
              elif curses_library:
                  readline_libs.append(curses_library)
              elif self.compiler.find_library_file(self.lib_dirs +
index 392c63a53bd482a43f8db0cc5029c07acf7ff785..e78668798ebe770e85128a92049572f0e2481c02 100644 (file)
@@ -1,7 +1,7 @@
-diff -Nur Python-3.3.1.orig/Lib/test/test_compileall.py Python-3.3.1/Lib/test/test_compileall.py
---- Python-3.3.1.orig/Lib/test/test_compileall.py      2013-04-06 08:41:41.000000000 +0100
-+++ Python-3.3.1/Lib/test/test_compileall.py   2013-04-07 19:39:23.449157629 +0100
-@@ -233,6 +233,7 @@ class EncodingTest(unittest.TestCase):
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_compileall.py Python-3.9.2/Lib/test/test_compileall.py
+--- Python-3.9.2.org/Lib/test/test_compileall.py       2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_compileall.py   2021-02-25 18:40:29.876560976 +0100
+@@ -419,6 +419,7 @@ class EncodingTest(unittest.TestCase):
              sys.stdout = orig_stdout
  
  
@@ -9,10 +9,10 @@ diff -Nur Python-3.3.1.orig/Lib/test/test_compileall.py Python-3.3.1/Lib/test/te
  class CommandLineTestsBase:
      """Test compileall's CLI."""
  
-diff -Nur Python-3.3.1.orig/Lib/test/test_warnings/__init__.py Python-3.3.1/Lib/test/test_warnings/__init__.py
---- Python-3.3.1.orig/Lib/test/test_warnings/__init__.py       2013-04-06 08:41:46.000000000 +0100
-+++ Python-3.3.1/Lib/test/test_warnings/__init__.py    2013-04-07 19:41:25.529164545 +0100
-@@ -717,6 +717,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_warnings/__init__.py Python-3.9.2/Lib/test/test_warnings/__init__.py
+--- Python-3.9.2.org/Lib/test/test_warnings/__init__.py        2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_warnings/__init__.py    2021-02-25 18:40:29.876560976 +0100
+@@ -1126,6 +1126,7 @@ class PyCatchWarningTests(CatchWarningTe
      module = py_warnings
  
  
@@ -20,9 +20,9 @@ diff -Nur Python-3.3.1.orig/Lib/test/test_warnings/__init__.py Python-3.3.1/Lib/
  class EnvironmentVariableTests(BaseTest):
  
      def test_single_warning(self):
-@@ -762,14 +763,17 @@
-                 "['ignore:DeprecaciónWarning']".encode('utf-8'))
-         self.assertEqual(p.wait(), 0)
+@@ -1206,14 +1207,17 @@ class EnvironmentVariableTests(BaseTest)
+             PYTHONDEVMODE="")
+         self.assertEqual(stdout, str([PYTHONWARNINGS]).encode())
  
 +@unittest.skipUnless(support.is_resource_enabled("cmdline"), "python cmdline tests disabled")
  class CEnvironmentVariableTests(EnvironmentVariableTests, unittest.TestCase):
index 8baa77aada721a4ec1407049f04b0ce3dd9db0cc..2ceb7f84575ad9c4e16cbf2d4474907cab633938 100644 (file)
@@ -1,6 +1,7 @@
---- Python-3.7.4/Lib/test/test_imaplib.py~     2019-07-08 20:03:50.000000000 +0200
-+++ Python-3.7.4/Lib/test/test_imaplib.py      2019-08-05 19:25:53.119629647 +0200
-@@ -73,7 +73,7 @@ class TestImaplib(unittest.TestCase):
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_imaplib.py Python-3.9.2/Lib/test/test_imaplib.py
+--- Python-3.9.2.org/Lib/test/test_imaplib.py  2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_imaplib.py      2021-02-25 18:42:23.540101637 +0100
+@@ -74,7 +74,7 @@ class TestImaplib(unittest.TestCase):
  
      def test_imap4_host_default_value(self):
          # Check whether the IMAP4_PORT is truly unavailable.
              try:
                  s.connect(('', imaplib.IMAP4_PORT))
                  self.skipTest(
-@@ -84,7 +84,7 @@ class TestImaplib(unittest.TestCase):
+@@ -85,7 +85,7 @@ class TestImaplib(unittest.TestCase):
          # This is the exception that should be raised.
-         expected_errnos = support.get_socket_conn_refused_errs()
+         expected_errnos = socket_helper.get_socket_conn_refused_errs()
          with self.assertRaises(OSError) as cm:
 -            imaplib.IMAP4()
 +            imaplib.IMAP4('0.0.0.0')
          self.assertIn(cm.exception.errno, expected_errnos)
  
  
---- Python-3.9.1/Lib/test/test_unicodedata.py~ 2020-12-07 15:02:38.000000000 +0100
-+++ Python-3.9.1/Lib/test/test_unicodedata.py  2021-02-06 11:25:21.864427644 +0100
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_unicodedata.py Python-3.9.2/Lib/test/test_unicodedata.py
+--- Python-3.9.2.org/Lib/test/test_unicodedata.py      2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_unicodedata.py  2021-02-25 18:42:23.540101637 +0100
 @@ -11,7 +11,7 @@ from http.client import HTTPException
  import sys
  import unicodedata
index 579ef1e36c9e6b67dcba014b95be5468706045ea..e26fb510216aa6634daaea27909d6f74aaec337b 100644 (file)
@@ -1,5 +1,6 @@
---- Python-3.7.0/Lib/test/test_asyncio/test_tasks.py~  2018-06-28 20:51:03.000000000 +0200
-+++ Python-3.7.0/Lib/test/test_asyncio/test_tasks.py   2018-06-28 21:01:38.756365097 +0200
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_asyncio/test_tasks.py Python-3.9.2/Lib/test/test_asyncio/test_tasks.py
+--- Python-3.9.2.org/Lib/test/test_asyncio/test_tasks.py       2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_asyncio/test_tasks.py   2021-02-25 18:41:41.098779547 +0100
 @@ -6,6 +6,7 @@ import contextvars
  import functools
  import gc
@@ -8,21 +9,18 @@
  import random
  import re
  import sys
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_asyncio/test_tasks.py Python-3.5.0/Lib/test/test_asyncio/test_tasks.py
---- Python-3.5.0.orig/Lib/test/test_asyncio/test_tasks.py      2015-09-13 13:41:23.000000000 +0200
-+++ Python-3.5.0/Lib/test/test_asyncio/test_tasks.py   2015-12-03 18:35:52.223668265 +0100
-@@ -1870,6 +1870,7 @@
+@@ -3283,6 +3284,7 @@ class GatherTestsBase:
          cb.assert_called_once_with(fut)
          self.assertEqual(fut.result(), [3, 1, exc, exc2])
  
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_env_var_debug(self):
-         aio_path = os.path.dirname(os.path.dirname(asyncio.__file__))
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_cmd_line.py Python-3.5.0/Lib/test/test_cmd_line.py
---- Python-3.5.0.orig/Lib/test/test_cmd_line.py        2015-09-13 13:41:23.000000000 +0200
-+++ Python-3.5.0/Lib/test/test_cmd_line.py     2015-12-03 18:35:52.227001621 +0100
-@@ -237,6 +237,7 @@
+         code = '\n'.join((
+             'import asyncio.coroutines',
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_cmd_line.py Python-3.9.2/Lib/test/test_cmd_line.py
+--- Python-3.9.2.org/Lib/test/test_cmd_line.py 2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_cmd_line.py     2021-02-25 18:41:41.098779547 +0100
+@@ -265,6 +265,7 @@ class CmdLineTest(unittest.TestCase):
          self.assertEqual(rc, 0)
          self.assertTrue(data.startswith(b'x'), data)
  
@@ -30,7 +28,7 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_cmd_line.py Python-3.5.0/Lib/t
      def test_large_PYTHONPATH(self):
          path1 = "ABCDE" * 100
          path2 = "FGHIJ" * 100
-@@ -252,6 +253,7 @@
+@@ -280,6 +281,7 @@ class CmdLineTest(unittest.TestCase):
          self.assertIn(path1.encode('ascii'), out)
          self.assertIn(path2.encode('ascii'), out)
  
@@ -38,18 +36,18 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_cmd_line.py Python-3.5.0/Lib/t
      def test_empty_PYTHONPATH_issue16309(self):
          # On Posix, it is documented that setting PATH to the
          # empty string is equivalent to not setting PATH at all,
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_compileall.py Python-3.5.0/Lib/test/test_compileall.py
---- Python-3.5.0.orig/Lib/test/test_compileall.py      2015-12-03 18:35:31.483520885 +0100
-+++ Python-3.5.0/Lib/test/test_compileall.py   2015-12-03 18:35:52.227001621 +0100
-@@ -206,6 +206,7 @@
-     def _cleanup(self):
-         support.rmtree(self.directory)
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_compileall.py Python-3.9.2/Lib/test/test_compileall.py
+--- Python-3.9.2.org/Lib/test/test_compileall.py       2021-02-25 18:41:39.412060338 +0100
++++ Python-3.9.2/Lib/test/test_compileall.py   2021-02-25 18:41:41.098779547 +0100
+@@ -486,6 +486,7 @@ class CommandLineTestsBase:
+         self.initfn = script_helper.make_script(self.pkgdir, '__init__', '')
+         self.barfn = script_helper.make_script(self.pkgdir, 'bar', '')
  
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_no_args_compiles_path(self):
          # Note that -l is implied for the no args case.
-         bazfn = script_helper.make_script(self.directory, 'baz', '')
-@@ -220,6 +220,7 @@ class CommandLineTestsBase:
+         self._skip_if_sys_path_not_writable()
+@@ -495,6 +496,7 @@ class CommandLineTestsBase:
          self.assertNotCompiled(self.initfn)
          self.assertNotCompiled(self.barfn)
  
@@ -57,18 +55,18 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_compileall.py Python-3.5.0/Lib
      @without_source_date_epoch  # timestamp invalidation test
      def test_no_args_respects_force_flag(self):
          self._skip_if_sys_path_not_writable()
-@@ -230,6 +232,7 @@
+@@ -513,6 +515,7 @@ class CommandLineTestsBase:
          mtime2 = os.stat(pycpath).st_mtime
          self.assertNotEqual(mtime, mtime2)
  
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_no_args_respects_quiet_flag(self):
+         self._skip_if_sys_path_not_writable()
          script_helper.make_script(self.directory, 'baz', '')
-         noisy = self.assertRunOK(PYTHONPATH=self.directory)
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_pydoc.py Python-3.5.0/Lib/test/test_pydoc.py
---- Python-3.5.0.orig/Lib/test/test_pydoc.py   2015-09-13 13:41:23.000000000 +0200
-+++ Python-3.5.0/Lib/test/test_pydoc.py        2015-12-03 18:35:52.227001621 +0100
-@@ -631,6 +631,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_pydoc.py Python-3.9.2/Lib/test/test_pydoc.py
+--- Python-3.9.2.org/Lib/test/test_pydoc.py    2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_pydoc.py        2021-02-25 18:41:41.098779547 +0100
+@@ -885,6 +885,7 @@ class PydocImportTest(PydocBaseTest):
          self.addCleanup(rmtree, TESTFN)
          importlib.invalidate_caches()
  
@@ -76,10 +74,10 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_pydoc.py Python-3.5.0/Lib/test
      def test_badimport(self):
          # This tests the fix for issue 5230, where if pydoc found the module
          # but the module had an internal import error pydoc would report no doc
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_site.py Python-3.5.0/Lib/test/test_site.py
---- Python-3.5.0.orig/Lib/test/test_site.py    2015-09-13 13:41:23.000000000 +0200
-+++ Python-3.5.0/Lib/test/test_site.py 2015-12-03 18:37:57.484550877 +0100
-@@ -320,6 +320,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_site.py Python-3.9.2/Lib/test/test_site.py
+--- Python-3.9.2.org/Lib/test/test_site.py     2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_site.py 2021-02-25 18:41:41.098779547 +0100
+@@ -387,6 +387,7 @@ class ImportSideEffectTests(unittest.Tes
          """Restore sys.path"""
          sys.path[:] = self.sys_path
  
@@ -87,17 +85,18 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_site.py Python-3.5.0/Lib/test/
      def test_abs_paths(self):
          # Make sure all imported modules have their __file__ and __cached__
          # attributes as absolute paths.  Arranging to put the Lib directory on
---- Python-3.7.4/Lib/test/test_venv.py~        2019-07-08 20:03:50.000000000 +0200
-+++ Python-3.7.4/Lib/test/test_venv.py 2019-07-09 08:37:18.251706609 +0200
-@@ -129,6 +129,7 @@ class BasicTest(BaseTest):
-         self.assertEqual(context.prompt, '(My prompt) ')
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_venv.py Python-3.9.2/Lib/test/test_venv.py
+--- Python-3.9.2.org/Lib/test/test_venv.py     2021-02-19 13:31:44.000000000 +0100
++++ Python-3.9.2/Lib/test/test_venv.py 2021-02-25 18:41:41.098779547 +0100
+@@ -173,6 +173,7 @@ class BasicTest(BaseTest):
+                 builder.upgrade_dependencies(fake_context)
  
      @requireVenvCreate
 +    @unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
      def test_prefixes(self):
          """
          Test that the prefix values are as expected.
-@@ -266,6 +267,7 @@ class BasicTest(BaseTest):
+@@ -310,6 +311,7 @@ class BasicTest(BaseTest):
      # point to the venv being used to run the test, and we lose the link
      # to the source build - so Python can't initialise properly.
      @requireVenvCreate
@@ -105,18 +104,18 @@ diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_site.py Python-3.5.0/Lib/test/
      def test_executable(self):
          """
          Test that the sys.executable value is as expected.
-@@ -326,6 +328,7 @@ class BasicTest(BaseTest):
-         self.assertEqual(out.strip(), "python".encode())
+@@ -406,6 +408,7 @@ class BasicTest(BaseTest):
+         self.assertEqual(out.strip(), 'False'.encode())
  
  @requireVenvCreate
 +@unittest.skipIf("PYTHONPATH" in os.environ, "$PYTHONPATH set")
  class EnsurePipTest(BaseTest):
      """Test venv module installation of pip."""
      def assert_pip_not_installed(self):
-diff -dur -x '*~' Python-3.5.0.orig/Lib/test/test_warnings/__init__.py Python-3.5.0/Lib/test/test_warnings/__init__.py
---- Python-3.5.0.orig/Lib/test/test_warnings/__init__.py       2015-12-03 18:35:31.483520885 +0100
-+++ Python-3.5.0/Lib/test/test_warnings/__init__.py    2015-12-03 18:35:52.227001621 +0100
-@@ -918,6 +918,7 @@
+diff -urNp -x '*.orig' Python-3.9.2.org/Lib/test/test_warnings/__init__.py Python-3.9.2/Lib/test/test_warnings/__init__.py
+--- Python-3.9.2.org/Lib/test/test_warnings/__init__.py        2021-02-25 18:41:39.412060338 +0100
++++ Python-3.9.2/Lib/test/test_warnings/__init__.py    2021-02-25 18:41:41.098779547 +0100
+@@ -1218,6 +1218,7 @@ class PyEnvironmentVariableTests(Environ
  
  class BootstrapTest(unittest.TestCase):
      @unittest.skipUnless(support.is_resource_enabled("cmdline"), "python cmdline tests disabled")
index bd4842d2c85c54b495037dc76f67318d16c4535b..2ab914f9d177798c9c6d3e8b17a1065bbc795035 100644 (file)
@@ -48,7 +48,7 @@ Summary(tr.UTF-8):    X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
 Summary(uk.UTF-8):     Мова програмування дуже високого рівня з X-інтерфейсом
 Name:          python3
 Version:       %{py_ver}.2
-Release:       1
+Release:       2
 Epoch:         1
 License:       PSF
 Group:         Development/Languages/Python
This page took 0.072478 seconds and 4 git commands to generate.