]> git.pld-linux.org Git - packages/python3.git/commitdiff
build with -fno-semantic-interposition
authorJan Palus <atler@pld-linux.org>
Tue, 29 Jun 2021 15:42:04 +0000 (15:42 +0000)
committerJan Palus <atler@pld-linux.org>
Tue, 29 Jun 2021 16:05:38 +0000 (16:05 +0000)
proposed by fedora where it's used by default and brings significant
performance boost for dynamically linked python. to become upstream
default in python 3.10.

see https://bugs.python.org/issue38980

python3.spec

index 6bc2716dbcb84aa263c6778f00ec2513f209bb02..54f2012b2c5498fb936a13e7474c50626699bca1 100644 (file)
@@ -7,6 +7,7 @@
 %bcond_without tests                   # disables Python testing
 %bcond_with    verbose_tests           # runs tests in verbose mode
 %bcond_without optimizations           # expensive, stable optimizations (PGO etc.) + LTO
+%bcond_with    semantic_interposition  # build without \-fno-semantic-interposition
 #
 # tests which will not work on 64-bit platforms
 %define                no64bit_tests   -x test_audioop -x test_rgbimg -x test_imageop
@@ -548,8 +549,10 @@ fi
 %configure \
        CC="%{__cc}" \
        OPT="%{rpmcflags}" \
+       CFLAGS_NODIST="%{!?with_semantic_interposition: -fno-semantic-interposition}" \
        CPPFLAGS="%{rpmcppflags}" \
        LDFLAGS="%{rpmldflags}" \
+       LDFLAGS_NODIST="%{!?with_semantic_interposition: -fno-semantic-interposition}" \
        ac_cv_posix_semaphores_enabled=yes \
        ac_cv_broken_sem_getvalue=no \
        --enable-ipv6 \
This page took 0.218827 seconds and 4 git commands to generate.