]> git.pld-linux.org Git - packages/python-pyPdf.git/blob - python-pyPdf.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-pyPdf.git] / python-pyPdf.spec
1 %define         module  pyPdf
2
3 Summary:        A Pure-Python library built as a PDF toolkit
4 Summary(pl.UTF-8):      Biblioteka toolkitu PDF napisana w czystym Pythonie
5 Name:           python-%{module}
6 Version:        1.13
7 Release:        2
8 License:        BSD
9 Group:          Development/Languages/Python
10 Source0:        http://pybrary.net/pyPdf/pyPdf-%{version}.tar.gz
11 # Source0-md5:  7a75ef56f227b78ae62d6e38d4b6b1da
12 URL:            http://pybrary.net/pyPdf/
13 BuildRequires:  rpmbuild(macros) >= 1.710
14 BuildRequires:  python-devel
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 A Pure-Python library built as a PDF toolkit. It is capable of:
22 * extracting document information (title, author, ...),
23 * splitting documents page by page,
24 * merging documents page by page,
25 * cropping pages,
26 * merging multiple pages into a single page,
27 * encrypting and decrypting PDF files.
28
29 %description -l pl.UTF-8
30 pyPdf to napisana w czystym Pythonie biblioteka stworzona jako toolkit
31 PDF. Potrafi:
32 - wyciągać informacje z dokumentów (tytuł, autora...),
33 - dzielić dokumenty na strony,
34 - łączyć dokumenty z pojedynczych stron,
35 - przycinać strony,
36 - łączyć wiele stron w jedną,
37 - szyfrować i odszyfrowywać pliki PDF.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 %build
43 %py_build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %py_install \
49         --optimize 2 \
50         --root=$RPM_BUILD_ROOT
51
52 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
53 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
54 %py_postclean
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGELOG
62 %dir %{py_sitescriptdir}/%{module}
63 %{py_sitescriptdir}/%{module}/*.py[co]
64 %{py_sitescriptdir}/*.egg-info
This page took 0.121031 seconds and 3 git commands to generate.