]> git.pld-linux.org Git - packages/python-alabaster.git/blob - python-alabaster.spec
rebuild with tests and docs
[packages/python-alabaster.git] / python-alabaster.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  alabaster
7 Summary:        A configurable sidebar-enabled Sphinx theme
8 Summary(pl.UTF-8):      Konfigurowany motyw z bocznym panelem dla Sphinksa
9 Name:           python-%{module}
10 Version:        0.7.12
11 Release:        3
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/alabaster/
15 Source0:        https://files.pythonhosted.org/packages/source/a/alabaster/%{module}-%{version}.tar.gz
16 # Source0-md5:  3591827fde96d1dd23970fb05410ed04
17 URL:            https://pypi.org/project/alabaster/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-devel >= 1:2.6
22 BuildRequires:  python-setuptools >= 7.0
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-devel >= 1:3.2
26 BuildRequires:  python3-modules >= 1:3.2
27 BuildRequires:  python3-setuptools >= 7.0
28 %endif
29 Requires:       python-modules >= 1:2.6
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A configurable sidebar-enabled Sphinx theme.
35
36 This theme is a modified "Kr" Sphinx theme from @kennethreitz
37 (especially as used in his Requests project), which was itself
38 originally based on @mitsuhiko's theme used for Flask & related
39 projects.
40
41 %description -l pl.UTF-8
42 Konfigurowany motyw z bocznym panelem (sidebarem) dla Sphinksa.
43
44 Motyw ten to zmodyfikowany motyw Sphinksa "Kr" od @kennethreitz
45 (konkretnie wersja używana w jego projekcie Requests), pierwotnie
46 oparty na motywie @mitsuhiko używanym w projekcie Flash i powiązanych
47 z nim.
48
49 %package -n python3-%{module}
50 Summary:        A configurable sidebar-enabled Sphinx theme
51 Summary(pl.UTF-8):      Konfigurowany motyw z bocznym panelem dla Sphinksa
52 Group:          Libraries/Python
53 Requires:       python3-modules >= 1:3.2
54
55 %description -n python3-%{module}
56 A configurable sidebar-enabled Sphinx theme
57
58 This theme is a modified "Kr" Sphinx theme from @kennethreitz
59 (especially as used in his Requests project), which was itself
60 originally based on @mitsuhiko's theme used for Flask & related
61 projects.
62
63 %description -n python3-%{module} -l pl.UTF-8
64 Konfigurowany motyw z bocznym panelem (sidebarem) dla Sphinksa.
65
66 Motyw ten to zmodyfikowany motyw Sphinksa "Kr" od @kennethreitz
67 (konkretnie wersja używana w jego projekcie Requests), pierwotnie
68 oparty na motywie @mitsuhiko używanym w projekcie Flash i powiązanych
69 z nim.
70
71 %prep
72 %setup -q -n %{module}-%{version}
73
74 %build
75 %if %{with python2}
76 %py_build
77 %endif
78
79 %if %{with python3}
80 %py3_build
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with python2}
87 %py_install
88
89 %py_postclean
90 %endif
91
92 %if %{with python3}
93 %py3_install
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc LICENSE README.rst
103 %{py_sitescriptdir}/%{module}
104 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
105 %endif
106
107 %if %{with python3}
108 %files -n python3-%{module}
109 %defattr(644,root,root,755)
110 %doc LICENSE README.rst
111 %{py3_sitescriptdir}/%{module}
112 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
113 %endif
This page took 0.072464 seconds and 3 git commands to generate.