]> git.pld-linux.org Git - packages/python-alabaster.git/blame - python-alabaster.spec
use C encoding for en
[packages/python-alabaster.git] / python-alabaster.spec
CommitLineData
afc9ffc8
JK
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module alabaster
7Summary: A configurable sidebar-enabled Sphinx theme
8Name: python-%{module}
9Version: 0.7.4
10Release: 1
11License: BSD
12Group: Libraries/Python
13Source0: https://pypi.python.org/packages/source/a/alabaster/%{module}-%{version}.tar.gz
14# Source0-md5: ba31bf652194200428aa4e3d976f5ccd
15URL: https://pypi.python.org/pypi/alabaster
16BuildRequires: rpm-pythonprov
17BuildRequires: rpmbuild(macros) >= 1.219
18%if %{with python2}
19BuildRequires: python-devel
20BuildRequires: python-setuptools >= 7.0
21%endif
22%if %{with python3}
23BuildRequires: python3-devel
24BuildRequires: python3-modules
25BuildRequires: python3-setuptools >= 7.0
26%endif
27Requires: python-modules
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32A configurable sidebar-enabled Sphinx theme
33
2c7296e8 34This theme is a modified "Kr" Sphinx theme from @kennethreitz
afc9ffc8 35(especially as used in his Requests project), which was itself
2c7296e8 36originally based on @mitsuhiko's theme used for Flask & related
afc9ffc8
JK
37projects.
38
39%package -n python3-%{module}
40Summary: A configurable sidebar-enabled Sphinx theme
41Group: Libraries/Python
42Requires: python3-modules
43
44%description -n python3-%{module}
45A configurable sidebar-enabled Sphinx theme
46
2c7296e8 47This theme is a modified "Kr" Sphinx theme from @kennethreitz
afc9ffc8 48(especially as used in his Requests project), which was itself
2c7296e8 49originally based on @mitsuhiko's theme used for Flask & related
afc9ffc8
JK
50projects.
51
52%prep
53%setup -q -n %{module}-%{version}
54
55%build
56%if %{with python2}
57%{__python} setup.py build --build-base build-2 %{?with_tests:test}
58%endif
59
60%if %{with python3}
61%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
62%endif
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67%if %{with python2}
68%{__python} setup.py \
69 build --build-base build-2 \
70 install --skip-build \
71 --optimize=2 \
72 --root=$RPM_BUILD_ROOT
73
74%py_postclean
75%endif
76
77%if %{with python3}
78%{__python3} setup.py \
79 build --build-base build-3 \
80 install --skip-build \
81 --optimize=2 \
82 --root=$RPM_BUILD_ROOT
83%endif
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%if %{with python2}
89%files
90%defattr(644,root,root,755)
91%doc README.rst
92%{py_sitescriptdir}/%{module}
93%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
94%endif
95
96%if %{with python3}
97%files -n python3-%{module}
98%defattr(644,root,root,755)
99%doc README.rst
100%{py3_sitescriptdir}/%{module}
101%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
102%endif
This page took 0.113386 seconds and 4 git commands to generate.