]> git.pld-linux.org Git - packages/python-PyKCS11.git/blob - python-PyKCS11.spec
- release 4 (by relup.sh)
[packages/python-PyKCS11.git] / python-PyKCS11.spec
1 %define         rname           PyKCS11
2 #
3 Summary:        Full PKCS11 wrapper for Python
4 Name:           python-PyKCS11
5 Version:        1.2.1
6 Release:        4
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        http://downloads.sourceforge.net/pkcs11wrap/%{rname}-%{version}.tar.gz
10 # Source0-md5:  f1be0bcef765a36e4362342c5df49eef
11 URL:            http://www.bit4id.org/trac/pykcs11
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-modules
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 PyKCS11: a complete PKCS#11 wrapper for Python, created using the SWIG
21 compile.
22
23 %prep
24 %setup -qn %{rname}-%{version}
25 %build
26
27 %py_build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31
32 %py_install
33
34 %py_postclean
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 %defattr(644,root,root,755)
41 %dir %{py_sitedir}/PyKCS11
42 %{py_sitedir}/PyKCS11/*.py[co]
43 %attr(755,root,root) %{py_sitedir}/PyKCS11/*.so
44 %{py_sitedir}/*.egg-info
This page took 0.079045 seconds and 4 git commands to generate.