]> git.pld-linux.org Git - packages/poppler0.61.git/commitdiff
- missing file from CVS, cairo includes fix
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Apr 2005 22:35:01 +0000 (22:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    poppler-qt.patch -> 1.1

poppler-qt.patch [new file with mode: 0644]

diff --git a/poppler-qt.patch b/poppler-qt.patch
new file mode 100644 (file)
index 0000000..72abf4c
--- /dev/null
@@ -0,0 +1,46 @@
+--- poppler-0.3.0/qt/poppler-private.h.orig    1970-01-01 01:00:00.000000000 +0100
++++ poppler-0.3.0/qt/poppler-private.h 2005-04-24 00:09:12.548011968 +0200
+@@ -0,0 +1,32 @@
++/* poppler-private.h: qt interface to poppler
++ * Copyright (C) 2005, Net Integration Technologies, Inc.
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 2, or (at your option)
++ * any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
++ */
++
++#include <PDFDoc.h>
++
++namespace Poppler {
++
++class DocumentData {
++  public:
++    DocumentData(GooString *filePath, GooString *password) : doc(filePath,password) {}
++  class PDFDoc doc;
++  bool locked;
++};
++
++}
++
++
+--- poppler-0.3.0/qt/Makefile.am.orig  2005-04-06 16:39:40.000000000 +0200
++++ poppler-0.3.0/qt/Makefile.am       2005-04-24 00:14:16.023876624 +0200
+@@ -1,3 +1,8 @@
++if BUILD_CAIRO_OUTPUT
++cairo_includes =                              \
++      $(CAIRO_CFLAGS)
++endif
++
+ INCLUDES =                                    \
+       -I$(top_srcdir)                         \
+       -I$(top_srcdir)/poppler                 \
This page took 0.131288 seconds and 4 git commands to generate.