]> git.pld-linux.org Git - packages/poppler0.61.git/commitdiff
- C++ fixes needed for gcc4, mostly "extra qualification" errors.
authorqrczak <qrczak@pld-linux.org>
Sun, 11 Dec 2005 11:20:16 +0000 (11:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    poppler-c++.patch -> 1.1
    poppler.spec -> 1.21

poppler-c++.patch [new file with mode: 0644]
poppler.spec

diff --git a/poppler-c++.patch b/poppler-c++.patch
new file mode 100644 (file)
index 0000000..d549d7c
--- /dev/null
@@ -0,0 +1,36 @@
+--- poppler-0.4.2/poppler/TextOutputDev.cc~    2005-08-24 19:57:47.000000000 +0200
++++ poppler-0.4.2/poppler/TextOutputDev.cc     2005-12-11 06:49:56.000000000 +0100
+@@ -3025,7 +3025,7 @@
+   virtual void visitWord (TextWord *word, int begin, int end,
+                         PDFRectangle *selection) { };
+-  GooString *TextSelectionDumper::getText(void);
++  GooString *getText(void);
+ private:
+   TextLineFrag *frags;
+--- poppler-0.4.2/qt/poppler-qt.h~     2005-06-27 01:35:27.000000000 +0200
++++ poppler-0.4.2/qt/poppler-qt.h      2005-12-11 12:07:26.000000000 +0100
+@@ -150,7 +150,7 @@
+     UseOC
+   };
+   
+-  static Document *Document::load(const QString & filePath);
++  static Document *load(const QString & filePath);
+   
+   Page *getPage(int index) const{ return new Page(this, index); }
+   
+@@ -172,11 +172,11 @@
+   bool okToAddNotes() const;
+   double getPDFVersion() const;
+   
+-  Document::~Document();
++  ~Document();
+   
+ private:
+   DocumentData *data;
+-  Document::Document(DocumentData *dataA);
++  Document(DocumentData *dataA);
+ };
+ }
index fd8b993cc8d13eca3ccb5c4ae69fd840f21019cb..a7516200baee775c73cc15ac1d0c1cb299e94d9f 100644 (file)
@@ -16,6 +16,7 @@ Source0:      http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
 # Source0-md5: beb1eea135a3c5b679a7a22d01a500c0
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-freetype_includes.patch
+Patch2:                %{name}-c++.patch
 URL:           http://poppler.freedesktop.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -146,6 +147,7 @@ Statyczna wersja wrappera Qt dla popplera.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
This page took 0.057879 seconds and 4 git commands to generate.