]> git.pld-linux.org Git - packages/poppler0.61.git/blob - poppler.spec
up to 0.56.0
[packages/poppler0.61.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt4     # disable qt4 wrapper
6 %bcond_without  qt5     # disable qt5 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9
10 %define         cairo_ver       1.10.0
11 %define         qt4_ver         4.7.0
12 %define         qt5_ver         5.0.0
13 Summary:        PDF rendering library
14 Summary(pl.UTF-8):      Biblioteka renderująca PDF
15 Name:           poppler
16 Version:        0.56.0
17 Release:        1
18 License:        GPL v2+
19 Group:          Libraries
20 Source0:        https://poppler.freedesktop.org/%{name}-%{version}.tar.xz
21 # Source0-md5:  31260c06e139d7270be4567cc8a4af97
22 URL:            https://poppler.freedesktop.org/
23 %{?with_qt5:BuildRequires:      Qt5Core-devel >= %{qt5_ver}}
24 %{?with_qt5:BuildRequires:      Qt5Gui-devel >= %{qt5_ver}}
25 %{?with_qt5:BuildRequires:      Qt5Test-devel >= %{qt5_ver}}
26 %{?with_qt5:BuildRequires:      Qt5Widgets-devel >= %{qt5_ver}}
27 %{?with_qt5:BuildRequires:      Qt5Xml-devel >= %{qt5_ver}}
28 %{?with_qt4:BuildRequires:      QtCore-devel >= %{qt4_ver}}
29 %{?with_qt4:BuildRequires:      QtGui-devel >= %{qt4_ver}}
30 %{?with_qt4:BuildRequires:      QtTest-devel >= %{qt4_ver}}
31 %{?with_qt4:BuildRequires:      QtXml-devel >= %{qt4_ver}}
32 BuildRequires:  autoconf >= 2.59
33 BuildRequires:  automake >= 1:1.7
34 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
35 BuildRequires:  curl-devel
36 BuildRequires:  docbook-dtd412-xml
37 BuildRequires:  fontconfig-devel >= 2.0.0
38 BuildRequires:  freetype-devel >= 2.0
39 BuildRequires:  gettext-tools
40 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.41}
41 BuildRequires:  gobject-introspection-devel >= 0.6.7
42 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
43 BuildRequires:  lcms2-devel >= 2
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libpng-devel
46 BuildRequires:  libstdc++-devel >= 6:4.7
47 BuildRequires:  libtiff-devel
48 BuildRequires:  libtool >= 2:1.5
49 BuildRequires:  libxml2-devel >= 2.0
50 BuildRequires:  nss-devel >= 3
51 BuildRequires:  openjpeg2-devel >= 2
52 BuildRequires:  pkgconfig >= 1:0.18
53 # wanted cairo backends
54 BuildRequires:  pkgconfig(cairo-pdf) >= %{cairo_ver}
55 BuildRequires:  pkgconfig(cairo-ps) >= %{cairo_ver}
56 BuildRequires:  pkgconfig(cairo-svg) >= %{cairo_ver}
57 %{?with_qt4:BuildRequires:      qt4-build >= %{qt4_ver}}
58 %{?with_qt5:BuildRequires:      qt5-build >= %{qt5_ver}}
59 BuildRequires:  sed >= 4.0
60 BuildRequires:  tar >= 1:1.22
61 BuildRequires:  which
62 BuildRequires:  xz
63 BuildRequires:  zlib-devel
64 Requires:       openjpeg2 >= 2
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 A common PDF rendering library for integrating PDF viewing into
69 desktop applications (based on the xpdf-3.0 code base).
70
71 %description -l pl.UTF-8
72 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
73 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
74
75 %package devel
76 Summary:        Poppler header files
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       curl-devel
81 Requires:       lcms2-devel >= 2
82 Requires:       libstdc++-devel >= 6:4.7
83 Requires:       nss-devel >= 3
84
85 %description devel
86 Header files for the Poppler library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki Poppler.
90
91 %package static
92 Summary:        Poppler static libraries
93 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Poppler static libraries.
99
100 %description static -l pl.UTF-8
101 Statyczne biblioteki Poppler.
102
103 %package apidocs
104 Summary:        Poppler library API documentation
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
106 Group:          Documentation
107 Requires:       gtk-doc-common
108 %if "%{_rpmversion}" >= "5"
109 BuildArch:      noarch
110 %endif
111
112 %description apidocs
113 Poppler library API documentation.
114
115 %description apidocs -l pl.UTF-8
116 Dokumentacja API biblioteki Poppler.
117
118 %package cpp
119 Summary:        Cpp wrapper for poppler
120 Summary(pl.UTF-8):      Wrapper cpp dla popplera
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123
124 %description cpp
125 Cpp wrapper for poppler.
126
127 %description cpp -l pl.UTF-8
128 Wrapper cpp dla popplera.
129
130 %package cpp-devel
131 Summary:        Header files for cpp wrapper for poppler
132 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
133 Group:          Development/Libraries
134 Requires:       %{name}-cpp = %{version}-%{release}
135 Requires:       %{name}-devel = %{version}-%{release}
136
137 %description cpp-devel
138 Header files for cpp wrapper for poppler.
139
140 %description cpp-devel -l pl.UTF-8
141 Pliki nagłówkowe wrappera cpp dla popplera.
142
143 %package cpp-static
144 Summary:        Static version of cpp wrapper for poppler
145 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
146 Group:          Development/Libraries
147 Requires:       %{name}-cpp-devel = %{version}-%{release}
148
149 %description cpp-static
150 Static version of cpp wrapper for poppler.
151
152 %description cpp-static -l pl.UTF-8
153 Statyczna wersja wrappera cpp dla popplera.
154
155 %package glib
156 Summary:        GLib wrapper for poppler
157 Summary(pl.UTF-8):      Wrapper GLib dla popplera
158 Group:          Libraries
159 Requires:       %{name} = %{version}-%{release}
160 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
161 Requires:       glib2 >= 1:2.41
162
163 %description glib
164 GLib wrapper for poppler.
165
166 %description glib -l pl.UTF-8
167 Wrapper GLib dla popplera.
168
169 %package glib-devel
170 Summary:        Header files for GLib wrapper for poppler
171 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174 Requires:       %{name}-glib = %{version}-%{release}
175 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
176 Requires:       glib2-devel >= 1:2.41
177
178 %description glib-devel
179 Header files for GLib wrapper for poppler.
180
181 %description glib-devel -l pl.UTF-8
182 Pliki nagłówkowe wrappera GLib dla popplera.
183
184 %package glib-static
185 Summary:        Static version of GLib wrapper for poppler
186 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
187 Group:          Development/Libraries
188 Requires:       %{name}-glib-devel = %{version}-%{release}
189
190 %description glib-static
191 Static version of GLib wrapper for poppler.
192
193 %description glib-static -l pl.UTF-8
194 Statyczna wersja wrappera GLib dla popplera.
195
196 %package qt4
197 Summary:        Qt4 wrapper for poppler
198 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
199 Group:          Libraries
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       QtCore >= %{qt4_ver}
202 Requires:       QtGui >= %{qt4_ver}
203 Requires:       QtXml >= %{qt4_ver}
204 Provides:       poppler-Qt = %{version}-%{release}
205 Obsoletes:      poppler-Qt < 0.24.4-2
206 Obsoletes:      poppler-qt
207
208 %description qt4
209 Qt4 wrapper for poppler.
210
211 %description qt4 -l pl.UTF-8
212 Wrapper Qt4 dla popplera.
213
214 %package qt4-devel
215 Summary:        Header files for Qt4 wrapper for poppler
216 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
217 Group:          Development/Libraries
218 Requires:       %{name}-devel = %{version}-%{release}
219 Requires:       %{name}-qt4 = %{version}-%{release}
220 Requires:       QtCore-devel >= %{qt4_ver}
221 Requires:       QtGui-devel >= %{qt4_ver}
222 Requires:       QtXml-devel >= %{qt4_ver}
223 Provides:       poppler-Qt-devel = %{version}-%{release}
224 Obsoletes:      poppler-Qt-devel < 0.24.4-2
225 Obsoletes:      poppler-qt-devel
226
227 %description qt4-devel
228 Header files for Qt4 wrapper for poppler.
229
230 %description qt4-devel -l pl.UTF-8
231 Pliki nagłówkowe wrapper Qt4 dla popplera.
232
233 %package qt4-static
234 Summary:        Static version of Qt4 wrapper for poppler
235 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
236 Group:          Development/Libraries
237 Requires:       %{name}-qt4-devel = %{version}-%{release}
238 Provides:       poppler-Qt-static = %{version}-%{release}
239 Obsoletes:      poppler-Qt-static < 0.24.4-2
240 Obsoletes:      poppler-qt-static
241
242 %description qt4-static
243 Static version of Qt4 wrapper for poppler.
244
245 %description qt4-static -l pl.UTF-8
246 Statyczna wersja wrappera Qt4 dla popplera.
247
248 %package qt5
249 Summary:        Qt5 wrapper for poppler
250 Summary(pl.UTF-8):      Wrapper Qt5 dla popplera
251 Group:          Libraries
252 Requires:       %{name} = %{version}-%{release}
253
254 %description qt5
255 Qt5 wrapper for poppler.
256
257 %description qt5 -l pl.UTF-8
258 Wrapper Qt5 dla popplera.
259
260 %package qt5-devel
261 Summary:        Header files for Qt5 wrapper for poppler
262 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt5 dla popplera
263 Group:          Development/Libraries
264 Requires:       %{name}-devel = %{version}-%{release}
265 Requires:       %{name}-qt5 = %{version}-%{release}
266 Requires:       Qt5Core-devel >= %{qt5_ver}
267 Requires:       Qt5Gui-devel >= %{qt5_ver}
268 Requires:       Qt5Widgets-devel >= %{qt5_ver}
269 Requires:       Qt5Xml-devel >= %{qt5_ver}
270
271 %description qt5-devel
272 Header files for Qt5 wrapper for poppler.
273
274 %description qt5-devel -l pl.UTF-8
275 Pliki nagłówkowe wrapper Qt5 dla popplera.
276
277 %package qt5-static
278 Summary:        Static version of Qt5 wrapper for poppler
279 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt5 dla popplera
280 Group:          Development/Libraries
281 Requires:       %{name}-qt5-devel = %{version}-%{release}
282
283 %description qt5-static
284 Static version of Qt5 wrapper for poppler.
285
286 %description qt5-static -l pl.UTF-8
287 Statyczna wersja wrappera Qt5 dla popplera.
288
289 %package progs
290 Summary:        Set of tools for viewing information and converting PDF files
291 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
292 Group:          Applications/Publishing
293 Provides:       pdftops
294 Obsoletes:      pdftohtml
295 Obsoletes:      pdftohtml-pdftops
296 Obsoletes:      poppler-utils
297 Obsoletes:      xpdf-tools
298
299 %description progs
300 Package contains utilites for PDF files. These utilities allow to
301 - extract information about PDF files,
302 - extract images from PDF files,
303 - convert PDF files to HTML, plain text and PS formats.
304
305 %description progs -l pl.UTF-8
306 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
307 - wyświetlanie informacji o plikach PDF,
308 - wydobywanie obrazków z plików PDF,
309 - konwersję plików PDF do formatów takich jak HTML, PS czy też
310   czystego tekstu.
311
312 %prep
313 %setup -q
314
315 %build
316 %{?with_apidocs:%{__gtkdocize}}
317 %{__libtoolize}
318 %{__aclocal} -I m4
319 %{__autoconf} -f
320 %{__autoheader}
321 %{__automake}
322 %configure \
323         --disable-gtk-test \
324         --enable-libcurl \
325         %{?with_apidocs:--enable-gtk-doc} \
326         %{!?with_cairo:--disable-cairo-output} \
327         %{!?with_cpp:--disable-poppler-cpp} \
328         %{!?with_glib:--disable-poppler-glib} \
329         %{!?with_qt4:--disable-poppler-qt4} \
330         %{!?with_qt5:--disable-poppler-qt5} \
331         --disable-silent-rules \
332         --enable-xpdf-headers \
333         --enable-zlib \
334         --enable-dependency-tracking \
335         --with-html-dir=%{_gtkdocdir}
336
337 %{__make}
338
339 %install
340 rm -rf $RPM_BUILD_ROOT
341
342 %{__make} install \
343         DESTDIR=$RPM_BUILD_ROOT
344
345 %if %{without apidocs}
346 # why it still installs them, brr
347 %{__rm} -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
348 %endif
349
350 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
351
352 %clean
353 rm -rf $RPM_BUILD_ROOT
354
355 %post   -p /sbin/ldconfig
356 %postun -p /sbin/ldconfig
357
358 %post   cpp -p /sbin/ldconfig
359 %postun cpp -p /sbin/ldconfig
360
361 %post   glib -p /sbin/ldconfig
362 %postun glib -p /sbin/ldconfig
363
364 %post   qt4 -p /sbin/ldconfig
365 %postun qt4 -p /sbin/ldconfig
366
367 %post   qt5 -p /sbin/ldconfig
368 %postun qt5 -p /sbin/ldconfig
369
370 %files
371 %defattr(644,root,root,755)
372 %doc AUTHORS ChangeLog NEWS README* TODO
373 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
374 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.67
375
376 %files devel
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_libdir}/libpoppler.so
379 %dir %{_includedir}/poppler
380 %{_includedir}/poppler/poppler-config.h
381 %{_includedir}/poppler/[ABCDEFGHJLMNOPRSTUVX]*.h
382 %{_includedir}/poppler/fofi
383 %{_includedir}/poppler/goo
384 %{_includedir}/poppler/splash
385 %{_pkgconfigdir}/poppler.pc
386 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
387 %{_pkgconfigdir}/poppler-splash.pc
388
389 %files static
390 %defattr(644,root,root,755)
391 %{_libdir}/libpoppler.a
392
393 %if %{with apidocs}
394 %files apidocs
395 %defattr(644,root,root,755)
396 %{_gtkdocdir}/poppler
397 %endif
398
399 %if %{with cpp}
400 %files cpp
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
403 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
404
405 %files cpp-devel
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
408 %{_includedir}/poppler/cpp
409 %{_pkgconfigdir}/poppler-cpp.pc
410
411 %files cpp-static
412 %defattr(644,root,root,755)
413 %{_libdir}/libpoppler-cpp.a
414 %endif
415
416 %if %{with glib}
417 %files glib
418 %defattr(644,root,root,755)
419 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
420 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.8
421 %{_libdir}/girepository-1.0/Poppler-0.18.typelib
422
423 %files glib-devel
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
426 %{_includedir}/poppler/glib
427 %{_pkgconfigdir}/poppler-glib.pc
428 %{_datadir}/gir-1.0/Poppler-0.18.gir
429
430 %files glib-static
431 %defattr(644,root,root,755)
432 %{_libdir}/libpoppler-glib.a
433 %endif
434
435 %if %{with qt4}
436 %files qt4
437 %defattr(644,root,root,755)
438 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
439 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.4
440
441 %files qt4-devel
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
444 %{_includedir}/poppler/qt4
445 %{_pkgconfigdir}/poppler-qt4.pc
446
447 %files qt4-static
448 %defattr(644,root,root,755)
449 %{_libdir}/libpoppler-qt4.a
450 %endif
451
452 %if %{with qt5}
453 %files qt5
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_libdir}/libpoppler-qt5.so.*.*.*
456 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt5.so.1
457
458 %files qt5-devel
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_libdir}/libpoppler-qt5.so
461 %{_includedir}/poppler/qt5
462 %{_pkgconfigdir}/poppler-qt5.pc
463
464 %files qt5-static
465 %defattr(644,root,root,755)
466 %{_libdir}/libpoppler-qt5.a
467 %endif
468
469 %files progs
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_bindir}/pdfdetach
472 %attr(755,root,root) %{_bindir}/pdffonts
473 %attr(755,root,root) %{_bindir}/pdfimages
474 %attr(755,root,root) %{_bindir}/pdfinfo
475 %attr(755,root,root) %{_bindir}/pdfseparate
476 %attr(755,root,root) %{_bindir}/pdfsig
477 %attr(755,root,root) %{_bindir}/pdftocairo
478 %attr(755,root,root) %{_bindir}/pdftohtml
479 %attr(755,root,root) %{_bindir}/pdftoppm
480 %attr(755,root,root) %{_bindir}/pdftops
481 %attr(755,root,root) %{_bindir}/pdftotext
482 %attr(755,root,root) %{_bindir}/pdfunite
483 %{_mandir}/man1/pdfdetach.1*
484 %{_mandir}/man1/pdffonts.1*
485 %{_mandir}/man1/pdfimages.1*
486 %{_mandir}/man1/pdfinfo.1*
487 %{_mandir}/man1/pdfseparate.1*
488 %{_mandir}/man1/pdfsig.1*
489 %{_mandir}/man1/pdftocairo.1*
490 %{_mandir}/man1/pdftohtml.1*
491 %{_mandir}/man1/pdftoppm.1*
492 %{_mandir}/man1/pdftops.1*
493 %{_mandir}/man1/pdftotext.1*
494 %{_mandir}/man1/pdfunite.1*
This page took 0.101339 seconds and 3 git commands to generate.