]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- name collision on case insensitive fs
[packages/poppler.git] / poppler.spec
1 # TODO
2 # - qt and Qt packages make file collisions on case insensitive filesystems,
3 #   consider adding version suffix to either of the pckages
4 #
5 # Conditional build:
6 %bcond_without  apidocs # disable gtk-doc
7 %bcond_without  cairo   # disable Cairo backend
8 %bcond_without  qt      # disable qt wrapper
9 %bcond_without  qt4     # disable qt4 wrapper
10 %bcond_without  cpp     # disable cpp wrapper
11 %bcond_without  glib    # disable glib wrapper
12 #
13 %define         cairo_ver       1.10.0
14 #
15 Summary:        PDF rendering library
16 Summary(pl.UTF-8):      Biblioteka renderująca PDF
17 Name:           poppler
18 Version:        0.16.7
19 Release:        1
20 License:        GPL v2+
21 Group:          Libraries
22 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
23 # Source0-md5:  3afa28e3c8c4f06b0fbca3c91e06394e
24 URL:            http://poppler.freedesktop.org/
25 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
26 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.4.0}
27 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.4.0}
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake
30 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
31 BuildRequires:  curl-devel
32 BuildRequires:  docbook-dtd412-xml
33 BuildRequires:  fontconfig-devel >= 2.0.0
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  gettext-devel
36 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.18.0}
37 BuildRequires:  gobject-introspection-devel >= 0.6.7
38 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
39 BuildRequires:  lcms-devel
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool >= 2:1.5
43 BuildRequires:  libxml2-devel >= 2.0
44 BuildRequires:  openjpeg-devel
45 BuildRequires:  pkgconfig >= 1:0.18
46 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
47 %{?with_qt4:BuildRequires:      qt4-build}
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  which
50 BuildRequires:  zlib-devel
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 A common PDF rendering library for integrating PDF viewing into
55 desktop applications (based on the xpdf-3.0 code base).
56
57 %description -l pl.UTF-8
58 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
59 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
60
61 %package devel
62 Summary:        Poppler header files
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       fontconfig-devel >= 2.0.0
67 Requires:       freetype-devel >= 2.0
68 Requires:       lcms-devel
69 Requires:       libstdc++-devel
70 Requires:       openjpeg-devel
71
72 %description devel
73 Header files for the Poppler library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki Poppler.
77
78 %package static
79 Summary:        Poppler static libraries
80 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Poppler static libraries.
86
87 %description static -l pl.UTF-8
88 Statyczne biblioteki Poppler.
89
90 %package apidocs
91 Summary:        Poppler library API documentation
92 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
93 Group:          Documentation
94 Requires:       gtk-doc-common
95
96 %description apidocs
97 Poppler library API documentation.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API biblioteki Poppler.
101
102 %package cpp
103 Summary:        Cpp wrapper for poppler
104 Summary(pl.UTF-8):      Wrapper cpp dla popplera
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description cpp
109 Cpp wrapper for poppler.
110
111 %description cpp -l pl.UTF-8
112 Wrapper cpp dla popplera.
113
114 %package cpp-devel
115 Summary:        Header files for cpp wrapper for poppler
116 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
117 Group:          Development/Libraries
118 Requires:       %{name}-cpp = %{version}-%{release}
119 Requires:       %{name}-devel = %{version}-%{release}
120
121 %description cpp-devel
122 Header files for cpp wrapper for poppler.
123
124 %description cpp-devel -l pl.UTF-8
125 Pliki nagłówkowe wrappera cpp dla popplera.
126
127 %package cpp-static
128 Summary:        Static version of cpp wrapper for poppler
129 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
130 Group:          Development/Libraries
131 Requires:       %{name}-cpp-devel = %{version}-%{release}
132
133 %description cpp-static
134 Static version of cpp wrapper for poppler.
135
136 %description cpp-static -l pl.UTF-8
137 Statyczna wersja wrappera cpp dla popplera.
138
139 %package glib
140 Summary:        GLib wrapper for poppler
141 Summary(pl.UTF-8):      Wrapper GLib dla popplera
142 Group:          Libraries
143 Requires:       %{name} = %{version}-%{release}
144 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
145 Requires:       glib2 >= 1:2.18.0
146
147 %description glib
148 GLib wrapper for poppler.
149
150 %description glib -l pl.UTF-8
151 Wrapper GLib dla popplera.
152
153 %package glib-devel
154 Summary:        Header files for GLib wrapper for poppler
155 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
156 Group:          Development/Libraries
157 Requires:       %{name}-devel = %{version}-%{release}
158 Requires:       %{name}-glib = %{version}-%{release}
159 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
160 Requires:       glib2-devel >= 1:2.18.0
161
162 %description glib-devel
163 Header files for GLib wrapper for poppler.
164
165 %description glib-devel -l pl.UTF-8
166 Pliki nagłówkowe wrappera GLib dla popplera.
167
168 %package glib-static
169 Summary:        Static version of GLib wrapper for poppler
170 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
171 Group:          Development/Libraries
172 Requires:       %{name}-glib-devel = %{version}-%{release}
173
174 %description glib-static
175 Static version of GLib wrapper for poppler.
176
177 %description glib-static -l pl.UTF-8
178 Statyczna wersja wrappera GLib dla popplera.
179
180 %package qt
181 Summary:        Qt wrapper for poppler
182 Summary(pl.UTF-8):      Wrapper Qt dla popplera
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description qt
187 Qt wrapper for poppler.
188
189 %description qt -l pl.UTF-8
190 Wrapper Qt dla popplera.
191
192 %package qt-devel
193 Summary:        Header files for Qt wrapper for poppler
194 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
195 Group:          Development/Libraries
196 Requires:       %{name}-devel = %{version}-%{release}
197 Requires:       %{name}-qt = %{version}-%{release}
198 Requires:       qt-devel
199
200 %description qt-devel
201 Header files for Qt wrapper for poppler.
202
203 %description qt-devel -l pl.UTF-8
204 Pliki nagłówkowe wrappera Qt dla popplera.
205
206 %package qt-static
207 Summary:        Static version of Qt wrapper for poppler
208 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
209 Group:          Development/Libraries
210 Requires:       %{name}-qt-devel = %{version}-%{release}
211
212 %description qt-static
213 Static version of Qt wrapper for poppler.
214
215 %description qt-static -l pl.UTF-8
216 Statyczna wersja wrappera Qt dla popplera.
217
218 %package Qt
219 Summary:        Qt4 wrapper for poppler
220 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
221 Group:          Libraries
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       QtGui >= 4.4.0
224 Requires:       QtXml >= 4.4.0
225
226 %description Qt
227 Qt4 wrapper for poppler.
228
229 %description Qt -l pl.UTF-8
230 Wrapper Qt4 dla popplera.
231
232 %package Qt-devel
233 Summary:        Header files for Qt4 wrapper for poppler
234 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
235 Group:          Development/Libraries
236 Requires:       %{name}-Qt = %{version}-%{release}
237 Requires:       %{name}-devel = %{version}-%{release}
238 Requires:       QtGui-devel >= 4.4.0
239 Requires:       QtXml-devel >= 4.4.0
240
241 %description Qt-devel
242 Header files for Qt4 wrapper for poppler.
243
244 %description Qt-devel -l pl.UTF-8
245 Pliki nagłówkowe wrapper Qt4 dla popplera.
246
247 %package Qt-static
248 Summary:        Static version of Qt4 wrapper for poppler
249 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
250 Group:          Development/Libraries
251 Requires:       %{name}-Qt-devel = %{version}-%{release}
252
253 %description Qt-static
254 Static version of Qt4 wrapper for poppler.
255
256 %description Qt-static -l pl.UTF-8
257 Statyczna wersja wrappera Qt4 dla popplera.
258
259 %package progs
260 Summary:        Set of tools for viewing information and converting PDF files
261 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
262 Group:          Applications/Publishing
263 Provides:       pdftops
264 Obsoletes:      pdftohtml
265 Obsoletes:      pdftohtml-pdftops
266 Obsoletes:      poppler-utils
267 Obsoletes:      xpdf-tools
268
269 %description progs
270 Package contains utilites for PDF files. These utilities allow to
271 - extract information about PDF files,
272 - extract images from PDF files,
273 - convert PDF files to HTML, plain text and PS formats.
274
275 %description progs -l pl.UTF-8
276 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
277 - wyświetlanie informacji o plikach PDF,
278 - wydobywanie obrazków z plików PDF,
279 - konwersję plików PDF do formatów takich jak HTML, PS czy też
280   czystego tekstu.
281
282 %prep
283 %setup -q
284
285 # fix link with Qt 3 libraries
286 %{__sed} -i 's,(POPPLER_QT_LIBS),(libqt3_LIBS),' qt/Makefile.am
287
288 %build
289 %{?with_apidocs:%{__gtkdocize}}
290 %{__libtoolize}
291 %{__aclocal} -I m4
292 %{__autoconf} -f
293 %{__autoheader}
294 %{__automake}
295 %configure \
296         QTINC=%{_includedir}/qt \
297         QTLIB=%{_libdir} \
298         --disable-gtk-test \
299         --enable-libcurl \
300         %{?with_apidocs:--enable-gtk-doc} \
301         %{!?with_cairo:--disable-cairo-output} \
302         %{!?with_cpp:--disable-poppler-cpp} \
303         %{!?with_glib:--disable-poppler-glib} \
304         %{!?with_qt:--disable-poppler-qt} \
305         %{!?with_qt4:--disable-poppler-qt4} \
306         --disable-silent-rules \
307         --enable-xpdf-headers \
308         --enable-zlib \
309         --enable-dependency-tracking \
310         --with-html-dir=%{_gtkdocdir} 
311
312 %{__make}
313
314 %install
315 rm -rf $RPM_BUILD_ROOT
316
317 %{__make} install \
318         DESTDIR=$RPM_BUILD_ROOT
319
320 %if %{without apidocs}
321 # why it still installs them, brr
322 %{__rm} -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler || :
323 %endif
324
325 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
326
327 %clean
328 rm -rf $RPM_BUILD_ROOT
329
330 %post   -p /sbin/ldconfig
331 %postun -p /sbin/ldconfig
332
333 %post   cpp -p /sbin/ldconfig
334 %postun cpp -p /sbin/ldconfig
335
336 %post   glib -p /sbin/ldconfig
337 %postun glib -p /sbin/ldconfig
338
339 %post   qt -p /sbin/ldconfig
340 %postun qt -p /sbin/ldconfig
341
342 %post   Qt -p /sbin/ldconfig
343 %postun Qt -p /sbin/ldconfig
344
345 %files
346 %defattr(644,root,root,755)
347 %doc AUTHORS ChangeLog NEWS README* TODO
348 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
349 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.13
350
351 %files devel
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_libdir}/libpoppler.so
354 %dir %{_includedir}/poppler
355 %{_includedir}/poppler/poppler-config.h
356 %{_includedir}/poppler/[ABCDEFGHJLMNOPRSTUX]*.h
357 %{_includedir}/poppler/fofi
358 %{_includedir}/poppler/goo
359 %{_includedir}/poppler/splash
360 %{_pkgconfigdir}/poppler.pc
361 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
362 %{_pkgconfigdir}/poppler-splash.pc
363
364 %files static
365 %defattr(644,root,root,755)
366 %{_libdir}/libpoppler.a
367
368 %if %{with apidocs}
369 %files apidocs
370 %defattr(644,root,root,755)
371 %{_gtkdocdir}/poppler
372 %endif
373
374 %if %{with cpp}
375 %files cpp
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
378 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
379
380 %files cpp-devel
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
383 %{_includedir}/poppler/cpp
384 %{_pkgconfigdir}/poppler-cpp.pc
385
386 %files cpp-static
387 %defattr(644,root,root,755)
388 %{_libdir}/libpoppler-cpp.a
389 %endif
390
391 %if %{with glib}
392 %files glib
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
395 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.6
396 %{_libdir}/girepository-1.0/Poppler-0.16.typelib
397
398 %files glib-devel
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
401 %{_includedir}/poppler/glib
402 %{_pkgconfigdir}/poppler-glib.pc
403 %{_datadir}/gir-1.0/Poppler-0.16.gir
404
405 %files glib-static
406 %defattr(644,root,root,755)
407 %{_libdir}/libpoppler-glib.a
408 %endif
409
410 %if %{with qt}
411 %files qt
412 %defattr(644,root,root,755)
413 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
414 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.3
415
416 %files qt-devel
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
419 %{_includedir}/poppler/qt3
420 %{_pkgconfigdir}/poppler-qt.pc
421
422 %files qt-static
423 %defattr(644,root,root,755)
424 %{_libdir}/libpoppler-qt.a
425 %endif
426
427 %if %{with qt4}
428 %files Qt
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
432
433 %files Qt-devel
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
436 %{_includedir}/poppler/qt4
437 %{_pkgconfigdir}/poppler-qt4.pc
438
439 %files Qt-static
440 %defattr(644,root,root,755)
441 %{_libdir}/libpoppler-qt4.a
442 %endif
443
444 %files progs
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_bindir}/pdf*
447 %{_mandir}/man1/pdf*
This page took 0.106097 seconds and 4 git commands to generate.