]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- quick fix
[packages/poppler.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt      # disable qt wrapper
6 %bcond_without  qt4     # disable qt4 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9 #
10 %define         cairo_ver       1.8.4
11 #
12 Summary:        PDF rendering library
13 Summary(pl.UTF-8):      Biblioteka renderująca PDF
14 Name:           poppler
15 Version:        0.16.0
16 Release:        1
17 License:        GPL v2+
18 Group:          Libraries
19 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
20 # Source0-md5:  654f8e8debf028085173d76e3c34b652
21 URL:            http://poppler.freedesktop.org/
22 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
23 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.4.0}
24 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.4.0}
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  fontconfig-devel >= 2.0.0
30 BuildRequires:  freetype-devel >= 2.0
31 BuildRequires:  gettext-devel
32 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.18.0}
33 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
34 BuildRequires:  lcms-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool >= 2:1.5
38 BuildRequires:  libxml2-devel >= 2.0
39 BuildRequires:  openjpeg-devel
40 BuildRequires:  pkgconfig
41 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
42 %{?with_qt4:BuildRequires:      qt4-build}
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  which
45 BuildRequires:  zlib-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 A common PDF rendering library for integrating PDF viewing into
50 desktop applications (based on the xpdf-3.0 code base).
51
52 %description -l pl.UTF-8
53 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
54 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
55
56 %package devel
57 Summary:        Poppler header files
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       fontconfig-devel >= 2.0.0
62 Requires:       freetype-devel >= 2.0
63 Requires:       lcms-devel
64 Requires:       libstdc++-devel
65 Requires:       openjpeg-devel
66
67 %description devel
68 Header files for the Poppler library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki Poppler.
72
73 %package static
74 Summary:        Poppler static libraries
75 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Poppler static libraries.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki Poppler.
84
85 %package apidocs
86 Summary:        Poppler library API documentation
87 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
88 Group:          Documentation
89 Requires:       gtk-doc-common
90
91 %description apidocs
92 Poppler library API documentation.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki Poppler.
96
97 %package cpp
98 Summary:        Cpp wrapper for poppler
99 Summary(pl.UTF-8):      Wrapper cpp dla popplera
100 Group:          Libraries
101 Requires:       %{name} = %{version}-%{release}
102
103 %description cpp
104 Cpp wrapper for poppler.
105
106 %description cpp -l pl.UTF-8
107 Wrapper cpp dla popplera.
108
109 %package cpp-devel
110 Summary:        Header files for cpp wrapper for poppler
111 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
112 Group:          Development/Libraries
113 Requires:       %{name}-cpp = %{version}-%{release}
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description cpp-devel
117 Header files for cpp wrapper for poppler.
118
119 %description cpp-devel -l pl.UTF-8
120 Pliki nagłówkowe wrappera cpp dla popplera.
121
122 %package cpp-static
123 Summary:        Static version of cpp wrapper for poppler
124 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
125 Group:          Development/Libraries
126 Requires:       %{name}-cpp-devel = %{version}-%{release}
127
128 %description cpp-static
129 Static version of cpp wrapper for poppler.
130
131 %description cpp-static -l pl.UTF-8
132 Statyczna wersja wrappera cpp dla popplera.
133
134 %package glib
135 Summary:        GLib wrapper for poppler
136 Summary(pl.UTF-8):      Wrapper GLib dla popplera
137 Group:          Libraries
138 Requires:       %{name} = %{version}-%{release}
139 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
140 Requires:       glib2 >= 1:2.18.0
141
142 %description glib
143 GLib wrapper for poppler.
144
145 %description glib -l pl.UTF-8
146 Wrapper GLib dla popplera.
147
148 %package glib-devel
149 Summary:        Header files for GLib wrapper for poppler
150 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
151 Group:          Development/Libraries
152 Requires:       %{name}-devel = %{version}-%{release}
153 Requires:       %{name}-glib = %{version}-%{release}
154 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
155 Requires:       glib2-devel >= 1:2.18.0
156
157 %description glib-devel
158 Header files for GLib wrapper for poppler.
159
160 %description glib-devel -l pl.UTF-8
161 Pliki nagłówkowe wrappera GLib dla popplera.
162
163 %package glib-static
164 Summary:        Static version of GLib wrapper for poppler
165 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
166 Group:          Development/Libraries
167 Requires:       %{name}-glib-devel = %{version}-%{release}
168
169 %description glib-static
170 Static version of GLib wrapper for poppler.
171
172 %description glib-static -l pl.UTF-8
173 Statyczna wersja wrappera GLib dla popplera.
174
175 %package qt
176 Summary:        Qt wrapper for poppler
177 Summary(pl.UTF-8):      Wrapper Qt dla popplera
178 Group:          Libraries
179 Requires:       %{name} = %{version}-%{release}
180
181 %description qt
182 Qt wrapper for poppler.
183
184 %description qt -l pl.UTF-8
185 Wrapper Qt dla popplera.
186
187 %package qt-devel
188 Summary:        Header files for Qt wrapper for poppler
189 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
190 Group:          Development/Libraries
191 Requires:       %{name}-devel = %{version}-%{release}
192 Requires:       %{name}-qt = %{version}-%{release}
193 Requires:       qt-devel
194
195 %description qt-devel
196 Header files for Qt wrapper for poppler.
197
198 %description qt-devel -l pl.UTF-8
199 Pliki nagłówkowe wrappera Qt dla popplera.
200
201 %package qt-static
202 Summary:        Static version of Qt wrapper for poppler
203 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
204 Group:          Development/Libraries
205 Requires:       %{name}-qt-devel = %{version}-%{release}
206
207 %description qt-static
208 Static version of Qt wrapper for poppler.
209
210 %description qt-static -l pl.UTF-8
211 Statyczna wersja wrappera Qt dla popplera.
212
213 %package Qt
214 Summary:        Qt4 wrapper for poppler
215 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       QtGui >= 4.4.0
219 Requires:       QtXml >= 4.4.0
220
221 %description Qt
222 Qt4 wrapper for poppler.
223
224 %description Qt -l pl.UTF-8
225 Wrapper Qt4 dla popplera.
226
227 %package Qt-devel
228 Summary:        Header files for Qt4 wrapper for poppler
229 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
230 Group:          Development/Libraries
231 Requires:       %{name}-Qt = %{version}-%{release}
232 Requires:       %{name}-devel = %{version}-%{release}
233 Requires:       QtGui-devel >= 4.4.0
234 Requires:       QtXml-devel >= 4.4.0
235
236 %description Qt-devel
237 Header files for Qt4 wrapper for poppler.
238
239 %description Qt-devel -l pl.UTF-8
240 Pliki nagłówkowe wrapper Qt4 dla popplera.
241
242 %package Qt-static
243 Summary:        Static version of Qt4 wrapper for poppler
244 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
245 Group:          Development/Libraries
246 Requires:       %{name}-Qt-devel = %{version}-%{release}
247
248 %description Qt-static
249 Static version of Qt4 wrapper for poppler.
250
251 %description Qt-static -l pl.UTF-8
252 Statyczna wersja wrappera Qt4 dla popplera.
253
254 %package progs
255 Summary:        Set of tools for viewing information and converting PDF files
256 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
257 Group:          Applications/Publishing
258 Provides:       pdftops
259 Obsoletes:      pdftohtml
260 Obsoletes:      pdftohtml-pdftops
261 Obsoletes:      poppler-utils
262 Obsoletes:      xpdf-tools
263
264 %description progs
265 Package contains utilites for PDF files. These utilities allow to
266 - extract information about PDF files
267 - extract images from PDF files
268 - convert PDF files to HTML, plain text and PS formats
269
270 %description progs -l pl.UTF-8
271 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
272 - wyświetlanie informacji o plikach PDF
273 - wydobywanie obrazków z plików PDF
274 - konwersję plików PDF do formatów takich jak HTML, PS czy też
275   czystego tekstu
276
277 %prep
278 %setup -q
279
280 # fix link with Qt 3 libraries
281 %{__sed} -i 's,(POPPLER_QT_LIBS),(libqt3_LIBS),' qt/Makefile.am
282
283 %build
284 %{?with_apidocs:%{__gtkdocize}}
285 %{__libtoolize}
286 %{__aclocal} -I m4
287 %{__autoconf} -f
288 %{__autoheader}
289 %{__automake}
290 %configure \
291         QTINC=%{_includedir}/qt \
292         QTLIB=%{_libdir} \
293         --disable-gtk-test \
294         %{!?with_cairo:--disable-cairo-output} \
295         %{!?with_qt:--disable-poppler-qt} \
296         %{!?with_qt4:--disable-poppler-qt4} \
297         %{!?with_cpp:--disable-poppler-cpp} \
298         %{!?with_glib:--disable-poppler-glib} \
299         --disable-silent-rules \
300         --enable-a4-paper \
301         %{?with_apidocs:--enable-gtk-doc} \
302         --enable-xpdf-headers \
303         --enable-zlib \
304         --enable-dependency-tracking \
305         --with-html-dir=%{_gtkdocdir}
306
307 %{__make}
308
309 %install
310 rm -rf $RPM_BUILD_ROOT
311
312 %{__make} install \
313         DESTDIR=$RPM_BUILD_ROOT
314
315 %if %{without apidocs}
316 # why it still installs them, brr
317 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
318 %endif
319
320 %clean
321 rm -rf $RPM_BUILD_ROOT
322
323 %post   -p /sbin/ldconfig
324 %postun -p /sbin/ldconfig
325
326 %post   cpp -p /sbin/ldconfig
327 %postun cpp -p /sbin/ldconfig
328
329 %post   glib -p /sbin/ldconfig
330 %postun glib -p /sbin/ldconfig
331
332 %post   qt -p /sbin/ldconfig
333 %postun qt -p /sbin/ldconfig
334
335 %post   Qt -p /sbin/ldconfig
336 %postun Qt -p /sbin/ldconfig
337
338 %files
339 %defattr(644,root,root,755)
340 %doc AUTHORS ChangeLog NEWS README* TODO
341 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
342 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.12
343
344 %files devel
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/libpoppler.so
347 %{_libdir}/libpoppler.la
348 %dir %{_includedir}/poppler
349 %{_includedir}/poppler/poppler-config.h
350 %{_includedir}/poppler/[ABCDEFGJLMNOPRSTUX]*.h
351 %{_includedir}/poppler/fofi
352 %{_includedir}/poppler/goo
353 %{_includedir}/poppler/splash
354 %exclude %{_includedir}/poppler/glib
355 %{_pkgconfigdir}/poppler.pc
356 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
357 %{_pkgconfigdir}/poppler-splash.pc
358
359 %files static
360 %defattr(644,root,root,755)
361 %{_libdir}/libpoppler.a
362
363 %if %{with apidocs}
364 %files apidocs
365 %defattr(644,root,root,755)
366 %{_gtkdocdir}/poppler
367 %endif
368
369 %if %{with cpp}
370 %files cpp
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
373 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
374
375 %files cpp-devel
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
378 %{_libdir}/libpoppler-cpp.la
379 %{_includedir}/poppler/cpp
380 %{_pkgconfigdir}/poppler-cpp.pc
381
382 %files cpp-static
383 %defattr(644,root,root,755)
384 %{_libdir}/libpoppler-cpp.a
385 %endif
386
387 %if %{with glib}
388 %files glib
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
391 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.6
392
393 %files glib-devel
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
396 %{_libdir}/libpoppler-glib.la
397 %{_includedir}/poppler/glib
398 %{_pkgconfigdir}/poppler-glib.pc
399
400 %files glib-static
401 %defattr(644,root,root,755)
402 %{_libdir}/libpoppler-glib.a
403 %endif
404
405 %if %{with qt}
406 %files qt
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
409 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.3
410
411 %files qt-devel
412 %defattr(644,root,root,755)
413 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
414 %{_libdir}/libpoppler-qt.la
415 %{_includedir}/poppler/qt3
416 %{_pkgconfigdir}/poppler-qt.pc
417
418 %files qt-static
419 %defattr(644,root,root,755)
420 %{_libdir}/libpoppler-qt.a
421 %endif
422
423 %if %{with qt4}
424 %files Qt
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
427 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
428
429 %files Qt-devel
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
432 %{_libdir}/libpoppler-qt4.la
433 %{_includedir}/poppler/qt4
434 %{_pkgconfigdir}/poppler-qt4.pc
435
436 %files Qt-static
437 %defattr(644,root,root,755)
438 %{_libdir}/libpoppler-qt4.a
439 %endif
440
441 %files progs
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_bindir}/pdf*
444 %{_mandir}/man1/pdf*
This page took 0.079717 seconds and 4 git commands to generate.