]> git.pld-linux.org Git - packages/physfs.git/blob - physfs.spec
- updated cmake version
[packages/physfs.git] / physfs.spec
1 Summary:        PhysicsFS file abstraction layer for games
2 Summary(pl.UTF-8):      PhysicsFS - warstwa abstrakcji plików dla gier
3 Name:           physfs
4 Version:        3.0.2
5 Release:        1
6 License:        BSD-like (see LICENSE)
7 Group:          Libraries
8 Source0:        http://www.icculus.org/physfs/downloads/%{name}-%{version}.tar.bz2
9 # Source0-md5:  dc751294aaf59d1359bbe34e693d1d87
10 URL:            http://www.icculus.org/physfs/
11 BuildRequires:  cmake >= 2.8.4
12 BuildRequires:  doxygen
13 BuildRequires:  ncurses-devel
14 BuildRequires:  readline-devel
15 BuildRequires:  rpmbuild(macros) >= 1.605
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 PhysicsFS is a library to provide abstract access to various archives.
21 It is intended for use in video games, and the design was somewhat
22 inspired by Quake 3's file subsystem. The programmer defines a "write
23 directory" on the physical filesystem. No file writing done through
24 the PhysicsFS API can leave that write directory, for security. For
25 example, an embedded scripting language cannot write outside of this
26 path if it uses PhysFS for all of its I/O, which means that untrusted
27 scripts can run more safely. Symbolic links can be disabled as well,
28 for added safety. For file reading, the programmer lists directories
29 and archives that form a "search path". Once the search path is
30 defined, it becomes a single, transparent hierarchical filesystem.
31 This makes for easy access to ZIP files in the same way as you access
32 a file directly on the disk, and it makes it easy to ship a new
33 archive that will override a previous archive on a per-file basis.
34 Finally, PhysicsFS gives you platform-abstracted means to determine if
35 CD-ROMs are available, the user's home directory, where in the real
36 filesystem your program is running, etc.
37
38 %description -l pl.UTF-8
39 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
40 archiwów. Została stworzona z myślą o grach video, a projekt był
41 trochę wzorowany na podsystemie plików z Quake 3. Programista
42 definiuje "katalog zapisu" w fizycznym systemie plików. Żaden zapis do
43 pliku poprzez API PhysicsFS nie może wyjść poza ten katalog - ze
44 względu na bezpieczeństwo. Na przykład, wbudowany język skryptowy nie
45 może zapisywać poza tą ścieżką, jeżeli używa PhysicsFS do wszystkich
46 operacji wejścia/wyjścia, dzięki czemu można bezpiecznie uruchamiać
47 nie zaufane skrypty. Dowiązania symboliczne także mogą być wyłączone
48 dla poprawy bezpieczeństwa. Do odczytu pliku programista podaje
49 katalogi i archiwa, które składają się na "ścieżkę poszukiwań". Po
50 zdefiniowaniu tej ścieżki, staje się ona pojedynczym, przezroczystym
51 hierarchicznym systemem plików. Pozwala to na łatwy dostęp do plików
52 ZIP w taki sam sposób, jak do plików na dysku, a także ułatwia
53 dostarczenie nowego archiwum, które przykryje poprzednie na poziomie
54 plików. Ponadto PhysicsFS daje wyabstrahowane od platformy sposoby na
55 określenie, czy dostępne są CD-ROMy, katalog domowy użytkownika, gdzie
56 w prawdziwym systemie plików działa program itp.
57
58 %package devel
59 Summary:        Header files for PhysicsFS development
60 Summary(pl.UTF-8):      Pliki nagłówkowe do programowania z użyciem PhysicsFS
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       zlib-devel
64
65 %description devel
66 PhysicsFS is a library to provide abstract access to various archives.
67 This package contains the development headers and documentaion to
68 build programs using PhysicsFS.
69
70 %description devel -l pl.UTF-8
71 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
72 archiwów. Ten pakiet zawiera pliki nagłówkowe i dokumentację do
73 budowania programów z użyciem PhysicsFS.
74
75 %package static
76 Summary:        Static PhysicsFS libraries
77 Summary(pl.UTF-8):      Statyczne biblioteki PhysicsFS
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 PhysicsFS is a library to provide abstract access to various archives.
83 This package contains the static PhysicsFS libraries.
84
85 %description static -l pl.UTF-8
86 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
87 archiwów. Ten pakiet zawiera statyczne biblioteki PhysicsFS.
88
89 %package programs
90 Summary:        Program for testing PhysicsFS archives
91 Summary(pl.UTF-8):      Program do testowania archiwów PhysicsFS
92 Group:          Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94
95 %description programs
96 PhysicsFS is a library to provide abstract access to various archives.
97 This package contains the programs using for PhysicsFS archives
98 testing.
99
100 %description programs -l pl.UTF-8
101 PhysicsFS to biblioteka udostępniająca abstrakcyjny dostęp do różnych
102 archiwów. Ten pakiet zawiera program używany do testowania archiwów
103 PhysicsFS.
104
105 %prep
106 %setup -q
107
108 %build
109 %cmake . \
110         -DCMAKE_CXX_COMPILER_WORKS=1 \
111         -DCMAKE_CXX_COMPILER="%{__cc}"
112
113 %{__make}
114
115 doxygen
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_mandir}/man3
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 cp -p docs/man/man3/{PHYS*,phys*} $RPM_BUILD_ROOT%{_mandir}/man3
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc docs/{CHANGELOG.txt,CREDITS.txt,TODO.txt} LICENSE.txt
135 %attr(755,root,root) %{_libdir}/libphysfs.so.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libphysfs.so.1
137
138 %files devel
139 %defattr(644,root,root,755)
140 %doc docs/html
141 %attr(755,root,root) %{_libdir}/libphysfs.so
142 %{_includedir}/physfs.h
143 %{_mandir}/man3/PHYSFS_*.3*
144 %{_mandir}/man3/physfs.h.3*
145 %{_pkgconfigdir}/physfs.pc
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libphysfs.a
150
151 %files programs
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/test_physfs
This page took 0.134154 seconds and 4 git commands to generate.