]> git.pld-linux.org Git - packages/php-phpmailer.git/commitdiff
- up to 5.1 auto/ac/php-phpmailer-5_1-1 auto/th/php-phpmailer-5_1-1
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 26 May 2010 15:06:39 +0000 (15:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    paths.patch -> 1.2
    php-phpmailer.spec -> 1.17
    phpmailer-update-et.patch -> 1.2

paths.patch
php-phpmailer.spec
phpmailer-update-et.patch

index 6ed10fffc3ab6415da46cbe9419850cb995cf1d4..ae24ca770548eb291925642853b91e84c9a97356 100644 (file)
@@ -1,5 +1,5 @@
---- phpMailer_v2.3/class.phpmailer.php~        2010-01-12 16:05:45.000000000 +0200
-+++ phpMailer_v2.3/class.phpmailer.php 2010-01-12 16:05:46.997539898 +0200
+--- PHPMailer_v5.1/class.phpmailer.php~        2010-05-26 17:37:24.000000000 +0300
++++ PHPMailer_v5.1/class.phpmailer.php 2010-05-26 17:37:48.416133079 +0300
 @@ -134,7 +134,7 @@
     * is in a different directory than the PHP include path.
     * @var string
@@ -9,12 +9,12 @@
  
    /**
     * Holds PHPMailer version.
-@@ -663,7 +663,7 @@
-    * @access public
-    * @return bool
-    */
--  function SetLanguage($lang_type = 'en', $lang_path = 'language/') {
-+  function SetLanguage($lang_type = 'en', $lang_path = '/usr/share/php/phpmailer/language/') {
-     if( !(@include $lang_path.'phpmailer.lang-'.$lang_type.'.php') ) {
-       $PHPMAILER_LANG = array();
-       $PHPMAILER_LANG["provide_address"]      = 'You must provide at least one ' .
+@@ -847,7 +847,7 @@
+   * @param string $lang_path Path to the language file directory
+   * @access public
+   */
+-  function SetLanguage($langcode = 'en', $lang_path = 'language/') {
++  function SetLanguage($langcode = 'en', $lang_path = '/usr/share/php/phpmailer/language/') {
+     //Define full set of translatable strings
+     $PHPMAILER_LANG = array(
+       'provide_address' => 'You must provide at least one recipient email address.',
index a8f485fc79d66cb25e304303a9d1670d44f0baba..b57b62aeb2d8b82d389b2f0b08c82e0dcf20bce3 100644 (file)
@@ -1,17 +1,17 @@
-%define                php_min_version 5.1.0
+%define                php_min_version 5.2.0
 %include       /usr/lib/rpm/macros.php
 Summary:       Full featured email transfer class for PHP
 Summary(pl.UTF-8):     W pełni funkcjonalna klasa PHP do przesyłania e-maili
 Name:          php-phpmailer
-Version:       2.3
-Release:       2
-License:       LGPL
+Version:       5.1
+Release:       1
+License:       LGPL v2.1
 Group:         Development/Languages/PHP
-Source0:       http://downloads.sourceforge.net/phpmailer/phpMailer_v%{version}.tar.gz
-# Source0-md5: 897f53ab746c48f372364b7745d8d468
+Source0:       http://downloads.sourceforge.net/project/phpmailer/phpmailer%20for%20php5_6/PHPMailer%20v%{version}/PHPMailer_v%{version}.tar.gz
+# Source0-md5: 6e81fc229f88f7d9dd7cf70d65296ef8
 Patch0:                paths.patch
 Patch1:                phpmailer-update-et.patch
-URL:           http://phpmailer.codeworxtech.com/
+URL:           http://phpmailer.worxware.com/index.php?pg=phpmailer
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.520
 Requires:      php-common >= 4:%{php_min_version}
@@ -25,8 +25,11 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _appdir         %{php_data_dir}/phpmailer
 
-# Exclude optional PHP extension dependencies
-%define                _noautoreq      php-openssl php-mbstring
+# exclude optional php dependencies
+%define                _noautophp      php-openssl php-mbstring php-filter
+
+# put it together for rpmbuild
+%define                _noautoreq      %{?_noautophp} %{?_noautopear}
 
 %description
 PHP email transport class featuring multiple file attachments, SMTP
@@ -41,7 +44,7 @@ itp. Potrafi wysyłać pocztę przez sendmaila, funkcją PHP mail() albo
 poprzez SMTP. Metody są oparte na popularnym komponencie AspEmail.
 
 %prep
-%setup -q -n phpMailer_v%{version}
+%setup -q -n PHPMailer_v%{version}
 %patch0 -p1
 %patch1 -p1
 
@@ -67,16 +70,16 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog.txt README LICENSE docs/*
+%doc changelog.txt README docs/*
 %{php_data_dir}/class.phpmailer.php
 
 %dir %{_appdir}
 %{_appdir}/class.pop3.php
 %{_appdir}/class.smtp.php
 %dir %{_appdir}/language
-%{_appdir}/language/phpmailer.lang-en.php
 %lang(ar) %{_appdir}/language/phpmailer.lang-ar.php
 %lang(ca) %{_appdir}/language/phpmailer.lang-ca.php
+%lang(ch) %{_appdir}/language/phpmailer.lang-ch.php
 %lang(cs) %{_appdir}/language/phpmailer.lang-cz.php
 %lang(da) %{_appdir}/language/phpmailer.lang-dk.php
 %lang(de) %{_appdir}/language/phpmailer.lang-de.php
@@ -96,5 +99,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ru) %{_appdir}/language/phpmailer.lang-ru.php
 %lang(sv) %{_appdir}/language/phpmailer.lang-se.php
 %lang(tr) %{_appdir}/language/phpmailer.lang-tr.php
+%lang(zh) %{_appdir}/language/phpmailer.lang-zh.php
+%lang(zh_CN) %{_appdir}/language/phpmailer.lang-zh_cn.php
 
 %{_examplesdir}/%{name}-%{version}
index 18d8b741d28c4d0d1a8a24004664b280b4e10a76..26f2707f98027c30db73d4d8540536fcb5ac1294 100644 (file)
@@ -1,13 +1,36 @@
---- phpmailer/language/phpmailer.lang-et.php~  2010-01-12 16:08:02.000000000 +0200
-+++ phpmailer/language/phpmailer.lang-et.php   2010-01-12 16:25:39.874296467 +0200
-@@ -18,7 +18,5 @@
- $PHPMAILER_LANG["connect_host"]         = 'SMTP Viga: Ei &otilde;nnestunud luua &uuml;hendust SMTP serveriga.';
- $PHPMAILER_LANG["file_access"]          = 'Pole piisavalt &otilde;iguseid j&auml;rgneva faili avamiseks: ';
- $PHPMAILER_LANG["file_open"]            = 'Faili Viga: Faili avamine eba&otilde;nnestus: ';
--$PHPMAILER_LANG["encoding"]             = 'Tundmatu Unknown kodeering: ';
--$PHPMAILER_LANG["signing"]              = 'Signing Error: ';
--
+--- PHPMailer_v5.1/language/phpmailer.lang-et.php~     2010-05-26 17:41:44.000000000 +0300
++++ PHPMailer_v5.1/language/phpmailer.lang-et.php      2010-05-26 17:42:42.706466459 +0300
+@@ -3,24 +3,24 @@
+ * PHPMailer language file: refer to English translation for definitive list
+ * Estonian Version
+ * By Indrek Päri
++* Revised By Elan Ruusamäe <glen@delfi.ee>
+ */
+ $PHPMAILER_LANG['authenticate']         = 'SMTP Viga: Autoriseerimise viga.';
+ $PHPMAILER_LANG['connect_host']         = 'SMTP Viga: Ei õnnestunud luua ühendust SMTP serveriga.';
+ $PHPMAILER_LANG['data_not_accepted']    = 'SMTP Viga: Vigased andmed.';
+-//$PHPMAILER_LANG['empty_message']        = 'Message body empty';
+-$PHPMAILER_LANG['encoding']             = 'Tundmatu Unknown kodeering: ';
++$PHPMAILER_LANG['empty_message']        = 'Tühi kirja sisu';
++$PHPMAILER_LANG["encoding"]             = 'Tundmatu kodeering: ';
+ $PHPMAILER_LANG['execute']              = 'Tegevus ebaõnnestus: ';
+ $PHPMAILER_LANG['file_access']          = 'Pole piisavalt õiguseid järgneva faili avamiseks: ';
+ $PHPMAILER_LANG['file_open']            = 'Faili Viga: Faili avamine ebaõnnestus: ';
+ $PHPMAILER_LANG['from_failed']          = 'Järgnev saatja e-posti aadress on vigane: ';
+ $PHPMAILER_LANG['instantiate']          = 'mail funktiooni käivitamine ebaõnnestus.';
+-//$PHPMAILER_LANG['invalid_email']        = 'Not sending, email address is invalid: ';
++$PHPMAILER_LANG['invalid_email']        = 'Saatmine peatatud, e-posti address vigane: ';
+ $PHPMAILER_LANG['provide_address']      = 'Te peate määrama vähemalt ühe saaja e-posti aadressi.';
+ $PHPMAILER_LANG['mailer_not_supported'] = ' maileri tugi puudub.';
+ $PHPMAILER_LANG['recipients_failed']    = 'SMTP Viga: Järgnevate saajate e-posti aadressid on vigased: ';
+-//$PHPMAILER_LANG['signing']              = 'Signing Error: ';
+-//$PHPMAILER_LANG['smtp_connect_failed']  = 'SMTP Connect() failed.';
+-//$PHPMAILER_LANG['smtp_error']           = 'SMTP server error: ';
+-//$PHPMAILER_LANG['variable_set']         = 'Cannot set or reset variable: ';
 -?>
 \ No newline at end of file
-+$PHPMAILER_LANG["encoding"]             = 'Tundmatu kodeering: ';
 +$PHPMAILER_LANG["signing"]              = 'Viga allkirjastamisel: ';
++$PHPMAILER_LANG['smtp_connect_failed']  = 'SMTP Connect() ebaõnnestus.';
++$PHPMAILER_LANG['smtp_error']           = 'SMTP serveri viga: ';
++$PHPMAILER_LANG['variable_set']         = 'Ei õnnestunud määrata või lähtestada muutujat: ';
This page took 0.101293 seconds and 4 git commands to generate.