]> git.pld-linux.org Git - packages/php-pear-XML_HTMLSax.git/blob - php-pear-XML_HTMLSax.spec
- pl fixes, cosmetics
[packages/php-pear-XML_HTMLSax.git] / php-pear-XML_HTMLSax.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          XML
3 %define         _subclass       HTMLSax
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - a SAX based parser for HTML and other badly formed XML documents
8 Summary(pl):    %{_pearname} - analizator SAX dla HTML-a i innych ¼le sformu³owanych dokumentów XML
9 Name:           php-pear-%{_pearname}
10 Version:        2.1.2
11 Release:        1
12 License:        PHP
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  f2cd9ea8ed1c59cc3046675d41c7cf98
16 URL:            http://pear.php.net/package/XML_HTMLSax/
17 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
18 Requires:       php-pear
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 XML_HTMLSax is a SAX based XML parser for badly formed XML documents,
24 such as HTML. The original code base was developed by Alexander Zhukov
25 and published at http://sourceforge.net/projects/phpshelve/, who in
26 turn was inspired by the Python HTMLSax package. Alexander kindly gave
27 permission to modify the code and license for inclusion in PEAR.
28 PEAR::XML_HTMLSax takes the last release from Sourceforge
29 (HTMLSax2002082201) and changes the API to make using HTMLSax very
30 similar to using the native PHP Expat extension, opening it up for use
31 with projects like SAX filters:
32 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
33 This version also fixes some bugs and adds further features such as
34 the ability to handle processing instructions and JSP/ASP markup.
35
36 This class has in PEAR status: %{_status}.
37
38 %description -l pl
39 XML_HTMLSax to oparty na SAX analizator XML-a dla ¼le sformu³owanych
40 dokumentów XML, takich jak HTML. Oryginalny kod zosta³ stworzony przez
41 Alexandra Zhukova i opublikowany pod
42 http://sourceforge.net/projects/phpshelve/, który z kolei by³
43 inspirowany pakietem HTMLSax dla Pythona. Alexander pozwoli³ na
44 modyfikowanie kodu i licencjonowanie do w³±czenia do PEAR.
45 PEAR::XML_HTMLSax wywodzi siê z ostatniej wersji z Sourceforge
46 (HTMLSax2002082201) i ma zmienione API, aby mo¿na by³o u¿ywaæ HTMLSax
47 bardzo podobnie do natywnego rozszerzenia PHP Expat, pozwalaj±c na
48 u¿ywanie w projektach typu filtry SAX:
49 http://phpxmlclasses.sourceforge.net/show_doc.php?class=class_sax_filters.html.
50 Ta wersja dodatkowo poprawia kilka b³êdów i dodaje nowe mo¿liwo¶ci,
51 takie jak obs³uga przetwarzania instrukcji i znaczników JSP/ASP.
52
53 Ta klasa ma w PEAR status: %{_status}.
54
55 %prep
56 %setup -q -c
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
61
62 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
63 install %{_pearname}-%{version}/%{_subclass}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc %{_pearname}-%{version}/docs
71 %dir %{php_pear_dir}/%{_class}/%{_subclass}
72 %{php_pear_dir}/%{_class}/*.php
73 %{php_pear_dir}/%{_class}/%{_subclass}/*.php
This page took 0.063383 seconds and 4 git commands to generate.