3 %bcond_without tests # unit tests
6 %define pnam build-perl
7 Summary: Calculate dependencies for Perl sources
8 Summary(pl.UTF-8): Znajdowanie zależności dla źródeł perlowych
9 Name: perl-rpm-build-perl
13 Group: Development/Languages/Perl
14 Source0: https://www.cpan.org/modules/by-authors/id/A/AT/ATOURBIN/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5: 1cfb4f6a0842d04ef39fd945abacce91
16 # https://rt.cpan.org/Ticket/Attachment/1513584/807128/rpm-build-perl-0.82-Adjust-to-perl-5.22.patch
17 Patch0: %{name}-perl5.22.patch
18 # https://rt.cpan.org/Ticket/Attachment/1213691/640915/0001-Fix-non-deterministic-failures-on-newer-perls.patch
19 Patch1: %{name}-non-deterministic-failures.patch
21 Patch2: rpm-build-perl-0.82-Port-to-OpSIBLING-like-macros-required-since-Perl-5..patch
23 Patch3: rpm-build-perl-Adapt-tests-to-Perl-5.35.12.patch
24 URL: https://metacpan.org/dist/rpm-build-perl
25 BuildRequires: perl-devel >= 1:5.8.0
26 BuildRequires: rpm-perlprov >= 4.1-13
27 BuildRequires: rpmbuild(macros) >= 1.745
29 BuildRequires: perl-Encode
30 BuildRequires: perl-Test-Simple
32 BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35 Calculate dependencies for Perl sources.
37 %description -l pl.UTF-8
38 Moduł ten znajduje zależności dla źródeł perlowych.
41 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %{__perl} Makefile.PL \
52 OPTIMIZE="%{rpmcflags}"
54 %{?with_tests:%{__make} test}
57 rm -rf $RPM_BUILD_ROOT
59 %{__make} pure_install \
60 DESTDIR=$RPM_BUILD_ROOT
63 rm -rf $RPM_BUILD_ROOT
66 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_bindir}/perl.clean
69 %attr(755,root,root) %{_bindir}/perl.prov
70 %attr(755,root,root) %{_bindir}/perl.prov.files
71 %attr(755,root,root) %{_bindir}/perl.req
72 %attr(755,root,root) %{_bindir}/perl.req.files
73 %{perl_vendorarch}/B/Clobbers.pm
74 %{perl_vendorarch}/B/ConstOptree.pm
75 %{perl_vendorarch}/B/PerlReq.pm
76 %{perl_vendorarch}/B/Walker.pm
77 %dir %{perl_vendorarch}/PerlReq
78 %{perl_vendorarch}/PerlReq/Utils.pm
79 %{perl_vendorarch}/fake.pm
80 %dir %{perl_vendorarch}/auto/B
81 %dir %{perl_vendorarch}/auto/B/ConstOptree
82 %attr(755,root,root) %{perl_vendorarch}/auto/B/ConstOptree/ConstOptree.so
83 %{_mandir}/man1/perl.prov.1p*
84 %{_mandir}/man1/perl.req.1p*
85 %{_mandir}/man3/B::Clobbers.3pm*
86 %{_mandir}/man3/B::ConstOptree.3pm*
87 %{_mandir}/man3/B::PerlReq.3pm*
88 %{_mandir}/man3/B::Walker.3pm*
89 %{_mandir}/man3/PerlReq::Utils.3pm*