]> git.pld-linux.org Git - packages/perl-namespace-autoclean.git/blob - perl-namespace-autoclean.spec
R: perl(Sub::Identify); rel 2
[packages/perl-namespace-autoclean.git] / perl-namespace-autoclean.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    namespace
6 %define pnam    autoclean
7 Summary:        namespace::autoclean removes all imported symbols at the end of compile cycle
8 Summary(pl.UTF-8):      namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec cyklu kompilacji
9 Name:           perl-namespace-autoclean
10 Version:        0.29
11 Release:        2
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/namespace/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  39b38c776cd1f0ee03cc70781a2f2798
16 URL:            https://metacpan.org/release/namespace-autoclean
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl-B-Hooks-EndOfScope >= 0.12
22 BuildRequires:  perl-Sub-Identify
23 BuildRequires:  perl-Test-Requires
24 BuildRequires:  perl-Test-Simple >= 0.88
25 BuildRequires:  perl-namespace-clean >= 0.20
26 %endif
27 Requires:       perl(Sub::Identify)
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 When you import a function into a Perl package, it will naturally also
33 be available as a method.
34
35 The namespace::autoclean pragma will remove all imported symbols at
36 the end of the current package's compile cycle. Functions called in
37 the package itself will still be bound by their name, but they won't
38 show up as methods on your class or instances.
39
40 This module is very similar to namespace::clean, except it will clean
41 all imported functions, no matter if you imported them before or after
42 you used the pagma. It will also not touch anything that looks like a
43 method, according to Class::MOP::Class::get_method_list.
44
45 %description -l pl.UTF-8
46 namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec
47 cyklu kompilacji
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/namespace/*.pm
72 %{_mandir}/man3/*
This page took 0.09896 seconds and 4 git commands to generate.