]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
up to 6.54
[packages/perl-libwww.git] / perl-libwww.spec
index 3c11a5df88fcae4fb4c7970703c90f48db737033..6af74870b2dc082aacbe69089377e6a75c405902 100644 (file)
@@ -1,36 +1,67 @@
 #
 # Conditional build:
-%bcond_with    tests   # perform "make test"
+%bcond_with    tests   # perform "make test" (uses network)
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    WWW
 %define                pnam    libwww-perl
 Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
 Summary(pl.UTF-8):     libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.808
-Release:       3
+Version:       6.54
+Release:       1
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-# Source0-md5: 72120d9195ab1649c2d787eb1102a90c
-URL:           http://search.cpan.org/dist/libwww-perl/
+Source0:       https://www.cpan.org/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
+# Source0-md5: aea3e2a207b128371db0ef0f86229667
+URL:           https://metacpan.org/release/libwww-perl
+BuildRequires: perl-CPAN-Meta-Requirements >= 2.120_620
+BuildRequires: perl-devel >= 1:5.8.8
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
+%if %{with tests}
 BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
+BuildRequires: perl-Encode >= 2.12
+BuildRequires: perl-Encode-Locale
+BuildRequires: perl-File-Listing >= 6
 BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-HTTP-Cookies >= 6
+BuildRequires: perl-HTTP-Daemon >= 6.12
+BuildRequires: perl-HTTP-Date >= 6
+BuildRequires: perl-HTTP-Message >= 6.07
+BuildRequires: perl-HTTP-Negotiate >= 6
+BuildRequires: perl-LWP-MediaTypes >= 6
 BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-Net-HTTP >= 6.18
+BuildRequires: perl-Test-Fatal
+BuildRequires: perl-Test-Needs
+BuildRequires: perl-Test-RequiresInternet
+BuildRequires: perl-Test-Simple
 BuildRequires: perl-URI >= 1.10
-BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-WWW-RobotRules >= 6
 BuildRequires: perl-libnet
-BuildRequires: rpm-perlprov >= 4.1-13
-Suggests:      perl-IO-Socket-SSL
+%endif
+Requires:      perl-File-Listing >= 6
+Requires:      perl-HTTP-Cookies >= 6
+Requires:      perl-HTTP-Daemon >= 6.12
+Requires:      perl-HTTP-Date >= 6
+Requires:      perl-HTTP-Message >= 6
+Requires:      perl-HTTP-Negotiate >= 6
+Requires:      perl-LWP-MediaTypes >= 6
+Requires:      perl-MIME-Base64 >= 2.1
+Requires:      perl-Net-HTTP >= 6.18
+Requires:      perl-URI >= 1.10
+Requires:      perl-WWW-RobotRules >= 6
+Provides:      perl(LWP::Debug::TraceHTTP::Socket) = %{version}
+Provides:      perl(LWP::Protocol::http::Socket) = %{version}
+Provides:      perl(LWP::Protocol::http::SocketMethods) = %{version}
 Obsoletes:     perl-libwww-perl
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # modules not always required
-%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
+%define        _noautoreq_perl HTTP::GHTTP Authen::NTLM
 
 %description
 The libwww-perl collection is a set of Perl modules which provides a
@@ -60,28 +91,42 @@ yes | %{__perl} Makefile.PL \
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
 for file in GET HEAD POST; do
        ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
-       rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
        echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
 done
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README*
-%{perl_vendorlib}/*.pm
-%{perl_vendorlib}/File/*
-%{perl_vendorlib}/HTML/*
-%{perl_vendorlib}/HTTP/*
-%{perl_vendorlib}/Net/*
-%{perl_vendorlib}/LWP
-%{perl_vendorlib}/WWW/*
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
-%{_mandir}/man3/[!B]*
+%doc Changes README.SSL
+%attr(755,root,root) %{_bindir}/GET
+%attr(755,root,root) %{_bindir}/HEAD
+%attr(755,root,root) %{_bindir}/POST
+%attr(755,root,root) %{_bindir}/lwp-*
+%{perl_vendorlib}/LWP.pm
+%{perl_vendorlib}/LWP/Authen
+%{perl_vendorlib}/LWP/ConnCache.pm
+%{perl_vendorlib}/LWP/Debug.pm
+%dir %{perl_vendorlib}/LWP/Debug
+%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
+%{perl_vendorlib}/LWP/DebugFile.pm
+%{perl_vendorlib}/LWP/MemberMixin.pm
+%{perl_vendorlib}/LWP/Protocol.pm
+%{perl_vendorlib}/LWP/Protocol
+%{perl_vendorlib}/LWP/RobotUA.pm
+%{perl_vendorlib}/LWP/Simple.pm
+%{perl_vendorlib}/LWP/UserAgent.pm
+%{_mandir}/man1/GET.1p*
+%{_mandir}/man1/HEAD.1p*
+%{_mandir}/man1/POST.1p*
+%{_mandir}/man1/lwp-*.1p*
+%{_mandir}/man3/LWP*.3pm*
+%{_mandir}/man3/libwww::lwpcook.3pm*
+%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.176734 seconds and 4 git commands to generate.