]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- autoupdated to 5.69
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl):    libwww-perl - prosty i logiczny API do WWW 
10 Name:           perl-libwww
11 Version:        5.69
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 BuildRequires:  perl(Net::FTP) >= 2.58
18 BuildRequires:  perl-Digest-MD5
19 BuildRequires:  perl-HTML-Parser
20 BuildRequires:  perl-MIME-Base64
21 BuildRequires:  perl-URI
22 BuildRequires:  perl-libnet
23 BuildRequires:  rpm-perlprov >= 3.0.3-18
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      perl-libwww-perl
27
28 # modules not always required
29 %define _noautoreq "perl(HTML::Parse)" "perl(HTML::FormatPS)" "perl(HTML::FormatText)" "perl(HTTP::GHTTP)" "perl(IO::Socket::SSL)" "perl(Mail::Internet)" "perl(Authen::NTLM)"
30
31 %description
32 The libwww-perl collection is a set of Perl modules which provides a
33 simple and consistent application programming interface to the World-Wide
34 Web. The main focus of the library is to provide classes and functions
35 that allow you to write WWW clients. The library also contain modules
36 that are of more general use and even classes that help you implement
37 simple HTTP servers.
38
39 %description -l pl
40 libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
41 do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
42 klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
43 tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
44 na implementacjê prostego serwera HTTP.
45
46 %prep
47 %setup -q -n libwww-perl-%{version}
48
49 %build
50 perl Makefile.PL </dev/null
51 %{__make}
52
53 %{?_with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README*
66 %{perl_sitelib}/*.pm
67 %{perl_sitelib}/File/*
68 %{perl_sitelib}/HTML/*
69 %{perl_sitelib}/HTTP/*
70 %{perl_sitelib}/Net/*
71 %{perl_sitelib}/LWP
72 %{perl_sitelib}/WWW/*
73 %attr(755,root,root) %{_bindir}/*
74 %{_mandir}/man1/*
75 %{_mandir}/man3/[^B]*
This page took 0.075398 seconds and 4 git commands to generate.