]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- standarized Source0 URL
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl):    libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        5.801
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  eda011c6b5483d2d7443dd737cf03118
18 URL:            http://search.cpan.org/dist/libwww-perl/
19 BuildRequires:  perl(Net::FTP) >= 2.58
20 BuildRequires:  perl-Digest-MD5
21 BuildRequires:  perl-HTML-Parser >= 3.33
22 BuildRequires:  perl-MIME-Base64 >= 2.1
23 BuildRequires:  perl-URI >= 1.10
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  perl-libnet
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29 Obsoletes:      perl-libwww-perl
30
31 # modules not always required
32 %define _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
33
34 %description
35 The libwww-perl collection is a set of Perl modules which provides a
36 simple and consistent application programming interface to the World-Wide
37 Web. The main focus of the library is to provide classes and functions
38 that allow you to write WWW clients. The library also contain modules
39 that are of more general use and even classes that help you implement
40 simple HTTP servers.
41
42 %description -l pl
43 libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
44 do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
45 klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
46 tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
47 na implementacjê prostego serwera HTTP.
48
49 %prep
50 %setup -q -n libwww-perl-%{version}
51
52 %build
53 %{__perl} Makefile.PL </dev/null \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README*
71 %{perl_vendorlib}/*.pm
72 %{perl_vendorlib}/File/*
73 %{perl_vendorlib}/HTML/*
74 %{perl_vendorlib}/HTTP/*
75 %{perl_vendorlib}/Net/*
76 %{perl_vendorlib}/LWP
77 %{perl_vendorlib}/WWW/*
78 %attr(755,root,root) %{_bindir}/*
79 %{_mandir}/man1/*
80 %{_mandir}/man3/[!B]*
This page took 0.052415 seconds and 4 git commands to generate.