]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- version 5.822
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl.UTF-8):      libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        5.822
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5b5856e0d61abb75fb5f52ed1678161f
18 URL:            http://search.cpan.org/dist/libwww-perl/
19 BuildRequires:  perl(Net::FTP) >= 2.58
20 BuildRequires:  perl-Digest-MD5
21 BuildRequires:  perl-HTML-Parser >= 3.33
22 BuildRequires:  perl-MIME-Base64 >= 2.1
23 BuildRequires:  perl-URI >= 1.10
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  perl-libnet
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 Suggests:       perl-IO-Socket-SSL
28 Obsoletes:      perl-libwww-perl
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # modules not always required
33 %define _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
34
35 %description
36 The libwww-perl collection is a set of Perl modules which provides a
37 simple and consistent application programming interface to the
38 World-Wide Web. The main focus of the library is to provide classes
39 and functions that allow you to write WWW clients. The library also
40 contain modules that are of more general use and even classes that
41 help you implement simple HTTP servers.
42
43 %description -l pl.UTF-8
44 libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
45 do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
46 udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
47 Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
48 nawet klasy, pozwalające na implementację prostego serwera HTTP.
49
50 %prep
51 %setup -q -n libwww-perl-%{version}
52
53 %build
54 yes | %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 for file in GET HEAD POST; do
67         ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
68         rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
69         echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
70 done
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README*
78 %{perl_vendorlib}/*.pm
79 %{perl_vendorlib}/File/*
80 %{perl_vendorlib}/HTML/*
81 %{perl_vendorlib}/HTTP/*
82 %{perl_vendorlib}/Net/*
83 %{perl_vendorlib}/LWP
84 %{perl_vendorlib}/WWW/*
85 %attr(755,root,root) %{_bindir}/*
86 %{_mandir}/man1/*
87 %{_mandir}/man3/[!B]*
This page took 0.060871 seconds and 4 git commands to generate.