]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- Up to 6.02
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl.UTF-8):      libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        6.02
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/WWW/GAAS/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4617dbc79a78992a8c8db263c170d8ec
18 URL:            http://search.cpan.org/dist/libwww-perl/
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Net::FTP) >= 2.58
23 BuildRequires:  perl-Digest-MD5
24 BuildRequires:  perl-Encode >= 2.12
25 BuildRequires:  perl-Encode-Locale
26 BuildRequires:  perl-File-Listing >= 6
27 BuildRequires:  perl-HTML-Parser >= 3.33
28 BuildRequires:  perl-HTTP-Cookies >= 6
29 BuildRequires:  perl-HTTP-Daemon >= 6
30 BuildRequires:  perl-HTTP-Date >= 6
31 BuildRequires:  perl-HTTP-Message >= 6
32 BuildRequires:  perl-HTTP-Negotiate >= 6
33 BuildRequires:  perl-LWP-MediaTypes >= 6
34 BuildRequires:  perl-MIME-Base64 >= 2.1
35 BuildRequires:  perl-Net-HTTP >= 6
36 BuildRequires:  perl-URI >= 1.10
37 BuildRequires:  perl-WWW-RobotRules >= 6
38 BuildRequires:  perl-libnet
39 %endif
40 Requires:       perl-File-Listing >= 6
41 Requires:       perl-HTTP-Cookies >= 6
42 Requires:       perl-HTTP-Daemon >= 6
43 Requires:       perl-HTTP-Date >= 6
44 Requires:       perl-HTTP-Message >= 6
45 Requires:       perl-HTTP-Negotiate >= 6
46 Requires:       perl-LWP-MediaTypes >= 6
47 Requires:       perl-MIME-Base64 >= 2.1
48 Requires:       perl-Net-HTTP >= 6
49 Requires:       perl-URI >= 1.10
50 Requires:       perl-WWW-RobotRules >= 6
51 Obsoletes:      perl-libwww-perl
52 BuildArch:      noarch
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # modules not always required
56 %define _noautoreq 'perl(HTTP::GHTTP)' 'perl(Authen::NTLM)'
57
58 %description
59 The libwww-perl collection is a set of Perl modules which provides a
60 simple and consistent application programming interface to the
61 World-Wide Web. The main focus of the library is to provide classes
62 and functions that allow you to write WWW clients. The library also
63 contain modules that are of more general use and even classes that
64 help you implement simple HTTP servers.
65
66 %description -l pl.UTF-8
67 libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
68 do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
69 udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
70 Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
71 nawet klasy, pozwalające na implementację prostego serwera HTTP.
72
73 %prep
74 %setup -q -n libwww-perl-%{version}
75
76 %build
77 yes | %{__perl} Makefile.PL \
78         INSTALLDIRS=vendor
79 %{__make}
80
81 %{?with_tests:%{__make} test}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} pure_install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 for file in GET HEAD POST; do
90         ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
91         rm -f $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
92         echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
93 done
94
95 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc Changes README*
103 %attr(755,root,root) %{_bindir}/GET
104 %attr(755,root,root) %{_bindir}/HEAD
105 %attr(755,root,root) %{_bindir}/POST
106 %attr(755,root,root) %{_bindir}/lwp-*
107 %{perl_vendorlib}/LWP.pm
108 %{perl_vendorlib}/LWP/Authen
109 %{perl_vendorlib}/LWP/ConnCache.pm
110 %{perl_vendorlib}/LWP/Debug.pm
111 %{perl_vendorlib}/LWP/DebugFile.pm
112 %{perl_vendorlib}/LWP/MemberMixin.pm
113 %{perl_vendorlib}/LWP/Protocol.pm
114 %{perl_vendorlib}/LWP/Protocol
115 %{perl_vendorlib}/LWP/RobotUA.pm
116 %{perl_vendorlib}/LWP/Simple.pm
117 %{perl_vendorlib}/LWP/UserAgent.pm
118 %{_mandir}/man1/GET.1p*
119 %{_mandir}/man1/HEAD.1p*
120 %{_mandir}/man1/POST.1p*
121 %{_mandir}/man1/lwp-*.1p*
122 %{_mandir}/man3/LWP*.3pm*
123 %{_mandir}/man3/lwpcook.3pm*
124 %{_mandir}/man3/lwptut.3pm*
This page took 0.056464 seconds and 4 git commands to generate.