]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
up to 6.73
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network)
4 #
5 %define         pdir    WWW
6 %define         pnam    libwww-perl
7 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
8 Summary(pl.UTF-8):      libwww-perl - prosty i logiczny API do WWW
9 Name:           perl-libwww
10 Version:        6.73
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  729fd102fb3879acca2d46cb36dbba21
17 URL:            https://metacpan.org/release/libwww-perl
18 BuildRequires:  perl-CPAN-Meta-Requirements >= 2.120_620
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl(Net::FTP) >= 2.58
24 BuildRequires:  perl-Digest-MD5
25 BuildRequires:  perl-Encode >= 2.12
26 BuildRequires:  perl-Encode-Locale
27 BuildRequires:  perl-File-Listing >= 6
28 BuildRequires:  perl-HTML-Parser >= 3.71
29 BuildRequires:  perl-HTTP-Cookies >= 6
30 BuildRequires:  perl-HTTP-Daemon >= 6.12
31 BuildRequires:  perl-HTTP-Date >= 6
32 BuildRequires:  perl-HTTP-Message >= 6.07
33 BuildRequires:  perl-HTTP-Negotiate >= 6
34 BuildRequires:  perl-LWP-MediaTypes >= 6
35 BuildRequires:  perl-MIME-Base64 >= 2.1
36 BuildRequires:  perl-Net-HTTP >= 6.18
37 BuildRequires:  perl-Test-Fatal
38 BuildRequires:  perl-Test-Needs
39 BuildRequires:  perl-Test-RequiresInternet
40 BuildRequires:  perl-Test-Simple
41 BuildRequires:  perl-URI >= 1.10
42 BuildRequires:  perl-WWW-RobotRules >= 6
43 BuildRequires:  perl-libnet
44 %endif
45 Requires:       perl-File-Listing >= 6
46 Requires:       perl-HTML-Parser >= 3.71
47 Requires:       perl-HTTP-Cookies >= 6
48 Requires:       perl-HTTP-Daemon >= 6.12
49 Requires:       perl-HTTP-Date >= 6
50 Requires:       perl-HTTP-Message >= 6
51 Requires:       perl-HTTP-Negotiate >= 6
52 Requires:       perl-LWP-MediaTypes >= 6
53 Requires:       perl-MIME-Base64 >= 2.1
54 Requires:       perl-Net-HTTP >= 6.18
55 Requires:       perl-URI >= 1.10
56 Requires:       perl-WWW-RobotRules >= 6
57 Provides:       perl(LWP::Debug::TraceHTTP::Socket) = %{version}
58 Provides:       perl(LWP::Protocol::http::Socket) = %{version}
59 Provides:       perl(LWP::Protocol::http::SocketMethods) = %{version}
60 Obsoletes:      perl-libwww-perl < 6
61 BuildArch:      noarch
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # modules not always required
65 %define _noautoreq_perl HTTP::GHTTP Authen::NTLM
66
67 %description
68 The libwww-perl collection is a set of Perl modules which provides a
69 simple and consistent application programming interface to the
70 World-Wide Web. The main focus of the library is to provide classes
71 and functions that allow you to write WWW clients. The library also
72 contain modules that are of more general use and even classes that
73 help you implement simple HTTP servers.
74
75 %description -l pl.UTF-8
76 libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
77 do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
78 udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
79 Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
80 nawet klasy, pozwalające na implementację prostego serwera HTTP.
81
82 %prep
83 %setup -q -n libwww-perl-%{version}
84
85 %build
86 yes | %{__perl} Makefile.PL \
87         INSTALLDIRS=vendor
88 %{__make}
89
90 %{?with_tests:%{__make} test}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} pure_install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 for file in GET HEAD POST; do
99         ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
100         echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
101 done
102 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc Changes README.SSL
110 %attr(755,root,root) %{_bindir}/GET
111 %attr(755,root,root) %{_bindir}/HEAD
112 %attr(755,root,root) %{_bindir}/POST
113 %attr(755,root,root) %{_bindir}/lwp-*
114 %{perl_vendorlib}/LWP.pm
115 %{perl_vendorlib}/LWP/Authen
116 %{perl_vendorlib}/LWP/ConnCache.pm
117 %{perl_vendorlib}/LWP/Debug.pm
118 %dir %{perl_vendorlib}/LWP/Debug
119 %{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
120 %{perl_vendorlib}/LWP/DebugFile.pm
121 %{perl_vendorlib}/LWP/MemberMixin.pm
122 %{perl_vendorlib}/LWP/Protocol.pm
123 %{perl_vendorlib}/LWP/Protocol
124 %{perl_vendorlib}/LWP/RobotUA.pm
125 %{perl_vendorlib}/LWP/Simple.pm
126 %{perl_vendorlib}/LWP/UserAgent.pm
127 %{_mandir}/man1/GET.1p*
128 %{_mandir}/man1/HEAD.1p*
129 %{_mandir}/man1/POST.1p*
130 %{_mandir}/man1/lwp-*.1p*
131 %{_mandir}/man3/LWP*.3pm*
132 %{_mandir}/man3/lwpcook.3pm*
133 %{_mandir}/man3/lwptut.3pm*
This page took 0.06809 seconds and 4 git commands to generate.