]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- updated to 5.77
[packages/perl-libwww.git] / perl-libwww.spec
1
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl):    libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        5.77
12 Release:        1
13 # same as Perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7aed09ed638986764e229beb2cbad6b4
18 BuildRequires:  perl(Net::FTP) >= 2.58
19 BuildRequires:  perl-Digest-MD5
20 BuildRequires:  perl-HTML-Parser >= 3.33
21 BuildRequires:  perl-MIME-Base64 >= 2.1
22 BuildRequires:  perl-URI >= 1.10
23 BuildRequires:  perl-devel >= 5.8
24 BuildRequires:  perl-libnet
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28 Obsoletes:      perl-libwww-perl
29
30 # modules not always required
31 %define _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
32
33 %description
34 The libwww-perl collection is a set of Perl modules which provides a
35 simple and consistent application programming interface to the World-Wide
36 Web. The main focus of the library is to provide classes and functions
37 that allow you to write WWW clients. The library also contain modules
38 that are of more general use and even classes that help you implement
39 simple HTTP servers.
40
41 %description -l pl
42 libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
43 do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
44 klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
45 tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
46 na implementacjê prostego serwera HTTP.
47
48 %prep
49 %setup -q -n libwww-perl-%{version}
50
51 %build
52 %{__perl} Makefile.PL </dev/null \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README*
70 %{perl_vendorlib}/*.pm
71 %{perl_vendorlib}/File/*
72 %{perl_vendorlib}/HTML/*
73 %{perl_vendorlib}/HTTP/*
74 %{perl_vendorlib}/Net/*
75 %{perl_vendorlib}/LWP
76 %{perl_vendorlib}/WWW/*
77 %attr(755,root,root) %{_bindir}/*
78 %{_mandir}/man1/*
79 %{_mandir}/man3/[!B]*
This page took 0.051695 seconds and 4 git commands to generate.