]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
up to 6.53
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network)
4 #
5 %define         pdir    WWW
6 %define         pnam    libwww-perl
7 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
8 Summary(pl.UTF-8):      libwww-perl - prosty i logiczny API do WWW
9 Name:           perl-libwww
10 Version:        6.53
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  33fdb6415018b8bf94242cace1b06479
17 URL:            https://metacpan.org/release/libwww-perl
18 BuildRequires:  perl-CPAN-Meta-Requirements >= 2.120_620
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl(Net::FTP) >= 2.58
24 BuildRequires:  perl-Digest-MD5
25 BuildRequires:  perl-Encode >= 2.12
26 BuildRequires:  perl-Encode-Locale
27 BuildRequires:  perl-File-Listing >= 6
28 BuildRequires:  perl-HTML-Parser >= 3.33
29 BuildRequires:  perl-HTTP-Cookies >= 6
30 BuildRequires:  perl-HTTP-Daemon >= 6.12
31 BuildRequires:  perl-HTTP-Date >= 6
32 BuildRequires:  perl-HTTP-Message >= 6.07
33 BuildRequires:  perl-HTTP-Negotiate >= 6
34 BuildRequires:  perl-LWP-MediaTypes >= 6
35 BuildRequires:  perl-MIME-Base64 >= 2.1
36 BuildRequires:  perl-Net-HTTP >= 6.18
37 BuildRequires:  perl-Test-Fatal
38 BuildRequires:  perl-Test-Needs
39 BuildRequires:  perl-Test-RequiresInternet
40 BuildRequires:  perl-Test-Simple
41 BuildRequires:  perl-URI >= 1.10
42 BuildRequires:  perl-WWW-RobotRules >= 6
43 BuildRequires:  perl-libnet
44 %endif
45 Requires:       perl-File-Listing >= 6
46 Requires:       perl-HTTP-Cookies >= 6
47 Requires:       perl-HTTP-Daemon >= 6.12
48 Requires:       perl-HTTP-Date >= 6
49 Requires:       perl-HTTP-Message >= 6
50 Requires:       perl-HTTP-Negotiate >= 6
51 Requires:       perl-LWP-MediaTypes >= 6
52 Requires:       perl-MIME-Base64 >= 2.1
53 Requires:       perl-Net-HTTP >= 6.18
54 Requires:       perl-URI >= 1.10
55 Requires:       perl-WWW-RobotRules >= 6
56 Provides:       perl(LWP::Debug::TraceHTTP::Socket) = %{version}
57 Provides:       perl(LWP::Protocol::http::Socket) = %{version}
58 Provides:       perl(LWP::Protocol::http::SocketMethods) = %{version}
59 Obsoletes:      perl-libwww-perl
60 BuildArch:      noarch
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # modules not always required
64 %define _noautoreq_perl HTTP::GHTTP Authen::NTLM
65
66 %description
67 The libwww-perl collection is a set of Perl modules which provides a
68 simple and consistent application programming interface to the
69 World-Wide Web. The main focus of the library is to provide classes
70 and functions that allow you to write WWW clients. The library also
71 contain modules that are of more general use and even classes that
72 help you implement simple HTTP servers.
73
74 %description -l pl.UTF-8
75 libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
76 do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
77 udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
78 Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
79 nawet klasy, pozwalające na implementację prostego serwera HTTP.
80
81 %prep
82 %setup -q -n libwww-perl-%{version}
83
84 %build
85 yes | %{__perl} Makefile.PL \
86         INSTALLDIRS=vendor
87 %{__make}
88
89 %{?with_tests:%{__make} test}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} pure_install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 for file in GET HEAD POST; do
98         ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
99         echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
100 done
101 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc Changes README.SSL
109 %attr(755,root,root) %{_bindir}/GET
110 %attr(755,root,root) %{_bindir}/HEAD
111 %attr(755,root,root) %{_bindir}/POST
112 %attr(755,root,root) %{_bindir}/lwp-*
113 %{perl_vendorlib}/LWP.pm
114 %{perl_vendorlib}/LWP/Authen
115 %{perl_vendorlib}/LWP/ConnCache.pm
116 %{perl_vendorlib}/LWP/Debug.pm
117 %dir %{perl_vendorlib}/LWP/Debug
118 %{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
119 %{perl_vendorlib}/LWP/DebugFile.pm
120 %{perl_vendorlib}/LWP/MemberMixin.pm
121 %{perl_vendorlib}/LWP/Protocol.pm
122 %{perl_vendorlib}/LWP/Protocol
123 %{perl_vendorlib}/LWP/RobotUA.pm
124 %{perl_vendorlib}/LWP/Simple.pm
125 %{perl_vendorlib}/LWP/UserAgent.pm
126 %{_mandir}/man1/GET.1p*
127 %{_mandir}/man1/HEAD.1p*
128 %{_mandir}/man1/POST.1p*
129 %{_mandir}/man1/lwp-*.1p*
130 %{_mandir}/man3/LWP*.3pm*
131 %{_mandir}/man3/libwww::lwpcook.3pm*
132 %{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.055695 seconds and 4 git commands to generate.