]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- BR: perl-devel; do not BR: perl
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl):    libwww-perl - prosty i logiczny API do WWW 
10 Name:           perl-libwww
11 Version:        5.69
12 Release:        2
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl-devel >= 5.6
17 BuildRequires:  perl(Net::FTP) >= 2.58
18 BuildRequires:  perl-Digest-MD5
19 BuildRequires:  perl-HTML-Parser
20 BuildRequires:  perl-MIME-Base64
21 BuildRequires:  perl-URI
22 BuildRequires:  perl-libnet
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      perl-libwww-perl
27
28 # modules not always required
29 %define _noautoreq "perl(HTML::Parse)" "perl(HTML::FormatPS)" "perl(HTML::FormatText)" "perl(HTTP::GHTTP)" "perl(IO::Socket::SSL)" "perl(Mail::Internet)" "perl(Authen::NTLM)"
30
31 %description
32 The libwww-perl collection is a set of Perl modules which provides a
33 simple and consistent application programming interface to the World-Wide
34 Web. The main focus of the library is to provide classes and functions
35 that allow you to write WWW clients. The library also contain modules
36 that are of more general use and even classes that help you implement
37 simple HTTP servers.
38
39 %description -l pl
40 libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
41 do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
42 klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
43 tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
44 na implementacjê prostego serwera HTTP.
45
46 %prep
47 %setup -q -n libwww-perl-%{version}
48
49 %build
50 %{__perl} Makefile.PL </dev/null \
51         INSTALLDIRS=vendor 
52 %{__make}
53
54 %{?_with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README*
67 %{perl_vendorlib}/*.pm
68 %{perl_vendorlib}/File/*
69 %{perl_vendorlib}/HTML/*
70 %{perl_vendorlib}/HTTP/*
71 %{perl_vendorlib}/Net/*
72 %{perl_vendorlib}/LWP
73 %{perl_vendorlib}/WWW/*
74 %attr(755,root,root) %{_bindir}/*
75 %{_mandir}/man1/*
76 %{_mandir}/man3/[^B]*
This page took 0.069947 seconds and 4 git commands to generate.