]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- updated to 5.75
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl):    libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        5.75
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  118a2b0556a194767aed15733f92a2ed
17 BuildRequires:  perl(Net::FTP) >= 2.58
18 BuildRequires:  perl-Digest-MD5
19 BuildRequires:  perl-HTML-Parser >= 3.33
20 BuildRequires:  perl-MIME-Base64 >= 2.1
21 BuildRequires:  perl-URI >= 1.10
22 BuildRequires:  perl-devel >= 5.8
23 BuildRequires:  perl-libnet
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Obsoletes:      perl-libwww-perl
28
29 # modules not always required
30 %define _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
31
32 %description
33 The libwww-perl collection is a set of Perl modules which provides a
34 simple and consistent application programming interface to the World-Wide
35 Web. The main focus of the library is to provide classes and functions
36 that allow you to write WWW clients. The library also contain modules
37 that are of more general use and even classes that help you implement
38 simple HTTP servers.
39
40 %description -l pl
41 libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
42 do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
43 klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
44 tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
45 na implementacjê prostego serwera HTTP.
46
47 %prep
48 %setup -q -n libwww-perl-%{version}
49
50 %build
51 %{__perl} Makefile.PL </dev/null \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?_with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README*
69 %{perl_vendorlib}/*.pm
70 %{perl_vendorlib}/File/*
71 %{perl_vendorlib}/HTML/*
72 %{perl_vendorlib}/HTTP/*
73 %{perl_vendorlib}/Net/*
74 %{perl_vendorlib}/LWP
75 %{perl_vendorlib}/WWW/*
76 %attr(755,root,root) %{_bindir}/*
77 %{_mandir}/man1/*
78 %{_mandir}/man3/[!B]*
This page took 0.062992 seconds and 4 git commands to generate.