]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
- release 2: added -lwp_download_dest_dir_support.patch
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl):    libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        5.801
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  eda011c6b5483d2d7443dd737cf03118
18 Patch0:         %{name}-lwp_download_dest_dir_support.patch
19 URL:            http://search.cpan.org/dist/libwww-perl/
20 BuildRequires:  perl(Net::FTP) >= 2.58
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-HTML-Parser >= 3.33
23 BuildRequires:  perl-MIME-Base64 >= 2.1
24 BuildRequires:  perl-URI >= 1.10
25 BuildRequires:  perl-devel >= 1:5.8.0
26 BuildRequires:  perl-libnet
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30 Obsoletes:      perl-libwww-perl
31
32 # modules not always required
33 %define _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
34
35 %description
36 The libwww-perl collection is a set of Perl modules which provides a
37 simple and consistent application programming interface to the World-Wide
38 Web. The main focus of the library is to provide classes and functions
39 that allow you to write WWW clients. The library also contain modules
40 that are of more general use and even classes that help you implement
41 simple HTTP servers.
42
43 %description -l pl
44 libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
45 do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
46 klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
47 tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
48 na implementacjê prostego serwera HTTP.
49
50 %prep
51 %setup -q -n libwww-perl-%{version}
52 %patch0 -p0
53
54 %build
55 %{__perl} Makefile.PL </dev/null \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README*
73 %{perl_vendorlib}/*.pm
74 %{perl_vendorlib}/File/*
75 %{perl_vendorlib}/HTML/*
76 %{perl_vendorlib}/HTTP/*
77 %{perl_vendorlib}/Net/*
78 %{perl_vendorlib}/LWP
79 %{perl_vendorlib}/WWW/*
80 %attr(755,root,root) %{_bindir}/*
81 %{_mandir}/man1/*
82 %{_mandir}/man3/[!B]*
This page took 0.036503 seconds and 4 git commands to generate.