]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
up to 6.48
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network)
4 #
5 %define         pdir    WWW
6 %define         pnam    libwww-perl
7 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
8 Summary(pl.UTF-8):      libwww-perl - prosty i logiczny API do WWW
9 Name:           perl-libwww
10 Version:        6.48
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  760156aed8b9845ef85f856369ff0f7e
17 URL:            http://search.cpan.org/dist/libwww-perl/
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.663
21 %if %{with tests}
22 BuildRequires:  perl(Net::FTP) >= 2.58
23 BuildRequires:  perl-Digest-MD5
24 BuildRequires:  perl-Encode >= 2.12
25 BuildRequires:  perl-Encode-Locale
26 BuildRequires:  perl-File-Listing >= 6
27 BuildRequires:  perl-HTML-Parser >= 3.33
28 BuildRequires:  perl-HTTP-Cookies >= 6
29 BuildRequires:  perl-HTTP-Daemon >= 6
30 BuildRequires:  perl-HTTP-Date >= 6
31 BuildRequires:  perl-HTTP-Message >= 6
32 BuildRequires:  perl-HTTP-Negotiate >= 6
33 BuildRequires:  perl-LWP-MediaTypes >= 6
34 BuildRequires:  perl-MIME-Base64 >= 2.1
35 BuildRequires:  perl-Net-HTTP >= 6.18
36 BuildRequires:  perl-Test-Needs
37 BuildRequires:  perl-Test-RequiresInternet
38 BuildRequires:  perl-Test-Simple
39 BuildRequires:  perl-URI >= 1.10
40 BuildRequires:  perl-WWW-RobotRules >= 6
41 BuildRequires:  perl-libnet
42 %endif
43 Requires:       perl-File-Listing >= 6
44 Requires:       perl-HTTP-Cookies >= 6
45 Requires:       perl-HTTP-Daemon >= 6
46 Requires:       perl-HTTP-Date >= 6
47 Requires:       perl-HTTP-Message >= 6
48 Requires:       perl-HTTP-Negotiate >= 6
49 Requires:       perl-LWP-MediaTypes >= 6
50 Requires:       perl-MIME-Base64 >= 2.1
51 Requires:       perl-Net-HTTP >= 6.18
52 Requires:       perl-URI >= 1.10
53 Requires:       perl-WWW-RobotRules >= 6
54 Provides:       perl(LWP::Debug::TraceHTTP::Socket) = %{version}
55 Provides:       perl(LWP::Protocol::http::Socket) = %{version}
56 Provides:       perl(LWP::Protocol::http::SocketMethods) = %{version}
57 Obsoletes:      perl-libwww-perl
58 BuildArch:      noarch
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # modules not always required
62 %define _noautoreq_perl HTTP::GHTTP Authen::NTLM
63
64 %description
65 The libwww-perl collection is a set of Perl modules which provides a
66 simple and consistent application programming interface to the
67 World-Wide Web. The main focus of the library is to provide classes
68 and functions that allow you to write WWW clients. The library also
69 contain modules that are of more general use and even classes that
70 help you implement simple HTTP servers.
71
72 %description -l pl.UTF-8
73 libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
74 do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
75 udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
76 Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
77 nawet klasy, pozwalające na implementację prostego serwera HTTP.
78
79 %prep
80 %setup -q -n libwww-perl-%{version}
81
82 %build
83 yes | %{__perl} Makefile.PL \
84         INSTALLDIRS=vendor
85 %{__make}
86
87 %{?with_tests:%{__make} test}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} pure_install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 for file in GET HEAD POST; do
96         ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
97         echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
98 done
99 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc Changes README*
107 %attr(755,root,root) %{_bindir}/GET
108 %attr(755,root,root) %{_bindir}/HEAD
109 %attr(755,root,root) %{_bindir}/POST
110 %attr(755,root,root) %{_bindir}/lwp-*
111 %{perl_vendorlib}/LWP.pm
112 %{perl_vendorlib}/LWP/Authen
113 %{perl_vendorlib}/LWP/ConnCache.pm
114 %{perl_vendorlib}/LWP/Debug.pm
115 %dir %{perl_vendorlib}/LWP/Debug
116 %{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
117 %{perl_vendorlib}/LWP/DebugFile.pm
118 %{perl_vendorlib}/LWP/MemberMixin.pm
119 %{perl_vendorlib}/LWP/Protocol.pm
120 %{perl_vendorlib}/LWP/Protocol
121 %{perl_vendorlib}/LWP/RobotUA.pm
122 %{perl_vendorlib}/LWP/Simple.pm
123 %{perl_vendorlib}/LWP/UserAgent.pm
124 %{_mandir}/man1/GET.1p*
125 %{_mandir}/man1/HEAD.1p*
126 %{_mandir}/man1/POST.1p*
127 %{_mandir}/man1/lwp-*.1p*
128 %{_mandir}/man3/LWP*.3pm*
129 %{_mandir}/man3/libwww::lwpcook.3pm*
130 %{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.064081 seconds and 4 git commands to generate.