]> git.pld-linux.org Git - packages/perl-libwww.git/blob - perl-libwww.spec
57f2051fd82b8e6def5555609557913a5f375f21
[packages/perl-libwww.git] / perl-libwww.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    libwww-perl
8 Summary:        libwww-perl - a simple and consistent API to the World-Wide Web
9 Summary(pl.UTF-8):      libwww-perl - prosty i logiczny API do WWW
10 Name:           perl-libwww
11 Version:        6.39
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e6eec32d76fee9d8752efbd355e6e7bc
18 URL:            http://search.cpan.org/dist/libwww-perl/
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.663
22 %if %{with tests}
23 BuildRequires:  perl(Net::FTP) >= 2.58
24 BuildRequires:  perl-Digest-MD5
25 BuildRequires:  perl-Encode >= 2.12
26 BuildRequires:  perl-Encode-Locale
27 BuildRequires:  perl-File-Listing >= 6
28 BuildRequires:  perl-HTML-Parser >= 3.33
29 BuildRequires:  perl-HTTP-Cookies >= 6
30 BuildRequires:  perl-HTTP-Daemon >= 6
31 BuildRequires:  perl-HTTP-Date >= 6
32 BuildRequires:  perl-HTTP-Message >= 6
33 BuildRequires:  perl-HTTP-Negotiate >= 6
34 BuildRequires:  perl-LWP-MediaTypes >= 6
35 BuildRequires:  perl-MIME-Base64 >= 2.1
36 BuildRequires:  perl-Net-HTTP >= 6.18
37 BuildRequires:  perl-Test-Needs
38 BuildRequires:  perl-Test-RequiresInternet
39 BuildRequires:  perl-Test-Simple
40 BuildRequires:  perl-URI >= 1.10
41 BuildRequires:  perl-WWW-RobotRules >= 6
42 BuildRequires:  perl-libnet
43 %endif
44 Requires:       perl-File-Listing >= 6
45 Requires:       perl-HTTP-Cookies >= 6
46 Requires:       perl-HTTP-Daemon >= 6
47 Requires:       perl-HTTP-Date >= 6
48 Requires:       perl-HTTP-Message >= 6
49 Requires:       perl-HTTP-Negotiate >= 6
50 Requires:       perl-LWP-MediaTypes >= 6
51 Requires:       perl-MIME-Base64 >= 2.1
52 Requires:       perl-Net-HTTP >= 6.18
53 Requires:       perl-URI >= 1.10
54 Requires:       perl-WWW-RobotRules >= 6
55 Obsoletes:      perl-libwww-perl
56 BuildArch:      noarch
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 # modules not always required
60 %define _noautoreq_perl HTTP::GHTTP Authen::NTLM
61
62 %description
63 The libwww-perl collection is a set of Perl modules which provides a
64 simple and consistent application programming interface to the
65 World-Wide Web. The main focus of the library is to provide classes
66 and functions that allow you to write WWW clients. The library also
67 contain modules that are of more general use and even classes that
68 help you implement simple HTTP servers.
69
70 %description -l pl.UTF-8
71 libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
72 do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
73 udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
74 Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
75 nawet klasy, pozwalające na implementację prostego serwera HTTP.
76
77 %prep
78 %setup -q -n libwww-perl-%{version}
79
80 %build
81 yes | %{__perl} Makefile.PL \
82         INSTALLDIRS=vendor
83 %{__make}
84
85 %{?with_tests:%{__make} test}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} pure_install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 for file in GET HEAD POST; do
94         ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
95         echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
96 done
97 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc Changes README*
105 %attr(755,root,root) %{_bindir}/GET
106 %attr(755,root,root) %{_bindir}/HEAD
107 %attr(755,root,root) %{_bindir}/POST
108 %attr(755,root,root) %{_bindir}/lwp-*
109 %{perl_vendorlib}/LWP.pm
110 %{perl_vendorlib}/LWP/Authen
111 %{perl_vendorlib}/LWP/ConnCache.pm
112 %{perl_vendorlib}/LWP/Debug.pm
113 %dir %{perl_vendorlib}/LWP/Debug
114 %{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
115 %{perl_vendorlib}/LWP/DebugFile.pm
116 %{perl_vendorlib}/LWP/MemberMixin.pm
117 %{perl_vendorlib}/LWP/Protocol.pm
118 %{perl_vendorlib}/LWP/Protocol
119 %{perl_vendorlib}/LWP/RobotUA.pm
120 %{perl_vendorlib}/LWP/Simple.pm
121 %{perl_vendorlib}/LWP/UserAgent.pm
122 %{_mandir}/man1/GET.1p*
123 %{_mandir}/man1/HEAD.1p*
124 %{_mandir}/man1/POST.1p*
125 %{_mandir}/man1/lwp-*.1p*
126 %{_mandir}/man3/LWP*.3pm*
127 %{_mandir}/man3/libwww::lwpcook.3pm*
128 %{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.067031 seconds and 2 git commands to generate.