]> git.pld-linux.org Git - packages/perl-libwww.git/blame_incremental - perl-libwww.spec
up to 6.73
[packages/perl-libwww.git] / perl-libwww.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" (uses network)
4#
5%define pdir WWW
6%define pnam libwww-perl
7Summary: libwww-perl - a simple and consistent API to the World-Wide Web
8Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
9Name: perl-libwww
10Version: 6.55
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: https://www.cpan.org/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
16# Source0-md5: 4df22c50511a3f01063d2ba4d91bfbec
17URL: https://metacpan.org/release/libwww-perl
18BuildRequires: perl-CPAN-Meta-Requirements >= 2.120_620
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRequires: rpmbuild(macros) >= 1.745
22%if %{with tests}
23BuildRequires: perl(Net::FTP) >= 2.58
24BuildRequires: perl-Digest-MD5
25BuildRequires: perl-Encode >= 2.12
26BuildRequires: perl-Encode-Locale
27BuildRequires: perl-File-Listing >= 6
28BuildRequires: perl-HTML-Parser >= 3.33
29BuildRequires: perl-HTTP-Cookies >= 6
30BuildRequires: perl-HTTP-Daemon >= 6.12
31BuildRequires: perl-HTTP-Date >= 6
32BuildRequires: perl-HTTP-Message >= 6.07
33BuildRequires: perl-HTTP-Negotiate >= 6
34BuildRequires: perl-LWP-MediaTypes >= 6
35BuildRequires: perl-MIME-Base64 >= 2.1
36BuildRequires: perl-Net-HTTP >= 6.18
37BuildRequires: perl-Test-Fatal
38BuildRequires: perl-Test-Needs
39BuildRequires: perl-Test-RequiresInternet
40BuildRequires: perl-Test-Simple
41BuildRequires: perl-URI >= 1.10
42BuildRequires: perl-WWW-RobotRules >= 6
43BuildRequires: perl-libnet
44%endif
45Requires: perl-File-Listing >= 6
46Requires: perl-HTTP-Cookies >= 6
47Requires: perl-HTTP-Daemon >= 6.12
48Requires: perl-HTTP-Date >= 6
49Requires: perl-HTTP-Message >= 6
50Requires: perl-HTTP-Negotiate >= 6
51Requires: perl-LWP-MediaTypes >= 6
52Requires: perl-MIME-Base64 >= 2.1
53Requires: perl-Net-HTTP >= 6.18
54Requires: perl-URI >= 1.10
55Requires: perl-WWW-RobotRules >= 6
56Provides: perl(LWP::Debug::TraceHTTP::Socket) = %{version}
57Provides: perl(LWP::Protocol::http::Socket) = %{version}
58Provides: perl(LWP::Protocol::http::SocketMethods) = %{version}
59Obsoletes: perl-libwww-perl
60BuildArch: noarch
61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63# modules not always required
64%define _noautoreq_perl HTTP::GHTTP Authen::NTLM
65
66%description
67The libwww-perl collection is a set of Perl modules which provides a
68simple and consistent application programming interface to the
69World-Wide Web. The main focus of the library is to provide classes
70and functions that allow you to write WWW clients. The library also
71contain modules that are of more general use and even classes that
72help you implement simple HTTP servers.
73
74%description -l pl.UTF-8
75libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
76do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
77udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
78Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
79nawet klasy, pozwalające na implementację prostego serwera HTTP.
80
81%prep
82%setup -q -n libwww-perl-%{version}
83
84%build
85yes | %{__perl} Makefile.PL \
86 INSTALLDIRS=vendor
87%{__make}
88
89%{?with_tests:%{__make} test}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94%{__make} pure_install \
95 DESTDIR=$RPM_BUILD_ROOT
96
97for file in GET HEAD POST; do
98 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
99 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
100done
101%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%files
107%defattr(644,root,root,755)
108%doc Changes README.SSL
109%attr(755,root,root) %{_bindir}/GET
110%attr(755,root,root) %{_bindir}/HEAD
111%attr(755,root,root) %{_bindir}/POST
112%attr(755,root,root) %{_bindir}/lwp-*
113%{perl_vendorlib}/LWP.pm
114%{perl_vendorlib}/LWP/Authen
115%{perl_vendorlib}/LWP/ConnCache.pm
116%{perl_vendorlib}/LWP/Debug.pm
117%dir %{perl_vendorlib}/LWP/Debug
118%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
119%{perl_vendorlib}/LWP/DebugFile.pm
120%{perl_vendorlib}/LWP/MemberMixin.pm
121%{perl_vendorlib}/LWP/Protocol.pm
122%{perl_vendorlib}/LWP/Protocol
123%{perl_vendorlib}/LWP/RobotUA.pm
124%{perl_vendorlib}/LWP/Simple.pm
125%{perl_vendorlib}/LWP/UserAgent.pm
126%{_mandir}/man1/GET.1p*
127%{_mandir}/man1/HEAD.1p*
128%{_mandir}/man1/POST.1p*
129%{_mandir}/man1/lwp-*.1p*
130%{_mandir}/man3/LWP*.3pm*
131%{_mandir}/man3/libwww::lwpcook.3pm*
132%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.074275 seconds and 4 git commands to generate.