]> git.pld-linux.org Git - packages/perl-libwww.git/blame_incremental - perl-libwww.spec
up to 6.41
[packages/perl-libwww.git] / perl-libwww.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" (uses network)
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir WWW
7%define pnam libwww-perl
8Summary: libwww-perl - a simple and consistent API to the World-Wide Web
9Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
10Name: perl-libwww
11Version: 6.41
12Release: 1
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
17# Source0-md5: d1b867b29e71d399dd5ff56b9a469637
18URL: http://search.cpan.org/dist/libwww-perl/
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRequires: rpmbuild(macros) >= 1.663
22%if %{with tests}
23BuildRequires: perl(Net::FTP) >= 2.58
24BuildRequires: perl-Digest-MD5
25BuildRequires: perl-Encode >= 2.12
26BuildRequires: perl-Encode-Locale
27BuildRequires: perl-File-Listing >= 6
28BuildRequires: perl-HTML-Parser >= 3.33
29BuildRequires: perl-HTTP-Cookies >= 6
30BuildRequires: perl-HTTP-Daemon >= 6
31BuildRequires: perl-HTTP-Date >= 6
32BuildRequires: perl-HTTP-Message >= 6
33BuildRequires: perl-HTTP-Negotiate >= 6
34BuildRequires: perl-LWP-MediaTypes >= 6
35BuildRequires: perl-MIME-Base64 >= 2.1
36BuildRequires: perl-Net-HTTP >= 6.18
37BuildRequires: perl-Test-Needs
38BuildRequires: perl-Test-RequiresInternet
39BuildRequires: perl-Test-Simple
40BuildRequires: perl-URI >= 1.10
41BuildRequires: perl-WWW-RobotRules >= 6
42BuildRequires: perl-libnet
43%endif
44Requires: perl-File-Listing >= 6
45Requires: perl-HTTP-Cookies >= 6
46Requires: perl-HTTP-Daemon >= 6
47Requires: perl-HTTP-Date >= 6
48Requires: perl-HTTP-Message >= 6
49Requires: perl-HTTP-Negotiate >= 6
50Requires: perl-LWP-MediaTypes >= 6
51Requires: perl-MIME-Base64 >= 2.1
52Requires: perl-Net-HTTP >= 6.18
53Requires: perl-URI >= 1.10
54Requires: perl-WWW-RobotRules >= 6
55Obsoletes: perl-libwww-perl
56BuildArch: noarch
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59# modules not always required
60%define _noautoreq_perl HTTP::GHTTP Authen::NTLM
61
62%description
63The libwww-perl collection is a set of Perl modules which provides a
64simple and consistent application programming interface to the
65World-Wide Web. The main focus of the library is to provide classes
66and functions that allow you to write WWW clients. The library also
67contain modules that are of more general use and even classes that
68help you implement simple HTTP servers.
69
70%description -l pl.UTF-8
71libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
72do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
73udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
74Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
75nawet klasy, pozwalające na implementację prostego serwera HTTP.
76
77%prep
78%setup -q -n libwww-perl-%{version}
79
80%build
81yes | %{__perl} Makefile.PL \
82 INSTALLDIRS=vendor
83%{__make}
84
85%{?with_tests:%{__make} test}
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90%{__make} pure_install \
91 DESTDIR=$RPM_BUILD_ROOT
92
93for file in GET HEAD POST; do
94 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
95 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
96done
97%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(644,root,root,755)
104%doc Changes README*
105%attr(755,root,root) %{_bindir}/GET
106%attr(755,root,root) %{_bindir}/HEAD
107%attr(755,root,root) %{_bindir}/POST
108%attr(755,root,root) %{_bindir}/lwp-*
109%{perl_vendorlib}/LWP.pm
110%{perl_vendorlib}/LWP/Authen
111%{perl_vendorlib}/LWP/ConnCache.pm
112%{perl_vendorlib}/LWP/Debug.pm
113%dir %{perl_vendorlib}/LWP/Debug
114%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
115%{perl_vendorlib}/LWP/DebugFile.pm
116%{perl_vendorlib}/LWP/MemberMixin.pm
117%{perl_vendorlib}/LWP/Protocol.pm
118%{perl_vendorlib}/LWP/Protocol
119%{perl_vendorlib}/LWP/RobotUA.pm
120%{perl_vendorlib}/LWP/Simple.pm
121%{perl_vendorlib}/LWP/UserAgent.pm
122%{_mandir}/man1/GET.1p*
123%{_mandir}/man1/HEAD.1p*
124%{_mandir}/man1/POST.1p*
125%{_mandir}/man1/lwp-*.1p*
126%{_mandir}/man3/LWP*.3pm*
127%{_mandir}/man3/libwww::lwpcook.3pm*
128%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.066578 seconds and 4 git commands to generate.