]> git.pld-linux.org Git - packages/perl-libwww.git/blame - perl-libwww.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-libwww.git] / perl-libwww.spec
CommitLineData
377e53b5 1#
5a01b76e 2# Conditional build:
3e6aff4b 3%bcond_with tests # perform "make test" (uses network)
377e53b5 4#
e6e936d4 5%define pdir WWW
6%define pnam libwww-perl
5a01b76e 7Summary: libwww-perl - a simple and consistent API to the World-Wide Web
5f0e6283 8Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
9c46f5b6 9Name: perl-libwww
32b1daeb 10Version: 6.43
64e31c17 11Release: 1
377e53b5 12# same as perl
13License: GPL v1+ or Artistic
2128e5d3 14Group: Development/Languages/Perl
ac3bd034 15Source0: http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
32b1daeb 16# Source0-md5: e64d87052eb51bb55627c756ccdfe233
f5ef0868 17URL: http://search.cpan.org/dist/libwww-perl/
3e6aff4b
JB
18BuildRequires: perl-devel >= 1:5.8.8
19BuildRequires: rpm-perlprov >= 4.1-13
f387c65e 20BuildRequires: rpmbuild(macros) >= 1.663
3e6aff4b 21%if %{with tests}
44760cc9 22BuildRequires: perl(Net::FTP) >= 2.58
e3a00125 23BuildRequires: perl-Digest-MD5
3e6aff4b
JB
24BuildRequires: perl-Encode >= 2.12
25BuildRequires: perl-Encode-Locale
26BuildRequires: perl-File-Listing >= 6
372188ef 27BuildRequires: perl-HTML-Parser >= 3.33
3e6aff4b
JB
28BuildRequires: perl-HTTP-Cookies >= 6
29BuildRequires: perl-HTTP-Daemon >= 6
30BuildRequires: perl-HTTP-Date >= 6
31BuildRequires: perl-HTTP-Message >= 6
32BuildRequires: perl-HTTP-Negotiate >= 6
33BuildRequires: perl-LWP-MediaTypes >= 6
372188ef 34BuildRequires: perl-MIME-Base64 >= 2.1
ac3bd034 35BuildRequires: perl-Net-HTTP >= 6.18
63744f40
JB
36BuildRequires: perl-Test-Needs
37BuildRequires: perl-Test-RequiresInternet
38BuildRequires: perl-Test-Simple
372188ef 39BuildRequires: perl-URI >= 1.10
3e6aff4b 40BuildRequires: perl-WWW-RobotRules >= 6
2128e5d3 41BuildRequires: perl-libnet
3e6aff4b
JB
42%endif
43Requires: perl-File-Listing >= 6
44Requires: perl-HTTP-Cookies >= 6
45Requires: perl-HTTP-Daemon >= 6
46Requires: perl-HTTP-Date >= 6
47Requires: perl-HTTP-Message >= 6
48Requires: perl-HTTP-Negotiate >= 6
49Requires: perl-LWP-MediaTypes >= 6
50Requires: perl-MIME-Base64 >= 2.1
ac3bd034 51Requires: perl-Net-HTTP >= 6.18
3e6aff4b
JB
52Requires: perl-URI >= 1.10
53Requires: perl-WWW-RobotRules >= 6
d2d1125d 54Obsoletes: perl-libwww-perl
fdae6112 55BuildArch: noarch
af046231 56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
03d3a68a 57
11092ec3 58# modules not always required
f387c65e 59%define _noautoreq_perl HTTP::GHTTP Authen::NTLM
11092ec3 60
03d3a68a 61%description
5a01b76e 62The libwww-perl collection is a set of Perl modules which provides a
d2d1125d
ER
63simple and consistent application programming interface to the
64World-Wide Web. The main focus of the library is to provide classes
65and functions that allow you to write WWW clients. The library also
66contain modules that are of more general use and even classes that
67help you implement simple HTTP servers.
03d3a68a 68
4dcbc77b
JR
69%description -l pl.UTF-8
70libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
d2d1125d
ER
71do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
72udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
73Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
74nawet klasy, pozwalające na implementację prostego serwera HTTP.
1574779f 75
03d3a68a 76%prep
9c46f5b6 77%setup -q -n libwww-perl-%{version}
03d3a68a
AM
78
79%build
667f460d 80yes | %{__perl} Makefile.PL \
44760cc9 81 INSTALLDIRS=vendor
89fabf57 82%{__make}
03d3a68a 83
1724ad1d 84%{?with_tests:%{__make} test}
5a01b76e 85
03d3a68a 86%install
9c46f5b6 87rm -rf $RPM_BUILD_ROOT
9c46f5b6 88
3e6aff4b 89%{__make} pure_install \
60f953d0 90 DESTDIR=$RPM_BUILD_ROOT
9c46f5b6 91
328e8fcd 92for file in GET HEAD POST; do
93 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
328e8fcd 94 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
95done
28788727 96%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
328e8fcd 97
03d3a68a 98%clean
85a3c1ae 99rm -rf $RPM_BUILD_ROOT
03d3a68a
AM
100
101%files
e3a00125 102%defattr(644,root,root,755)
3e6aff4b
JB
103%doc Changes README*
104%attr(755,root,root) %{_bindir}/GET
105%attr(755,root,root) %{_bindir}/HEAD
106%attr(755,root,root) %{_bindir}/POST
107%attr(755,root,root) %{_bindir}/lwp-*
108%{perl_vendorlib}/LWP.pm
109%{perl_vendorlib}/LWP/Authen
110%{perl_vendorlib}/LWP/ConnCache.pm
111%{perl_vendorlib}/LWP/Debug.pm
e23e58c8
MK
112%dir %{perl_vendorlib}/LWP/Debug
113%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
3e6aff4b
JB
114%{perl_vendorlib}/LWP/DebugFile.pm
115%{perl_vendorlib}/LWP/MemberMixin.pm
116%{perl_vendorlib}/LWP/Protocol.pm
117%{perl_vendorlib}/LWP/Protocol
118%{perl_vendorlib}/LWP/RobotUA.pm
119%{perl_vendorlib}/LWP/Simple.pm
120%{perl_vendorlib}/LWP/UserAgent.pm
121%{_mandir}/man1/GET.1p*
122%{_mandir}/man1/HEAD.1p*
123%{_mandir}/man1/POST.1p*
124%{_mandir}/man1/lwp-*.1p*
125%{_mandir}/man3/LWP*.3pm*
e23e58c8
MK
126%{_mandir}/man3/libwww::lwpcook.3pm*
127%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.169249 seconds and 4 git commands to generate.