]> git.pld-linux.org Git - packages/perl-libwww.git/blame - perl-libwww.spec
up to 6.43
[packages/perl-libwww.git] / perl-libwww.spec
CommitLineData
377e53b5 1#
5a01b76e 2# Conditional build:
3e6aff4b 3%bcond_with tests # perform "make test" (uses network)
377e53b5 4#
2128e5d3 5%include /usr/lib/rpm/macros.perl
e6e936d4 6%define pdir WWW
7%define pnam libwww-perl
5a01b76e 8Summary: libwww-perl - a simple and consistent API to the World-Wide Web
5f0e6283 9Summary(pl.UTF-8): libwww-perl - prosty i logiczny API do WWW
9c46f5b6 10Name: perl-libwww
32b1daeb 11Version: 6.43
64e31c17 12Release: 1
377e53b5 13# same as perl
14License: GPL v1+ or Artistic
2128e5d3 15Group: Development/Languages/Perl
ac3bd034 16Source0: http://search.cpan.org/CPAN/authors/id/O/OA/OALDERS/%{pnam}-%{version}.tar.gz
32b1daeb 17# Source0-md5: e64d87052eb51bb55627c756ccdfe233
f5ef0868 18URL: http://search.cpan.org/dist/libwww-perl/
3e6aff4b
JB
19BuildRequires: perl-devel >= 1:5.8.8
20BuildRequires: rpm-perlprov >= 4.1-13
f387c65e 21BuildRequires: rpmbuild(macros) >= 1.663
3e6aff4b 22%if %{with tests}
44760cc9 23BuildRequires: perl(Net::FTP) >= 2.58
e3a00125 24BuildRequires: perl-Digest-MD5
3e6aff4b
JB
25BuildRequires: perl-Encode >= 2.12
26BuildRequires: perl-Encode-Locale
27BuildRequires: perl-File-Listing >= 6
372188ef 28BuildRequires: perl-HTML-Parser >= 3.33
3e6aff4b
JB
29BuildRequires: perl-HTTP-Cookies >= 6
30BuildRequires: perl-HTTP-Daemon >= 6
31BuildRequires: perl-HTTP-Date >= 6
32BuildRequires: perl-HTTP-Message >= 6
33BuildRequires: perl-HTTP-Negotiate >= 6
34BuildRequires: perl-LWP-MediaTypes >= 6
372188ef 35BuildRequires: perl-MIME-Base64 >= 2.1
ac3bd034 36BuildRequires: perl-Net-HTTP >= 6.18
63744f40
JB
37BuildRequires: perl-Test-Needs
38BuildRequires: perl-Test-RequiresInternet
39BuildRequires: perl-Test-Simple
372188ef 40BuildRequires: perl-URI >= 1.10
3e6aff4b 41BuildRequires: perl-WWW-RobotRules >= 6
2128e5d3 42BuildRequires: perl-libnet
3e6aff4b
JB
43%endif
44Requires: perl-File-Listing >= 6
45Requires: perl-HTTP-Cookies >= 6
46Requires: perl-HTTP-Daemon >= 6
47Requires: perl-HTTP-Date >= 6
48Requires: perl-HTTP-Message >= 6
49Requires: perl-HTTP-Negotiate >= 6
50Requires: perl-LWP-MediaTypes >= 6
51Requires: perl-MIME-Base64 >= 2.1
ac3bd034 52Requires: perl-Net-HTTP >= 6.18
3e6aff4b
JB
53Requires: perl-URI >= 1.10
54Requires: perl-WWW-RobotRules >= 6
d2d1125d 55Obsoletes: perl-libwww-perl
fdae6112 56BuildArch: noarch
af046231 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
03d3a68a 58
11092ec3 59# modules not always required
f387c65e 60%define _noautoreq_perl HTTP::GHTTP Authen::NTLM
11092ec3 61
03d3a68a 62%description
5a01b76e 63The libwww-perl collection is a set of Perl modules which provides a
d2d1125d
ER
64simple and consistent application programming interface to the
65World-Wide Web. The main focus of the library is to provide classes
66and functions that allow you to write WWW clients. The library also
67contain modules that are of more general use and even classes that
68help you implement simple HTTP servers.
03d3a68a 69
4dcbc77b
JR
70%description -l pl.UTF-8
71libwww-perl jest zbiorem modułów Perla, dostarczających prostego API
d2d1125d
ER
72do WWW (World-Wide Web). Głównym zadaniem biblioteki jest
73udostępnianie klas i funkcji, pozwalających na pisanie klientów WWW.
74Biblioteka zawiera także moduły bardziej ogólnego przeznaczenia, a
75nawet klasy, pozwalające na implementację prostego serwera HTTP.
1574779f 76
03d3a68a 77%prep
9c46f5b6 78%setup -q -n libwww-perl-%{version}
03d3a68a
AM
79
80%build
667f460d 81yes | %{__perl} Makefile.PL \
44760cc9 82 INSTALLDIRS=vendor
89fabf57 83%{__make}
03d3a68a 84
1724ad1d 85%{?with_tests:%{__make} test}
5a01b76e 86
03d3a68a 87%install
9c46f5b6 88rm -rf $RPM_BUILD_ROOT
9c46f5b6 89
3e6aff4b 90%{__make} pure_install \
60f953d0 91 DESTDIR=$RPM_BUILD_ROOT
9c46f5b6 92
328e8fcd 93for file in GET HEAD POST; do
94 ln -sf lwp-request $RPM_BUILD_ROOT%{_bindir}/$file
328e8fcd 95 echo '.so lwp-request.1p' > $RPM_BUILD_ROOT%{_mandir}/man1/$file.1p
96done
28788727 97%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/libwww/*.pod
328e8fcd 98
03d3a68a 99%clean
85a3c1ae 100rm -rf $RPM_BUILD_ROOT
03d3a68a
AM
101
102%files
e3a00125 103%defattr(644,root,root,755)
3e6aff4b
JB
104%doc Changes README*
105%attr(755,root,root) %{_bindir}/GET
106%attr(755,root,root) %{_bindir}/HEAD
107%attr(755,root,root) %{_bindir}/POST
108%attr(755,root,root) %{_bindir}/lwp-*
109%{perl_vendorlib}/LWP.pm
110%{perl_vendorlib}/LWP/Authen
111%{perl_vendorlib}/LWP/ConnCache.pm
112%{perl_vendorlib}/LWP/Debug.pm
e23e58c8
MK
113%dir %{perl_vendorlib}/LWP/Debug
114%{perl_vendorlib}/LWP/Debug/TraceHTTP.pm
3e6aff4b
JB
115%{perl_vendorlib}/LWP/DebugFile.pm
116%{perl_vendorlib}/LWP/MemberMixin.pm
117%{perl_vendorlib}/LWP/Protocol.pm
118%{perl_vendorlib}/LWP/Protocol
119%{perl_vendorlib}/LWP/RobotUA.pm
120%{perl_vendorlib}/LWP/Simple.pm
121%{perl_vendorlib}/LWP/UserAgent.pm
122%{_mandir}/man1/GET.1p*
123%{_mandir}/man1/HEAD.1p*
124%{_mandir}/man1/POST.1p*
125%{_mandir}/man1/lwp-*.1p*
126%{_mandir}/man3/LWP*.3pm*
e23e58c8
MK
127%{_mandir}/man3/libwww::lwpcook.3pm*
128%{_mandir}/man3/libwww::lwptut.3pm*
This page took 0.121785 seconds and 4 git commands to generate.