]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 Summary:        perl-ldap module - a client interface to LDAP servers
6 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
7 Name:           perl-ldap
8 Version:        0.57
9 Release:        1
10 Epoch:          3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
15 # Source0-md5:  deff50f0de5d4cf95145765b6edd67d1
16 Patch0:         non-unicode-dump.patch
17 Patch1:         ignore-uninitialized.patch
18 URL:            http://ldap.perl.org/
19 BuildRequires:  perl-Authen-SASL >= 2.00
20 BuildRequires:  perl-Convert-ASN1 >= 0.20
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IO-Socket-INET6
23 BuildRequires:  perl-IO-Socket-SSL >= 1.26
24 BuildRequires:  perl-JSON
25 BuildRequires:  perl-MIME-Base64
26 BuildRequires:  perl-URI >= 1.1
27 BuildRequires:  perl-XML-SAX-Writer
28 BuildRequires:  perl-devel >= 1:5.18.0
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 %if %{with tests}
31 BuildRequires:  perl-Module-Signature
32 BuildRequires:  perl-Test-Simple
33 BuildRequires:  perl-libwww
34 %endif
35 Obsoletes:      perl-LDAP
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 perl-ldap is a collection of modules that implements a LDAP services
41 API for Perl programs.
42
43 %description -l pl.UTF-8
44 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
45 poziomu programów w Perlu.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 # this must be done after tests because of signature checking
60 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %{__make} pure_install \
67         DESTDIR=$RPM_BUILD_ROOT
68 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
71 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
72 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc CREDITS Changes README TODO
80 %{perl_vendorlib}/LWP/Protocol/ldap.pm
81 %{perl_vendorlib}/LWP/Protocol/ldapi.pm
82 %{perl_vendorlib}/LWP/Protocol/ldaps.pm
83 %{perl_vendorlib}/Net/LDAP*.pm
84 %dir %{perl_vendorlib}/Net/LDAP
85 %{perl_vendorlib}/Net/LDAP/*.pm
86 %{perl_vendorlib}/Net/LDAP/Control
87 %{perl_vendorlib}/Net/LDAP/Extension
88 %{perl_vendorlib}/Net/LDAP/Extra
89 %{perl_vendorlib}/Net/LDAP/Intermediate
90 %{_mandir}/man3/LWP::Protocol::ldap*
91 %{_mandir}/man3/N*
92 %{_examplesdir}/%{name}-%{version}
This page took 0.061753 seconds and 3 git commands to generate.