]> git.pld-linux.org Git - packages/perl-YAML-LibYAML.git/blob - perl-YAML-LibYAML.spec
perl 5.38.0 rebuild
[packages/perl-YAML-LibYAML.git] / perl-YAML-LibYAML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define pdir    YAML
6 %define pnam    LibYAML
7 Summary:        YAML::XS::LibYAML - An XS Wrapper Module of libyaml
8 Summary(pl.UTF-8):      YAML::XS::LibYAML - moduł wrappera XS dla libyaml
9 Name:           perl-YAML-LibYAML
10 Version:        0.86
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://www.cpan.org/modules/by-module/YAML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  416e14d9a6daf7bb37998c0aca488c11
17 URL:            https://metacpan.org/release/YAML-LibYAML
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.90
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.1
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 YAML::XS is a Perl YAML implementation using XS and libyaml.
29
30 YAML::XS::LibYAML is an XS wrapper module for libyaml.
31
32 %description -l pl.UTF-8
33 YAML::XS to perlowa implementacja YAML-a przy użyciu XS i biblioteki
34 libyaml.
35
36 YAML::XS::LibYAML to moduł wrappera XS dla libyaml.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/YAML/*.pod
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes
64 %{perl_vendorarch}/YAML/LibYAML.pm
65 %{perl_vendorarch}/YAML/XS.pm
66 %{perl_vendorarch}/YAML/XS
67 %dir %{perl_vendorarch}/auto/YAML/XS
68 %dir %{perl_vendorarch}/auto/YAML/XS/LibYAML
69 %attr(755,root,root) %{perl_vendorarch}/auto/YAML/XS/LibYAML/LibYAML.so
70 %{_mandir}/man3/YAML::LibYAML.3pm*
71 %{_mandir}/man3/YAML::XS.3pm*
72 %{_mandir}/man3/YAML::XS::LibYAML.3pm*
This page took 0.119425 seconds and 4 git commands to generate.