]> git.pld-linux.org Git - packages/perl-XML-XPathEngine.git/blob - perl-XML-XPathEngine.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-XPathEngine.git] / perl-XML-XPathEngine.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    XML
6 %define pnam    XPathEngine
7 Summary:        XML::XPathEngine - a re-usable XPath engine for DOM-like trees
8 Summary(pl.UTF-8):      XML::XPathEngine - silnik XPath dla drzew w stylu DOM
9 Name:           perl-XML-XPathEngine
10 Version:        0.14
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d840cbefa57c23041f0bed14940a6b22
17 URL:            http://search.cpan.org/dist/XML-XPathEngine/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides an XPath engine, that can be re-used by other
25 module/classes that implement trees.
26
27 In order to use the XPath engine, nodes in the user module need to
28 mimick DOM nodes. The degree of similitude between the user tree and a
29 DOM dictates how much of the XPath features can be used. A module
30 implementing all of the DOM should be able to use this module very
31 easily (you might need to add the cmp method on nodes in order to get
32 ordered result sets). 
33
34 %description -l pl.UTF-8
35 Ten moduł udostępnia silnik XPath, który można wykorzystywać w innych
36 modułach/klasach implementujących drzewa.
37
38 W celu użycia silnika XPath węzły w module użytkownika muszą
39 naśladować węzły DOM. Stopień podobieństwa między drzewem użytkownika
40 a drzewem DOM określa jak wiele możliwości XPath można wykorzystać.
41 Moduł implementujący całość DOM powinien być w stanie bardzo łatwo
42 użyć tego modułu (może zajść potrzeba dodania metody cmp dla węzłów w
43 celu uzyskania uporządkowanych zbiorów wyników).
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/XML/XPathEngine.pm
68 %{perl_vendorlib}/XML/XPathEngine
69 %{_mandir}/man3/XML::XPathEngine*.3pm*
This page took 0.064171 seconds and 4 git commands to generate.