]> git.pld-linux.org Git - packages/perl-XML-SAX.git/blob - perl-XML-SAX.spec
- rediffed
[packages/perl-XML-SAX.git] / perl-XML-SAX.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    SAX
7 Summary:        XML::SAX - simple API for XML
8 Summary(pl.UTF-8):      XML::SAX - proste API dla XML-a
9 Name:           perl-XML-SAX
10 Version:        1.02
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b62e3754523695c7f5bbcafa3676a38d
17 Patch0:         %{name}-noalter.patch
18 URL:            https://metacpan.org/release/XML-SAX
19 BuildRequires:  perl-XML-NamespaceSupport >= 0.03
20 BuildRequires:  perl-XML-SAX-Base >= 1.05
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 Requires(post): coreutils
25 Requires:       perl-XML-NamespaceSupport >= 0.03
26 Requires:       perl-XML-SAX-Base >= 1.05
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 XML::SAX consists of several framework classes for using and building
32 Perl SAX2 XML parsers, filters, and drivers. It is designed around the
33 need to be able to "plug in" different SAX parsers to an application
34 without requiring programmer intervention. Those of you familiar with
35 the DBI will be right at home. Some of the designs come from the Java
36 JAXP specification (SAX part), only without the javaness.
37
38 %description -l pl.UTF-8
39 XML::SAX składa się z kilku klas tworzących szkielet do używania i
40 budowania parserów, filtrów i sterowników SAX2 XML w Perlu. Zadaniem
41 modułu jest umożliwienie włączania różnych parserów SAX do aplikacji
42 bez udziału programisty. Znający moduły DBI będą się czuli jak w domu.
43 Niektóre koncepcje pochodzą ze specyfikacji Java JAXP (część SAX), ale
44 bez javowości.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p1
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62 touch $RPM_BUILD_ROOT%{perl_vendorlib}/XML/SAX/ParserDetails.ini
63
64 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/XML/SAX/Intro.pod
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 umask 022
71 touch %{perl_vendorlib}/XML/SAX/ParserDetails.ini
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/XML/SAX.pm
77 %{perl_vendorlib}/XML/SAX/DocumentLocator.pm
78 %{perl_vendorlib}/XML/SAX/ParserFactory.pm
79 %{perl_vendorlib}/XML/SAX/PurePerl.pm
80 %{perl_vendorlib}/XML/SAX/PurePerl
81 %ghost %{perl_vendorlib}/XML/SAX/ParserDetails.ini
82 %{_mandir}/man3/XML::SAX.3pm*
83 %{_mandir}/man3/XML::SAX::DocumentLocator.3pm*
84 %{_mandir}/man3/XML::SAX::Intro.3pm*
85 %{_mandir}/man3/XML::SAX::ParserFactory.3pm*
86 %{_mandir}/man3/XML::SAX::PurePerl*.3pm*
This page took 0.078542 seconds and 4 git commands to generate.