]> git.pld-linux.org Git - packages/perl-XML-LibXML-Iterator.git/blob - perl-XML-LibXML-Iterator.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-LibXML-Iterator.git] / perl-XML-LibXML-Iterator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    LibXML-Iterator
7 Summary:        XML::LibXML::Iterator - XML::LibXML's Tree Iteration Class
8 Summary(pl.UTF-8):      XML::LibXML::Iterator - klasa iteratora dla drzew XML::LibXML
9 Name:           perl-XML-LibXML-Iterator
10 Version:        1.04
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bcbf474656bd4e1a1939c2459ca91ac1
17 URL:            http://search.cpan.org/dist/XML-LibXML-Iterator/
18 %if %{with tests}
19 BuildRequires:  perl-XML-LibXML >= 1.52
20 BuildRequires:  perl-XML-NodeFilter
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-XML-LibXML >= 1.52
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 XML::LibXML::Iterator implements the iterator part of the DOM
30 Traversal and Range specification. This class allows to iterate
31 through a DOM as it is done through an ordinary array.
32
33 %description -l pl.UTF-8
34 XML::LibXML::Iterator implementuje część dotyczącą iteratora ze
35 specyfikacji "DOM Traversal and Range". Klasa ta pozwala na
36 przemieszczanie po DOM tak, jak po zwykłej tablicy.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %dir %{perl_vendorlib}/XML/LibXML
61 %{perl_vendorlib}/XML/LibXML/Iterator.pm
62 %{perl_vendorlib}/XML/LibXML/NodeList
63 %{_mandir}/man3/*
This page took 0.080061 seconds and 4 git commands to generate.