]> git.pld-linux.org Git - packages/perl-WebFetch.git/blob - perl-WebFetch.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-WebFetch.git] / perl-WebFetch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    WebFetch
6 Summary:        WebFetch - Perl module to download and save information from the Web
7 Summary(pl.UTF-8):      WebFetch - moduł Perla do ściągania i zapisywania informacji z WWW
8 Name:           perl-WebFetch
9 Version:        0.13
10 Release:        3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/I/IK/IKLUFT/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  c06a23ec6f9762d92c3510c685b1112e
16 URL:            http://search.cpan.org/dist/WebFetch/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Locale::Country)
21 BuildRequires:  perl-Class-ISA
22 BuildRequires:  perl-DB_File
23 BuildRequires:  perl-Date-Calc
24 BuildRequires:  perl-Exception-Class
25 BuildRequires:  perl-HTML-Parser
26 BuildRequires:  perl-Template-Plugin-XML-XPath
27 BuildRequires:  perl-Test-Pod-Coverage
28 BuildRequires:  perl-XML-Atom
29 BuildRequires:  perl-XML-Parser
30 BuildRequires:  perl-XML-RSS
31 BuildRequires:  perl-libwww
32 %endif
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 WebFetch - infrastructure for downloading ("fetching") information
38 from various sources around the Internet or the local system in order
39 to present them for display, or to export local information to other
40 sites on the Internet.
41
42 %description -l pl.UTF-8
43 Moduł WebFetch - infrastruktura do ściągania informacji z różnych
44 źródeł w całym Internecie lub z lokalnego systemu w celu wyświetlenia
45 lub eksportu informacji na inne serwisy internetowe.
46
47 %prep
48 %setup -q -n %{pdir}-%{version}
49
50 # Coverage for WebFetch::Output::TWiki is 0.0%, with 5 naked subroutines
51 %{__sed} -i -e '/WebFetch::Output::TWiki/d' t/pod-coverage.t
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Embedding_API.pod README TODO
72 %{perl_vendorlib}/*.pm
73 %{perl_vendorlib}/WebFetch
74 %{_mandir}/man3/*
This page took 0.092284 seconds and 4 git commands to generate.