]> git.pld-linux.org Git - packages/perl-WWW-Mechanize.git/blob - perl-WWW-Mechanize.spec
- updated URL, BR: perl-Path-Tiny
[packages/perl-WWW-Mechanize.git] / perl-WWW-Mechanize.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    WWW
6 %define         pnam    Mechanize
7 Summary:        WWW::Mechanize - automate interaction with websites
8 Summary(pl.UTF-8):      WWW::Mechanize - automatyzacja interakcji ze stronami WWW
9 Name:           perl-WWW-Mechanize
10 Version:        2.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/WWW/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6e269687c5f5a9400fdf256e593756bc
17 URL:            https://metacpan.org/dist/WWW-Mechanize
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Encode
23 BuildRequires:  perl-HTML-Form >= 1.00
24 BuildRequires:  perl-HTML-Parser >= 3.33
25 BuildRequires:  perl-HTML-Tree >= 5
26 BuildRequires:  perl-HTTP-Cookies
27 BuildRequires:  perl-HTTP-Daemon >= 6.12
28 BuildRequires:  perl-HTTP-Message >= 1.30
29 BuildRequires:  perl-HTTP-Server-Simple
30 BuildRequires:  perl-Path-Tiny
31 BuildRequires:  perl-Scalar-List-Utils >= 1.14
32 BuildRequires:  perl-Sub-Uplevel >= 0.13
33 BuildRequires:  perl-Test-Deep
34 BuildRequires:  perl-Test-Exception
35 BuildRequires:  perl-Test-Fatal
36 BuildRequires:  perl-Test-Memory-Cycle >= 1.06
37 BuildRequires:  perl-Test-NoWarnings >= 1.04
38 BuildRequires:  perl-Test-Output
39 BuildRequires:  perl-Test-Simple >= 0.96
40 BuildRequires:  perl-Test-Taint >= 1.08
41 BuildRequires:  perl-Test-Warn
42 BuildRequires:  perl-Test-Warnings
43 BuildRequires:  perl-URI
44 BuildRequires:  perl-libwww >= 6.45
45 %endif
46 Requires:       perl-Encode
47 Requires:       perl-libwww >= 6.45
48 BuildArch:      noarch
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 WWW::Mechanize, or Mech for short, was designed to help you automate
53 interaction with a website. It supports performing a sequence of page
54 fetches including following links and submitting forms. Each fetched
55 page is parsed and its links and forms are extracted. A link or a form
56 can be selected, form fields can be filled and the next page can be
57 fetched. Mech also stores a history of the URLs you've visited, which
58 can be queried and revisited.
59
60 %description -l pl.UTF-8
61 Moduł Perla WWW::Mechanize, w skrócie Mech, został zaprojektowany, aby
62 ułatwić automatyzację interakcji ze stronami WWW. Wspiera on
63 wykonywanie szeregu kolejnych pobrań stron, włączając w to podążanie
64 za odnośnikami i odsyłanie formularzy. Każda z pobranych stron jest
65 przetwarzana i wydzielane są z niej odnośniki i formularze. Można
66 wybrać odnośnik lub formularz, wypełnić pola formularza i pobrać
67 następną stronę. Mech przechowuje również historię odwiedzanych URL-i,
68 o które można odpytać i je ponownie odwiedzić.
69
70 %prep
71 %setup -q -n %{pdir}-%{pnam}-%{version}
72
73 %build
74 echo 'y' | %{__perl} Makefile.PL \
75         INSTALLDIRS=vendor
76 %{__make}
77
78 %{?with_tests:%{__make} test}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/WWW/Mechanize/{FAQ,Cookbook,Examples}.pod
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc Changes
94 %attr(755,root,root) %{_bindir}/mech-dump
95 %{perl_vendorlib}/WWW/Mechanize.pm
96 %dir %{perl_vendorlib}/WWW/Mechanize
97 %{perl_vendorlib}/WWW/Mechanize/*.pm
98 %{_mandir}/man1/mech-dump.1p*
99 %{_mandir}/man3/WWW::Mechanize*.3pm*
This page took 0.1292 seconds and 4 git commands to generate.