]> git.pld-linux.org Git - packages/perl-WWW-Form-UrlEncoded.git/blob - perl-WWW-Form-UrlEncoded.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-WWW-Form-UrlEncoded.git] / perl-WWW-Form-UrlEncoded.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    WWW
6 %define         pnam    Form-UrlEncoded
7 Summary:        WWW::Form::UrlEncoded - parser and builder for application/x-www-form-urlencoded
8 Name:           perl-WWW-Form-UrlEncoded
9 Version:        0.26
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/WWW/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  cbe0e1c3ee54738d900c739ea348efda
16 URL:            http://search.cpan.org/dist/WWW-Form-UrlEncoded/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-JSON >= 2
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 WWW::Form::UrlEncoded provides application/x-www-form-urlencoded
28 parser and builder. This module aims to have compatibility with other
29 CPAN modules like HTTP::Body's urlencoded parser.
30
31 This module try to use WWW::Form::UrlEncoded::XS by default and fail
32 to it, use WWW::Form::UrlEncoded::PP instead
33
34 WWW::Form::UrlEncoded parsed string in this rule.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         --destdir=$RPM_BUILD_ROOT \
42         --installdirs=vendor
43 BREAK_BACKWARD_COMPAT=1 ./Build
44
45 %{?with_tests:BREAK_BACKWARD_COMPAT=1 ./Build test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 BREAK_BACKWARD_COMPAT=1 ./Build install
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %dir %{perl_vendorlib}/WWW/Form
62 %{perl_vendorlib}/WWW/Form/*.pm
63 %{perl_vendorlib}/WWW/Form/UrlEncoded
64 %{_mandir}/man3/WWW::Form::UrlEncoded*.3*
65 %{_examplesdir}/%{name}-%{version}
This page took 0.072293 seconds and 4 git commands to generate.