]> git.pld-linux.org Git - packages/perl-Version-Requirements.git/blob - perl-Version-Requirements.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Version-Requirements.git] / perl-Version-Requirements.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Version
6 %define         pnam    Requirements
7 Summary:        Version::Requirements - a set of version requirements for a CPAN dist
8 Summary(pl.UTF-8):      Version::Requirements - zbiór wersjonowanych wymagań dla dystrybucji CPAN
9 Name:           perl-Version-Requirements
10 Version:        0.101023
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0ceebafa26543bbe8cc9a035d0612cac
17 URL:            http://search.cpan.org/dist/Version-Requirements/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Scalar-List-Utils
23 BuildRequires:  perl-Test-Simple >= 0.96
24 BuildRequires:  perl-version >= 0.77
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 A Version::Requirements object models a set of version constraints
31 like those specified in the META.yml or META.json files in CPAN
32 distributions. It can be built up by adding more and more constraints,
33 and it will reduce them to the simplest representation.
34
35 Logically impossible constraints will be identified immediately by
36 thrown exceptions.
37
38 Note: this module is DEPRECATED, use CPAN::Meta::Requirements instead.
39
40 %description -l pl.UTF-8
41 Obiekt Version::Requirements modeluje zbiór wersjonowanych wymagań,
42 jak te podawane w plikach META.yml lub META.json w dystrybucjach CPAN.
43 Może być tworzony w oparciu o dodawanie kolejnych ograniczeń, a on
44 zredukuje je do najprostszej postaci.
45
46 Logicznie wykluczające się ograniczenia są natychmiast zgłaszane przez
47 rzucenie wyjątku.
48
49 Uwaga: ten moduł jest PRZESTARZAŁY, zamiast niego lepiej używać
50 CPAN::Meta::Requirements.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} pure_install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %dir %{perl_vendorlib}/Version
75 %{perl_vendorlib}/Version/Requirements.pm
76 %{_mandir}/man3/Version::Requirements.3pm*
This page took 0.065255 seconds and 4 git commands to generate.