]> git.pld-linux.org Git - packages/perl-Unicode-UTF8simple.git/blob - perl-Unicode-UTF8simple.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Unicode-UTF8simple.git] / perl-Unicode-UTF8simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Unicode
6 %define pnam    UTF8simple
7 Summary:        Unicode::UTF8simple - Conversions to/from UTF-8 from/to character sets
8 Summary(pl.UTF-8):      Unicode::UTF8simple - konwersje do/z UTF-8 z/do różnych zestawów znaków
9 Name:           perl-Unicode-UTF8simple
10 Version:        1.06
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1d90907170ed41690a572a2d6ed6e7da
17 URL:            http://search.cpan.org/dist/Unicode-UTF8simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides UTF-8 conversion for Perl versions from 5.00 and up.
25 It was mainly written for use with Perl 5.00 to 5.6.0 because
26 those Perl versions do not support Unicode::MapUTF8 or Encode.
27
28 Unicode::UTF8simple is written in plain Perl (no C code) and will
29 work with any Perl 5 version. It is just slightly slower than
30 Encode.
31
32 %description -l pl.UTF-8
33 Ten pakiet udostępnia funkcję do konwersji UTF-8 dla wersji Perla
34 począwszy od 5.00. Został napisany głównie do używania z perlem od
35 5.00 do 5.6.0, jako że te wersje Perla nie obsługują Unicode::MapUTF8
36 i Encode.
37
38 Unicode::UTF8simple jest napisany w czystym Perlu (bez kodu w C) i
39 będzie działać z dowolną wersją Perla 5. Jest tylko trochę wolniejszy
40 niż Encode.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README
64 %{perl_vendorlib}/Unicode/*.pm
65 %{_mandir}/man3/*
This page took 0.095077 seconds and 4 git commands to generate.