]> git.pld-linux.org Git - packages/perl-Unicode-MapUTF8.git/blob - perl-Unicode-MapUTF8.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Unicode-MapUTF8.git] / perl-Unicode-MapUTF8.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    MapUTF8
7 Summary:        Unicode::MapUTF8 - conversions to and from arbitrary character sets and UTF8
8 Summary(pl.UTF-8):      Unicode::MapUTF8 - konwersje między dowolnym zestawem znaków a UTF8
9 Name:           perl-Unicode-MapUTF8
10 Version:        1.11
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  16e66ee0bdc0e6cc9c36e29212d8ffdc
17 URL:            http://search.cpan.org/dist/Unicode-MapUTF8/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Jcode
21 BuildRequires:  perl-Unicode-Map
22 BuildRequires:  perl-Unicode-Map8
23 BuildRequires:  perl-Unicode-String
24 %endif
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Unicode::MapUTF8 provides an adapter layer between core routines for
31 converting to and from UTF8 and other encodings. In essence, a way to
32 give multiple existing Unicode modules a single common interface so
33 you don't have to know the underlaying implementations to do simple
34 UTF8 to-from other character set encoding conversions. As such, it
35 wraps the Unicode::String, Unicode::Map8, Unicode::Map and Jcode
36 modules in a standardized and simple API.
37
38 %description -l pl.UTF-8
39 Unicode::MapUTF8 udostępnia warstwę pośrednią pomiędzy wewnętrznymi
40 funkcjami do konwersji pomiędzy UTF8 a innymi kodowaniami. W
41 szczególności jest sposobem na udostępnienie wielu istniejącym modułom
42 Unicode wspólnego interfejsu, dzięki czemu nie trzeba znać
43 implementacji każdego modułu do zastosowania prostej konwersji z/do
44 UTF8. Unicode::MapUTF8 opakowuje moduły Unicode::String,
45 Unicode::Map8, Unicode::Map i Jcode w ustandaryzowane i proste API.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Unicode/MapUTF8.pod
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README
71 %{perl_vendorlib}/%{pdir}/*.pm
72 %{_mandir}/man3/*
This page took 0.082374 seconds and 4 git commands to generate.